• Can't even drop into a tty


    Hi,

    A couple days ago, on my laptop, I upgraded a bunch of packages; kernel being one of them. For some reason, the update didn’t go through before the laptop died, and thus I started getting the black screens after login. (Gnome 3)

    I had come across this before; just drop into tty, clean some files to unlock your gnome session and back to business. However, things were apparently more complicated this time, I got a bunch of nouveau errors (expected, I’d re-install packages if I could get in) and a “lspcon” error.

    I saw that the newest nouveau drivers are now compatible with mu GPU, and thus installed antergos-17.12-x86_64.iso to clean the slate. After that installation, nothing changed. Gnome still got to the login screen, didn’t allow me to ctrl+alt+f2, and whatever happened, froze after awhile.

    Then I read somewhere that antergos-minimal-17.12-x86_64.iso doesn’t require HW accelerated graphics, so I decided to try that one. With this one, I can’t even launch Live.

    I get to the tty which antergos uses for temp login. Again, a bunch of things fail to init, and lastly I get; “waited i915.ko driver for n seconds.” And then it’s an Xserver fatal error This goes on in a loop.

    At this point, I’ve been bash’ing my head against this all weekend, and am out of ideas. Please help me at least get to a functioning tty.

    p.s. GPU: GTX1050 Ti - have 1TB HDD and 128 SSD in the same box, tried these operations only on the SSD. I just mount the HDD and use it as a downloads folder, so I don’t think formatting that one is necessary.

  • this looks like optimus / bumblebee problem?
    Do you have hybrid graphics? intel + nvidia ???

    lspci -vnn | grep '\''[030[02]]'
    

    will show the two cards…

    Do a good read here:

    https://antergos.com/wiki/hardware/bumblebee-for-nvidia-optimus/

    It seems that this hybrid cards conflicting if bumblebee is not set up, possible is also to take a look into BIOS/EFI to configure the way two graphic cards are used…may you can control them and disable one of to get a clean boot on only one card.

    And for sure !!! feel very welcome at Antergos Forum!

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad

    I can’t get to a shell currently. I could (at some time) boot the full live .iso. I’ll try installing from that and run lspci.

    My previous (working) installation was from here. That one with the proprietary drivers worked. Now I think I can get full compat with the open source release. Am I correct?

    Just went over the BIOS setup - no mention of nvidia or any graphics card.

  • I am maintaining the nvidia ISO.
    I have done a newer version, aviable over
    My website http://kamprad.net/Downloads/Antergos-Nvidia-ISO/antergos-nvidia-17.12-x86_64.iso
    As it may boot fine for you.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad

    I am currently getting that .iso you linked.

    I also tried antergos-nvidia-RADICAL-17.11-x86_64.iso, before I tried thoroughly the official one. That didn’t solve the issue, as well. My working image was antergos-nvidia-17.9-2-x86_64.iso.

    I will report what happens with this one.

  • @joekamprad

    I went through the install process with no glitch.

    I can get to a shell through the Antergos Fallback option.

    Before I start fumbling my way through the process, can you tell me how I should approach this? What are the logs you need to look at?

  • @doruk said in Can't even drop into a tty:

    I went through the install process with no glitch.

    no logs needed f installation went fine… you need to show if you have hybrid graphics (optimus) by give the output of this command:
    lspci -vnn | grep '\''[030[02]]'

    or autopasting to a pastebin:

    lspci -vnn | grep '\''[030[02]]' | curl -F [email protected] https://ptpb.pw/?u=1

    will give you a short url may more easy to write it down here…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • if you get two cards out of this start installing bumblebee:

    sudo pacman -S nvidia-installer
    sudo nvidia-installer -b
    

    then follow up with the wiki:

    https://antergos.com/wiki/hardware/bumblebee-for-nvidia-optimus/#Add_yourself_to_bumblebee_group

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • That worked. Everything looks OK.

    Thanks for saving me a few gray hairs.

    p.s. Could not curl. I got this with the command you supplied: “SSL: no alternative cert subject name matches target gost ptpb.com”. I then tried again with the -kF flag and this time got errno 104 from openssl.

  • have fun with Antergos!!!

    SSL: no alternative cert subject

    You are behind proxy or using vpn?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Nope.

    But my country (TR) has a mini firewall of china in place, so maybe that?

    Disregard that. I was writing .com instead of .pw :)

    Cheers,
    -d

  • @joekamprad said in Can't even drop into a tty:

    lspci -vnn | grep ‘’’[030[02]]’ | curl -F [email protected] https://ptpb.pw/?u=1

    lspci -vnn | grep '\''[030[02]]' | curl -F [email protected] https://ptpb.com/\?u\=1
    curl: (51) SSL: no alternative certificate subject name matches target host name 'ptpb.com'
    

    https://www.ptps.com/cart/

    yea do not look like they want pastebins on there side ;)

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

Posts 12Views 221
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.