• Cinnamon - is currently running without video hardware acceleration

    Hi all,

    I’m running into an odd issue with Antergos Cinnamon where I can’t seem to get my Nvidia drivers running properly. When I boot I receive an error that Cinnamon is running in software rendering mode. I have a Nvidia 780ti graphics card.

    //$ lspci | grep VGA
    01:00.0 VGA compatible controller: NVIDIA Corporation GK110 [GeForce GTX 780] (rev a1)

    I have the 387 driver installed

    //$ nvidia-smi
    Sun Dec 17 23:58:56 2017       
    | NVIDIA-SMI 387.34                 Driver Version: 387.34                    |
    | GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
    | Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
    |   0  GeForce GTX 780     Off  | 00000000:01:00.0 N/A |                  N/A |
    | 37%   27C    P8    N/A /  N/A |     94MiB /  3017MiB |     N/A      Default |
    | Processes:                                                       GPU Memory |
    |  GPU       PID   Type   Process name                             Usage      |
    |    0                    Not Supported                                       |

    I ran nvidia-xserver to generage xorg.conf. I have tried installing the 340xxx driver(and utils and lib32, etc. Uninstalled everything associated with 387), to no avail. I made sure that nvidia-libgl and lib32-nvidia-utils are installed. I have completely uninstalled the nvidia drivers, rebooted to a cli terminal and re-installed them. I wanted to swap from noveau because I was having serious performance issues with games(CS:GO and Civ6 in particular). These are games that I was able to play without issue in Ubuntu and Arch(CS:GO only - Civ6 wasn’t out) previously with the proprietary drivers.

    I’m not sure where to troubleshoot from here - any help would be appreciated

  • @bruenor80 how do you install nvidia drivers?
    can you post the output of:

    ls /etc/X11/xorg.conf.d

    you may try to install nvidia driver with our handy installer:

    sudo pacman -S nvidia-installer
    nvidia-installer -t

    if it gives no erroro message you can do the real install:

    sudo nvidia-installer
  • Thanks for the reply!

    //$ ls /etc/X11/xorg.conf.d/
    00-keyboard.conf  20-nvidia.conf  50-synaptics.conf  99-killX.conf

    I ran the nvidia-installer as you suggested, it didn’t give any errors so ran the real install.

    //nvidia-installer -t
    2017-12-18 20:47:31 [INFO]: Antergos Nvidia Installer v1.12
    2017-12-18 20:47:31 [INFO]: All logs will be stored in /tmp/nvidia-installer.log
    2017-12-18 20:47:31 [INFO]: Running the installer in testing mode...
    2017-12-18 20:47:31 [INFO]: Installing nvidia driver...
    2017-12-18 20:47:31 [INFO]: Removing conflicting packages...
    2017-12-18 20:47:31 [INFO]: Downloading and installing driver packages, please wait...
    2017-12-18 20:47:31 [INFO]: pacman -Sqy --noconfirm --noprogressbar nvidia libvdpau lib32-nvidia-utils lib32-libvdpau
    2017-12-18 20:47:31 [INFO]: Disabling bumblebeed.service service...
    2017-12-18 20:47:31 [INFO]: systemctl disable bumblebeed.service
    2017-12-18 20:47:31 [INFO]: Unpatching /usr/share/applications/nvidia-settings.desktop...
    2017-12-18 20:47:31 [INFO]: sed -i s|Exec=optirun -b none /usr/bin/nvidia-settings -c :8|Exec=/usr/bin/nvidia-settings| /usr/share/applications/nvidia-settings.desktop
    2017-12-18 20:47:31 [INFO]: Creating /etc/X11/xorg.conf.d/20-nvidia.conf file...
    2017-12-18 20:47:31 [INFO]: Installation finished. Nothing has been modified as testing mode was ON.

    I’m still seeing the same error upon boot.

  • @bruenor80 said in Cinnamon - is currently running without video hardware acceleration:

    I ran nvidia-xserver to generage xorg.conf

    do you remove this not needed file from nvidia-xconfig already?

  • @joekamprad

    Yes, I did…I ran into an older arch forum thread with a similar issue that was resolved by running that and didn’t realize it wasn’t needed anymore until later. I actually got it working late last night by booting to a terminal(multi-user target) and uninstalling everything to do with Nvidia and re-installing with the nvidia-installer that you recommended. Everything was working great on the reboot. Thanks for the help!

  • thats good to hear!

    Great to be helpfull, for you! And have fun with Antergos!

cinnamon93 video41 running20 currently2 Posts 6Views 5257
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.