• Updating issue with libkexiv2 dependencies


    Hi there,

    I’m quite new in Antergos and Arch Linux and today I’ve got an issue while updating the OS.
    It looks like it’s not possible to update the “libkexiv2” library from 17.08.3-1 to 17.12.0-1 because the updating will remove the ‘kdenetwork-kopete’ and ‘kdeutils-sweeper’ required by ‘antergos-kde-meta’.
    I’m thinking to remove the ‘antergos-kde-meta’ package, but I’m not sure it is a good idea.
    Any other solution?

    Please, can anyone help me?
    Thanks, Francesco!

    0_1513519763730_2017.12.17 - Updating Issue - Screenshot_20171217.jpeg

  • @francesco-ntrgs said in Updating issue with libkexiv2 dependencies:

    update the “libkexiv2” library from 17.08.3-1 to 17.12.0-1 because the updating will remove the ‘kdenetwork-kopete’ and ‘kdeutils-sweeper’ required by ‘antergos-kde-meta’.

    this have to go to @developers

  • @francesco-ntrgs said in Updating issue with libkexiv2 dependencies:

    I’m thinking to remove the ‘antergos-kde-meta’ package, but I’m not sure it is a good idea

    you can do this, and reinstall after update…

  • I have the same problem. Removing antergos-kde-meta did not help

  • antergos-meta doesn t seem to be installed (checked it via pamac).
    So, it is the antergos-kde-setup that should have to be uninstalled. Since, I don t have the antergos-kde-setup installed myself, I did a test in a secondary machine of mine and it just worked (by the way, you can re-install antergos-kde-set-up at any time should you think you need it).
    After uninstalling it, you ll see that kdeutils-sweeper 17.08.3-1 will be replaced with sweeper 17.12.0-1 & kdenetwork-kopete 17.08.3-1 with kopete 17.08.3-1.
    Cheers

  • That seems to work. Thank you!
    A note for other users: It is important that the setting “remove unneeded dependencies” is disabled. Otherwise, removing the package antergos-kde-setup removes half the system! ;)

  • @anarch Had the same problem and removing both antergos-kde-setup and antergos-kde-meta were required to make the 53 updates install.

    FYI (not that you have anything to do with it): I spent quite some time deselecting updates, and it did not matter which ones I deselected, on every single one, even when only one update was selected, it always popped up the message that the install would break kdenetwork-kopete and kdeutils-sweeper, including the updates that are not even related to KDE in any way, like ARK, the kernal…

    I can only assume that the problem lies elsewhere.

  • I had the same problem. anarch’s solution worked for me, too. thanks, anarch

  • Two issues, package is named antergos-kde-setup. I was able to uninstall this package then upgrade pacman -R antergos-kde-setup , and pacman -Syyu. But I still cannot reinstall antergos-kde-setup , i get the following

    pacman -S antergos-kde-setup
    resolving dependencies...
    warning: cannot resolve "kdenetwork-kopete", a dependency of "antergos-kde-setup"
    warning: cannot resolve "kdeutils-sweeper", a dependency of "antergos-kde-setup"
    :: The following package cannot be upgraded due to unresolvable dependencies:
          antergos-kde-setup
    
    :: Do you want to skip the above package for this upgrade? [y/N]
    

    Maybe in a couple days this will resolve itself…

    Nz

  • If you look in the main repo, you can see antergos-kde-setup is still at version 1.0.3, but the pull request that closed that issue fixes it in version 1.1-4.

    The main repo just needs a fixed package to be built, as you can see that the last time it was built was in 2017-10-08

  • @sum1 antergos-kde-setup is still at 1.0-3 and I’m also getting the following error:

    warning: cannot resolve "kdenetwork-kopete", a dependency of "antergos-kde-setup"
    warning: cannot resolve "kdeutils-sweeper", a dependency of "antergos-kde-setup"
    :: The following package cannot be upgraded due to unresolvable dependencies:
          antergos-kde-setup
    
    :: Do you want to skip the above package for this upgrade? [y/N]
    

    Is there a timeline for when the fixed version will be released I can find somewhere?

  • @evaljim
    Hi!
    Seems that KDE setup has changed…

    Just a moment ago I installed Antergos KDE using the newest ISO 18.1.
    By default it does not have package antergos-kde-setup installed, but antergos-kde-meta instead.

    Also package kdenetwork-kopete does not exist, instead an AUR package kdenetwork-kopete-git is there. Package kdeutils-sweeper does not exist at all, and I couldn’t find anything from AUR either (but maybe sweeper ?).

  • @manuel said in Updating issue with libkexiv2 dependencies:

    Seems that KDE setup has changed…

    Without seems, KDE setup is changed.

    You’re right. Until December 2017 Antergos KDE was set up by one meta package - antergos-kde-setup. Starting from December 2017, al DEs are set up by one antergos-[DEname]-meta meta package. As you correctly notice, KDE is set up by antergos-kde-meta now.

    Older than December 2017 KDE installations still suffer from this change. The old antergos-kde-setup seems to be abandoned, the new antergos-kde-meta doesn’t apply to them.

    Systems, installed by one meta package, are very rigid. It is hard to deal with them for less skilled users.

    @evaljim said in Updating issue with libkexiv2 dependencies:

    antergos-kde-setup is still at 1.0-3 and I’m also getting the following error:…

    Two possible workarounds to solve the issue were proposed a month ago here. Both still work.

    A deeper explanation.

    At the time, when antergos-kde-setup meta package was created, two packages - kdenetwork-kopete and kdeutils-sweeper also existed in Arch. There were no problems with them.

    At the begining of December 2017 the kdenetwork-kopete and kdeutils-sweeper packages were modified upstream, and became extra/kopete and extra/sweeper. Two old kdenetwork-kopete and kdeutils-sweeper packages were disappeared.

    It doesn’t cause any problem in flexible systems, i.e., not installed by one meta package. In meta-packaged systems it may cause a big problem, if the meta package doesn’t adjusted in time accordingly. Like in this case.

    antergos-kde-setup remains not adjusted to new kopete and sweeper names and location in the Arch repo. Until unmodified antergos-kde-setup is present in the system, it will continue to insist to install not exsting kdenetwork-kopete and kdeutils-sweeper packages.

    The new antergos-kde-meta simply installs two new extra/kopete and extra/sweeper packages.

  • Thank you @manuel and @just 🙏

    I ended up trying kde on my Ubuntu install last night and hated it, but I really appreciate your help and I’m sure others coming upon this thread will too.

    I’m getting progressively closer to making the switch to Antergos full time. I think the community alone makes it worth giving up some of the out-of-the-box convenience of Ubuntu :)

    Cheers!

  • Thanks @just I installed the antergos-kde-meta and it has resolved my issues.

    @evaljim KDE is the only DE I like for my desktop computer, I am curious to try Gnome again since I haven’t used it in many years… On my laptop I use deepin - but I still installed dolphin and kate because I use those almost unconsciously now. I switched from Sabayon (Gentoo based) to Antergos recently (mostly out of curiosity, although there seems to be more packages directly available). Good luck with your switch !

    Nz

  • @notzippy I’m a coder so I usually have my hands on the keyboard rather than the mouse. I have to remember lots of keyboard shortcuts for my IDE, so my brain and muscle memory are much quicker at that than clicking stuff. Gnome3 supports keyboard control beautifully. It’s almost completely invisible (apart from the top status bar which I find super useful with it’s notifications, time, network status etc.) until I want it. I even remove the dock. I used Alfred heavily on Mac before I made the switch to Linux, so the Super-key then type what you want workflow is very familiar and productive for me. I also love the keyboard shortcuts for window management (super+arrow-keys to move windows around). Little touches like the way you can resize both windows simultaneously when you have two arranged left and right are awesome.

    I personally found KDE to be too, um, present. It seemed to me to be all about the widgets, with complicated menus all over the place. I don’t access my settings often, and when I do I prefer to do so via a few key strokes that open a dedicated dialog. I also found it a little old looking despite trying a couple of popular themes. I understand it’s crazy customisable though, so I’m sure it can look beautiful with a little effort.

    That said, I love that Linux gives us this breadth of choice and I can totally see why many people love KDE. I have to say I find the amount of public hate for Gnome3 a bit surprising though. I understand it was released a bit too soon and alienated people in the early days, but I feel like it’s maybe become trendy in the community to hate on it? I’ve also heard people complaining about performance issues, but I’m running it on a fully loaded XPS 15 with 32Gb of RAM so I find it incredibly responsive.

    What are your reasons for loving KDE?

  • @evaljim thanks for this “good words” on GNOME, this is exactly why i likeed GNOME3 from its beginning! It goes out of the way and gives easy access to settings, and allow a real ergonomic workflow!

  • @evaljim I am a coder as well (maintainer for github.com/revel), but the only Global DE shortcuts I use is the shortcut to activate yakuake, switch windows, activate quick launch and play music. When my code is running I use docked flyouts to view processor usage / disk usage and such. I use a trackball for most of my navigation across screens (I am surprised at the number of people still using mice). Dolphin has to be the best file manager I have ever used, for flexibility and seamless access to remote files. To be honest I dont use a lot of the features in KDE like the “activites” which allows you to setup different desktops (not workspaces) so you can customize a activity to a task. I do like the activity bar as well in the KDE, being able to stack windows (like opened chrome instances) on a single spot, and begin able to ctrl click the stack to see all the open windows in a scaled format, so that none overlap, and any can be closed without leaving this view is another sweet spot for me (sometimes my browser and file manager sessions get a little out of control)…

    I think any DE takes a bit of time getting used to but there are perks to all of them - nice that antergros gives us maximum flexibility on that front.

    Every find that browsers are like DE ? firefox, chrome, vivaldi all have their own quirks… (I am getting to like vivaldi more now though…)

    Nz

  • @notzippy Thanks for the insight!

    I’ve been meaning to try a trackball. As an ex Apple user I was spoiled by the superb trackpads on their laptops for many years. Maybe now is the time.

    I do agree with your browser comment. I used to be a die hard Firefox and Mozilla supporter, but since switching to Chrome / Chromium I just can’t go back.

    Vivaldi does sound good though - I love that it’s built using web tech like Gnome 3.

    Enjoy your setup :)

Posts 20Views 3677
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.