• Freeze on exiting and with some scripts


    Hi

    It has been going on for some weeks now. My Lenovo laptop freezes before exiting either after poweroff, shutdown or reboot. I can stop it uncleanly with

    sudo poweroff -f
    

    It suspends quite well.
    This is a log text that I found after another freeze. when trying to obtain info with

    lspci > log.txt && lsusb >> log.txt && dmesg >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1
    

    It did not complete this command and reported one error for the curl part of it.

    https://pastebin.com/gpwSYSy8

    It also froze severely when I tried to execute

    sudo nvidia-installer -f
    

    This is a previous report of inxi -Fx (now I have 4.14.5-1-ARCH, everything hardware related being the same)

    System:    Host: manjaro Kernel: 4.14.0-1-MANJARO x86_64 bits: 64 gcc: 7.2.0
               Desktop: N/A Distro: Manjaro Linux
    Machine:   Device: laptop System: LENOVO product: 80WW v: RESCUER R720-15IKBN serial: N/A
               Mobo: LENOVO model: LNVNB161216 v: SDK0L77769 WIN serial: N/A
               UEFI: LENOVO v: 4KCN30WW date: 08/31/2017
    Battery    BAT0: charge: 35.2 Wh 85.0% condition: 41.4/45.0 Wh (92%)
               model: SANYO L14S3P24 status: Discharging
    CPU:       Quad core Intel Core i7-7700HQ (-HT-MCP-) 
               arch: Skylake rev.9 cache: 6144 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22472
               clock speeds: max: 3800 MHz 1: 2800 MHz 2: 2800 MHz 3: 2800 MHz
               4: 2800 MHz 5: 2800 MHz 6: 2800 MHz 7: 2800 MHz 8: 2800 MHz
    Graphics:  Card-1: Intel Device 591b bus-ID: 00:02.0
               Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] bus-ID: 01:00.0
               Display Server: N/A driver: intel tty size: 80x24
    Audio:     Card Intel CM238 HD Audio Controller
               driver: snd_hda_intel bus-ID: 00:1f.3
               Sound: Advanced Linux Sound Architecture v: k4.14.0-1-MANJARO
    Network:   Card-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
               driver: ath10k_pci bus-ID: 03:00.0
               IF: wlp3s0 state: down mac: ...
               Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
               driver: r8168 v: 8.044.02-NAPI port: 3000 bus-ID: 04:00.0
               IF: enp4s0 state: up speed: 1000 Mbps duplex: full
               mac: ...
               Card-3: Qualcomm Atheros usb-ID: 001-004
               IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
    Drives:    HDD Total Size: 2128.4GB (0.6% used)
               ID-1: /dev/nvme0n1 model: SAMSUNG_MZVLW128HEGR size: 128.0GB
               ID-2: /dev/sda model: ST1000LM035 size: 1000.2GB
               ID-3: USB /dev/sdb model: External_USB_3.0 size: 1000.2GB
    Partition: ID-1: / size: 27G used: 5.6G (23%) fs: ext4 dev: /dev/nvme0n1p3
               ID-2: /home size: 27G used: 155M (1%) fs: ext4 dev: /dev/nvme0n1p4
               ID-3: swap-1 size: 6.29GB used: 0.00GB (0%)
               fs: swap dev: /dev/nvme0n1p2
    Sensors:   System Temperatures: cpu: 39.0C mobo: N/A
               Fan Speeds (in rpm): cpu: N/A
    Info:      Processes: 196 Uptime: 29 min Memory: 1064.9/7861.7MB
               Init: systemd Gcc sys: 7.2.0
               Client: Shell (bash 4.4.121) inxi: 2.3.43 
    

    I also have not been able to install Antergos with the live iso and succeeded only with the minimal install one.

  • @roger64 said in Freeze on exiting and with some scripts:

    It also froze severely when I tried to execute
    sudo nvidia-installer -f

    https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting

  • @roger64 said in Freeze on exiting and with some scripts:

    Graphics: Card-1: Intel Device 591b bus-ID: 00:02.0
    Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] bus-ID: 01:00.0

    If this is a bumblebee enabled notebook, you should give bumblebee a try, as it may is caused by doublegraphics combination that your system is freezing so often…

    https://antergos.com/wiki/de/hardware/bumblebee-for-nvidia-optimus/

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • this part of your log is showing a freeze caused by nouveau:

    [    6.739382] nouveau 0000:01:00.0: timeout
    [    8.740660] WARNING: CPU: 1 PID: 906 at drivers/gpu/drm/nouveau/nvkm/subdev/mmu/gf100.c:190 gf100_vm_flush+0x19e/0x1b0 [nouveau]
    

    https://pastebin.com/5zJu4pvj

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Thank you for your replies.

    As I had got these freezes from day one, without adding anything particular, I first hoped that some kernel update would sort it out. As nothing changed, I later suspected that these freezes could somewhat be related to nouveau and that’s why I will be trying to install the nvidia drivers.

    I shall first check this bumblebee question. Up to now I have no idea.

    thanks again

    • check bumblebee with the command
    • check bios/efi to see if it is possible to control graphics from this.
    • install needed software with sudo nvidia-installer -b
    • follow the steps for configuration
    • try if it works

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • I’ll do it, carefully. Nothing to lose. 🙂

    Thank you.

  • Hi this is to report full success. Install was a breeze and everything is working. A big thanks to Antergos and both of you.

      • I checked the BIOS. The entry graphic device let me toggle between [discrete] (already selected) and [UMA only]. I left unchanged.
        Discrete enable the integrated (here Intel) and discrete (here NVIDIA) graphic controller. System will choose graphic controller according to the user scenario.
        UMA only enable integrated graphic controller only. Windows XP need choose UMA only.
    [[email protected] roger]# nvidia-installer -b
    2017-12-17 17:02:29 [INFO]: Antergos Nvidia Installer v1.12
    2017-12-17 17:02:29 [INFO]: All logs will be stored in /tmp/nvidia-installer.log
    2017-12-17 17:02:29 [INFO]: Installing bumblebee driver...
    2017-12-17 17:02:29 [INFO]: Removing conflicting packages...
    2017-12-17 17:02:29 [INFO]: Downloading and installing driver packages, please wait...
    2017-12-17 17:04:43 [INFO]: Adding user roger to bumblebee group...
    2017-12-17 17:04:43 [INFO]: gpasswd -a roger bumblebee
    2017-12-17 17:04:43 [INFO]: Adding user roger to video group...
    2017-12-17 17:04:43 [INFO]: gpasswd -a roger video
    2017-12-17 17:04:43 [INFO]: Enabling bumblebeed.service service...
    2017-12-17 17:04:43 [INFO]: systemctl enable bumblebeed.service
    2017-12-17 17:04:43 [INFO]: Patching /usr/share/applications/nvidia-settings.desktop...
    2017-12-17 17:04:43 [INFO]: /etc/X11/xorg.conf.d/20-nvidia.conf not found. That's ok.
    2017-12-17 17:04:43 [INFO]: Installation finished. You need to reboot now!
    [[email protected] roger]# 
    
      • On reboot, everything is in perfect order. No more freeze for example when shutting down. Boot time goes from nearly 25 seconds (very long for a SSD) to some few seconds.

    I will also copy and paste this text to conclude as solved the other topic about GTX1050.

  • thanks for the flowers! and have much fun as you can out of your Antergos box !!!

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

freeze26 scripts6 exiting1 Posts 9Views 502
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.