• Dependency problems: python-distro (1.1.0-1) - python-distro<1.1.0'


    It seems that I can’t update the system anymome.
    I tried:
    sudo pacman-key --refresh-keys & sudo pacman -Syyu to no avail.

    If I try to update the system the following error message occurs: “:: conan: das Installieren von python-distro (1.1.0-1) verletzt Abhängigkeit von ‘python-distro<1.1.0’”

    What should I do to get rid of this problem?

    Thanks in advance.

  • pacman -Qqem | curl -F [email protected] https://ptpb.pw/?u=1
    

    To see all AUR packages, this “sehr wahrscheinlich” caused by an AUR build needing this package…
    If not you can simple uninstall old version sudo pacman -R python-distro update system and reinstall it—

  • @joekamprad

    The following aur-packages are needing this package:

    mendeleydesktop
    papirus-plasma-theme
    plex-media-player
    spotify
    trimage

    Deinstalling the package with -R wouldn’t work, I had to use -Rdd. I was able to update and the system runs fine again.

    Thank you for helping me out.

  • @joekamprad said in Dependency problems: python-distro (1.1.0-1) - python-distro<1.1.0':

    pacman -Qqem

    thats the reason why i asked before for this to see dependencies …

    Nice to be helpfull for you, and more nice to see pushing you in the right direction to find a solution on your own ;)

  • I also have this problem. Can anyone direct me on how to find the cause?

  • @giebels.to said in Dependency problems: python-distro (1.1.0-1) - python-distro<1.1.0':

    -Rdd

    To remove a package, which is required by another package, without removing the dependent package:

    pacman -Rdd package_name

    will remove the conflicting package and let you do the systemupdate, after succeeding with this reinstall package

  • @joekamprad
    To confirm:

    [[email protected] ~]$ pacman -Q python-distro
    python-distro 1.0.4-2
    
    

    So I need to

    pacman -Rdd python-distro
    

    then:

    pacman -Syu
    

    followed by:

    pacman -S python-distro
    

    Won’t this error the next time ‘conan’ tries to update because the python-distro dependency will be above the recommended version?

    Thank you,
    Ryan

  • dependencies of AUR builds needs to be solved with update this PKGBUILD by the user maintaining them, or you can do on your own.

    And your version is python-distro 1.0.4-2 so you miss updates for longer time?

dependency22 python-distro1 1.1.0-11 Posts 8Views 657
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.