• Forge for Minecraft

    I will skip any introduction and just get straight to the point: I can install Forge for Minecraft, but when I run it in the MC launcher it crashes, stating it ended with a bad state (exit code 1). This same thing occurred when I used Manjaro as well. I was unable to find anything online about this problem, so I am coming to the community forums to potentially receive assistance.

    When I try to install the universal version it says I am missing a few things, while the general-use installer does the install seemingly perfectly fine up until the part where MC crashes. I can run MC fine otherwise, but I would really like to play with Optifine and maybe a few mods. I haven’t played MC in at least two years, so I’d like to get it “moddable” again (I used Windows then). I would really appreciate any answers I could get!

    Also, if somebody provides answers and gives me commands to plug in, please explain what they do and how they do it if you know; I really want to learn as I go along. Thank you!

  • Download Recommended Installer (not windows) from here https://files.minecraftforge.net/ We are currently using 1.12.2 -

    Next open downloads folder and change permissions on downloaded file to allow executing the file as a program.
    alt text

    Right click on open space beside the file and select Open In Terminal

    In terminal become super user using su

    Enter your root password.

    run the file as root

    java -jar forge-1.12.2-

    Show the installer your .minecraft folder and select client.
    alt text

    Right click open space in your /home directory and select Open In Terminal

    su and enter pass to become super user (root)

    Set Minecraft folder permission recursively
    chmod 777 -R .minecraft

    Run Minecraft Launcher and select forge.

    upload launcher log to https://pastebin.com/ and link back here if you still have issues.

  • I was eventually able to figure it out and it now seems to work fine. Thank you a whole bunch for your help, Underclock! I really appreciate it.

  • @Aervec No problem. You can change the forum thread to solved if you’re satisfied.

  • @underclock Hey, I’m not OP but I could use some help too. When I do this, every terminal session I close after following the steps exactly say it’s still running and that closing it kills it, and I continue still not being able to launch forge.

    Forge terminal: https://pastebin.com/MhVv2z8x

    and .minecraft terminal:

    [[email protected] ~]$ su
    [[email protected] oof]# chmod 777 -R .minecraft
    [[email protected] oof]#

    regular minecraft works though


  • @Aervec Did you do anything different from what underclock said? I’m having the same issue that you were having

minecraft7 forge1 Posts 6Views 1413
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.