• Antergos doesn't boot on my HDD.

    Hi , I tried to install Antergos on my Acer VN7 nitro 592G.
    I have an ssd 960 Evo with Windows 10 installed on it and an HDD where i want to install Antergos 17.12.
    I disabled secure boot (with Ubuntu Mate it works also with secure boot enabled) and then I followed all the instructions . I choose the option that erase my hdd and install everything in the same place, without /home.
    When the installation ended , I tried to reboot my pc and it started running windows.
    Also if i try to open the boot menu with F12 and I set the HDD as first option , nothing change .
    PS: I noticed that in the boot menu, before the name of my HDD it’s written “Windows boot manager”.
    Maybe there is some issue dealing with Grub.
    If you need more information , please ask me. Thank you!

  • @cristhian.bruno9
    Hi, what is the output of terminal command
    lsblk -f
    You can do it by booting the installer and start a terminal.

  • On your Windows disk there is an ”ESP” partition in vfat format. You should have used that existing partition during Antergos installation for /boot/efi, but instead you created another partition for /boot/efi on the HDD. Was ESP invisible during installation?

  • @manuel I just didn’t think it was important ,so i let Antergos create for me all the partitions. I didn’t choose anything

  • Ok, so the installer wasn’t able to recognize the ESP partition correctly ( @developers ?).
    But now, I suggest you reinstall Antergos and use the existing ESP partition for /boot/efi (but do NOT format it!). Select manual partitioning for HDD instead of automatic, create a similar partitioning on HDD as the lsblk showed, but do not create that extra vfat partition. Hopefully that fixes the problem.
    But if your Windows disk is encrypted, this may not work.

  • @manuel So let me understand, I choose manual partitioning and then I can just format the actual partitions on the HDD, plus eliminate the efi partition on the HDD?
    Or I must eliminate partitions and restart everything from the beginning?
    And how can I select the efi partition on the windows disk?

    ![3_1513284302925_IMG_20171214_213421.jpg](Uploading 100%) ![2_1513284302890_IMG_20171214_203825.jpg](Uploading 100%) ![1_1513284302867_IMG_20171214_214319.jpg](Uploading 100%) ![0_1513284302835_IMG_20171214_203648.jpg](Uploading 100%)

  • @cristhian.bruno9
    First of all, make sure to use UEFI type installer, just as you seem to have done earlier.
    When you use manual partitioning, you could delete the old partitions from HDD and create two partitions there: one for root (/) and one for swap. Root partition could be ext4 formatted. Then you select /boot/efi to refer to the existing ESP partition on the Windows disk, if that is possible.

  • You seem to have sent pictures but I cannot open them… 😞

  • @cristhian.bruno9 Ok, you could just delete all partitions of /dev/sda (or just sda for short). Then create the two partitions I mentioned above.
    Then set /boot/efi to refer to that fat32 (also known as vfat) partition, if the installer lets you do it. If not, there is a problem, but let’s not worry about it just yet.

  • The third picture link was not readable…

  • @manuel what does it mean “Using UEFI type installer”?
    What about the size of the two partitions?

  • @cristhian.bruno9
    Your system seems to use UEFI boot instead of BIOS legacy boot, but you have already used that correctly.
    Partition sizes are mostly up to you, but as a rule of thumb, swap size should be slightly more than the amount of your RAM, and root partition needs about 10GB for the system plus whatever you put there e.g. in /home, I’d recommend at least 100GB for root. You can later resize it if needed.

    By the way, I’ll be gone for now, will be back tomorrow! 🙂

  • @manuel OK I’ve create two partitions and edit the efi partition with /boot/efi as point of mount.
    I choose to install Grub on the Antergos drive(HDD). Did I made it right or I had to install it on the windows drive?
    PS: Now is installing, I’m waiting to see results

    PPs: thank you very much , don’t worry 😊

  • @cristhian.bruno9 It shouldn’t matter afaik.

  • @manuel It doesn’t works,but there is something different …Now when I enter in the boot menu, the HDD is not there .Now there are just the ssd with windows and the usb flashdrive.

    Ps: Also installing grub on the windows disk, I’m still in the same situation😰

  • Hi,

    on some acer devices extra steps in the UEFI has to be made after the installation.

    So go to UEFI with F2 at POST an set a supervisior password. Now you can add the grub bootloader.

    Choose “Select an UEFI file as trusted for executing” -> then select the SSD -> select “grubx64.efi” and press enter.

    0_1513328910937_2017-12-15 10_04_11-Acer RayleighSLS_NonTouch_SG_V1.02.pdf - Adobe Acrobat Reader DC.jpg

    Now give that bootentry a name like antergos. Save this setting by pressing F10. Reboot and go again to UEFI.

    Its now possible to select the Antergos Bootenty in the boot menu. So this should do the trick 🙂

    Linux ist das beste Betriebssystem (Albert Einstein)

  • Also possible that the entry for /dev/sda is still legacy mode ? or a boot entry for it still persist into EFI/Bios or on the HD itself?

    0_1513335339181_Bildschirmfoto vom 2017-12-15 11-53-41.png

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2

  • @pseudonym it did not work. Here what I did:

    Update news:
    In this drive you can see the option displayed when I select the uefi file.

    Maybe i selected the wrong grubx64.efi (Infact there are 3 of them, one in “Boot” folder, and 2 as you can see in the picture.
    So reset to factory default the secure boot and tried again with another grubx64.efi file . The only one that works is "antergos_grub_h1pg"
    Now everything works but I want to understand what was the problem. I don’t like to go forward without understanding what I did to make it works!
    I tried choosing that file beacuse “h1” remember me the HDD(where Antergos is installed.

boot216 hdd7 Posts 33Views 1026
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.