• lightdm and gdm fail to start after an update


    https://imgur.com/a/UwglI

    I tried moving the SSD into another machine, and it boots fine, so nvidia drivers are also a suspect (I have a 1080ti).

    What set command outputs should I provide to troubleshoot this?

    I’m on a LTS kernel.

    ~ % uname -rms
    Linux 4.9.68-1-lts x86_64
    
    ~ % pacman -Q nvidia-lts
    nvidia-lts 387.34-3
    
  • @furion I’m just guessing here since I don’t have my usual Antergos install available now, sorry about that.
    But maybe reinstalling linux-lts and nvidia-lts (and reboot) helps if they recompile some drivers…

  • Even though with Linux you it’s much easier to just put a drive into another machine, you still have to watch out for issues that occur due to different hardware between bother systems.

    I can’t give your the right instructions, but maybe you should find a way to boot the kernel without the binary nvidia driver. That would solve the issue if this would be the problem

  • Unfortunately no, since its a watercooled 1080ti in a small case, and removing it is almost impossible.

    I could try downgrading to nouveau however.

  • This was the breaking upgrade: https://pastebin.com/BEgjS5th

  • dmesg | curl -F [email protected] https://ptpb.pw/?u=1
    and give the url it gives out

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • nvidia_drm fails completely …

    you should try to start with nouveau driver and then “repair” nvidia installation.

    If not already done try the nvidia-installer as it can simply install nvidia and revert to nouveau:

    sudo pacman -S nividia-installer
    sudo nvidia-installer -n Restores nouveau (open) nvidia driver

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • make sure you do not have stuff at mkinitcpio.conf or at kernel boot line (but i think nvidia installer check this too…)

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • nvidia-installer -n didn’t help, as 1080ti doesn’t seem to be supported by nouveau.

    Fortunately, todays linux+nvidia update fixed the issue for me.

  • @furion
    Nice to hear! So if you feel this is solved, would you mark it as such? 🙂

  • But on some research it seems true that cards with NV132 like the 1080ti are still not fully supported by nouveau driver…

    My question here is if you use standard Antergos ISO to install system, do you upgrade the card after install, or different ISO?

    I see in first post, would be nice if you can try booting with installee ISO to see if it was able to boot intolive environment

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

Posts 12Views 259
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.