• gnome printer settings detect wireless printer but..


    Hi. I installed antergos in my office and gnme printer settings detect my hp officejet wireless printer but, while ubuntu works out of the box, this printer “doesn’taccept jobs” even id I opened firewall for cups, ipp, hplip and avahi. what else could it be? even if I try to install a new driver , it doesn’t work.
    If I setup the printer via hp-setup giving the exact ip number, it works. so now I have two entries pointing to the same printer and the automatical one can’t be canceled…

  • You need to open gnome-control-center from top right drop down, got to devices, choose printers and unlock settings over the button top right of the settings window, then you will be able to remove.

  • And most hp printers need a proprietary plugin aviable over hp-setup, it is downloading this on the setup process.
    This is causing the problem on automatic added printer…

  • well beyond that point. the problem is that after remove it comes back automagically. and hp plugin is already installed both in Ubuntu and antergos

  • then mark the one you create manually as default will be a workaround, but it is odd indeed :)

  • looks like the wireless network printers are automatically detected but not usable. if you try to erase it, it pops up after some minute again.

  • I have this problem as well. The printer device which is detected and setup automatically does not work and is marked as “Does not accept jobs”.

    I setup my printer using hp-setup and now my printer, marked as default, works. The problem I have is this unusable printer device automatically comes back no mater how often I delete it. I see 2 printers on the printer device tab and also whenever I try to print (Libreoffice etc.).

    How can this be permanently deleted and not automatically detected, or how can it detect the correct printer?

  • edit the

    sudo nano /etc/cups/cupsd.conf
    

    and set

    Browsing Off
    

    and restart cups-server sudo systemctl restart org.cups.cupsd.service

    can do the trick…

  • Setting to Off removed the working printer I setup using hp-setup. The automatically setup printer, even though I removed it, is still automatically re-created and still marked as “Does not accept jobs”.

  • @joekamprad said in gnome printer settings detect wireless printer but..:

    can do the trick…

    so not doing the trick :( i can not test it caus my printer is usb only

  • @joekamprad Hopefully someone will post a solution… thanks for trying!

  • So the workaround is to set the printer you add with hp-setup as default…
    You can try to rename the automatic added one, and run sudo hp-setup -i right after this – say yes to add a new printer qeue… then name this one with the original name of automatic added, erase the renamed auto added one and left the one configured with hp-setup … understand what i want to say?

  • @joekamprad I ran the setup with the -i option. Runs in text mode. Either way, same problem. Naming doesn’t seem to matter. A sort of clue, CUPS only shows one printer. I give up for now. I spent days trying to get this changing all kinds on .conf files. I did a fresh install yesterday, and tried your suggestions with the newer installation.

  • I would blame this to system-config-printer

  • Yes, the hp printer needs a proprietary plugin available over hp-setup, I downloaded successfully this now if it causing any problem with your printer to try the blog of Printer is in an error state,

gnome329 printer46 wireless34 detect7 Posts 15Views 1407
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.