• Uninstalling LightDM


    Hello everyone,
    I’ve been with Antergos for a while now, but recently I had to reinstall it on my systems.
    I’ve unfortunately discovered that lightdm has been included as dependency for the package antergos-common-meta and consequently the guide “Installing Display Managers” for its removal is not working anymore.
    If I uninstall lightdm with the command sudo pacman -Rsnc lightdm it would remove also xorg and a lot of other useful packages.

    Is there any other way to uninstall lightdm keeping the other packages? In any case, should the guide be updated? And also, Is there any way to suggest to include the choosing of the login manager as part of the installation process of Antergos?

    Thank you.

  • @ThiasTux said in Uninstalling LightDM:

    sudo pacman -Rsnc lightdm

    usually should this be the right command to uninstall lightdm and dependencies, not needed by other packages… can you post what it want to uninstall?

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • or sudo pacman -Rnscdd lightdm

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • sudo pacman -Rsnc lightdm
    [sudo] password for joekamprad: 
    checking dependencies...
    
    Packages (5) 
    libxxf86misc-1.0.3-2  
    light-locker-1.8.0-1 
    lightdm-webkit2-greeter-2.2.5-1  
    xf86miscproto-0.9.3-1  
    lightdm-1:1.24.0-1
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad Thank you for the reply.

    [[email protected]:~]$ yaourt -Rsnc lightdm
    [sudo] password for mathias: 
    checking dependencies...
    :: arc-gtk-theme optionally requires gtk-engine-murrine: for gtk2 themes
    :: gnome-music optionally requires gst-plugins-ugly: Extra media codecs
    :: gnome-music optionally requires gst-libav: Extra media codecs
    :: libdvdread optionally requires libdvdcss: for decoding encrypted DVDs
    :: mesa optionally requires mesa-vdpau: for accelerated video playback
    :: totem optionally requires gst-plugins-ugly: Extra media codecs
    :: totem optionally requires gst-libav: Extra media codecs
    :: webkit2gtk optionally requires gst-libav: nonfree media decoding
    
    Packages (73) a52dec-0.7.4-9  antergos-common-meta-1.1-1  antergos-wallpapers-0.7-2  dconf-editor-3.26.2-1  dmxproto-2.3.1-3  ffmpegthumbnailer-2.2.0-1  gst-libav-1.12.3+1+ge87c20d-1  gst-plugins-ugly-1.12.3-1 gstreamer-vaapi-1.12.3+9+g325ecbc1-1  gtk-engine-murrine-0.98.2-2  hunspell-de-20161207-1  hunspell-el-0.9-2  hunspell-en-2017.01.22-2  hunspell-en_GB-2017.01.22-2  hunspell-en_US-2017.01.22-2 hunspell-es-1:2.2-1  hunspell-fr-6.0.2-1  hunspell-he-1.3-1  hunspell-hu-1.6.1-3  hunspell-it-2.4-5  hunspell-nl-2.10g-2  hunspell-pl-20160801-1  hunspell-ro-3.3.10-1  libdmx-1.1.3-1 libdvdcss-1.4.0-2  libsidplay-1.36.59-8  libx264-all-2:148.20170521-1  libxxf86dga-1.1.4-1  libxxf86misc-1.0.3-2  light-locker-1.8.0-1  light-locker-settings-1.5.3-1 lightdm-webkit2-greeter-2.2.5-1  mesa-vdpau-17.2.6-1  mpg123-1.25.7-1  numix-frost-themes-3.6.6-1  numix-icon-theme-1:0.r1970-1  numix-icon-theme-square-1:0.r83_9-1  pavucontrol-3.0-4 python-psutil-5.4.1-1  qt5-styleplugins-5.0.0.20170311-3  xf86-video-fbdev-0.4.4+12+ge0bce0d-1  xf86-video-vesa-2.3.4-4  xf86dgaproto-2.1-3  xf86miscproto-0.9.3-1  xorg-iceauth-1.0.7-1 xorg-luit-1.1.1-2  xorg-sessreg-1.1.1-1  xorg-smproxy-1.0.6-1  xorg-x11perf-1.6.0-1  xorg-xbacklight-1.2.1-1  xorg-xcmsdb-1.0.5-1  xorg-xcursorgen-1.0.6-1  xorg-xdpyinfo-1.3.2-1 xorg-xdriinfo-1.0.5-2  xorg-xev-1.2.2-1  xorg-xgamma-1.0.6-1  xorg-xinit-1.3.4-4  xorg-xinput-1.6.2-1  xorg-xkbevd-1.1.4-1  xorg-xkbutils-1.0.4-2  xorg-xkill-1.0.4-1  xorg-xlsatoms-1.1.2-1 xorg-xlsclients-1.1.3-1  xorg-xmodmap-1.0.9-1  xorg-xpr-1.0.4-2  xorg-xrandr-1.5.0-1  xorg-xrefresh-1.0.5-1  xorg-xsetroot-1.1.1-2  xorg-xvinfo-1.1.3-1  xorg-xwd-1.0.6-1  xorg-xwininfo-1.1.3-1 xorg-xwud-1.0.4-2  lightdm-1:1.24.0-1
    
    Total Removed Size:  136.39 MiB
    
    :: Do you want to remove these packages? [Y/n]
    

    I think that the responsible is antergos-common-meta-1.1-1 which requires lightdm as dependency and it would be removed together with all his dependencies.

  • yea now i can see the problem with metapackages @just are talking about 😉

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • let me check this in new installed Vm i’ll be right back in 3 minutes…

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @ThiasTux said in Uninstalling LightDM:

    antergos-common-meta

    As i can see depending on your installed DE it will be problematic… you can uninstall “”-meta packages with pacman -R and it will not remove dependencies, but i would like to hear about a solution from @developers here…

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @ThiasTux said in Uninstalling LightDM:

    antergos-common-meta

    you can try to do so:

    sudo pacman -R antergos-common-meta 
    sudo pacman -Rsnc lightdm
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • If you want to use another DM you can leave also lightdm installed, needs only to remove lightlocker removed from autostart.
    Enable another DM can be done with:

    sudo systemctl - f enable gdm
    

    Instead of gdm you need to put the DM you want to use, the - f option will remove lightdm from starting at boot and enable the choosen one.

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • I am actually already using a different DM with the solution you suggested in the last post. I disable lightdm and enable sddm. I was just wondering if it wasn’t the case either to fix the guide or to fix the meta-package. The solution you suggested previously (to remove the meta package without removing the dependencies and then to remove lightdm) did work, thanks.

  • I have the same issue when trying to remove lightdm. However, the suggested solution

    sudo pacman -R antergos-common-meta 
    sudo pacman -Rsnc lightdm
    

    doesn’t work for me. I guess some packages got updated recently.

    Here is what I get. antergos-common-meta is removed at this point.

    ➜  ~ sudo pacman -Rsnc lightdm                                
    checking dependencies...
    :: apache optionally requires lua: for mod_lua module
    :: git optionally requires perl-libwww: git svn
    :: git optionally requires gnome-keyring: GNOME keyring credential helper
    :: gnome-online-accounts optionally requires gvfs-goa: Virtual file systems (e.g. OwnCloud)
    :: gnome-online-accounts optionally requires gvfs-google: Google Drive
    :: gnome-shell optionally requires gnome-control-center: System settings
    :: google-chrome optionally requires gnome-keyring: for storing passwords in GNOME keyring
    :: graphviz optionally requires lua: lua bindings
    :: gvfs optionally requires gvfs-smb: SMB/CIFS (Windows client) support
    :: gvfs optionally requires gvfs-mtp: MTP device support
    :: gvfs optionally requires gvfs-goa: gnome-online-accounts (e.g. OwnCloud) support
    :: gvfs optionally requires gvfs-google: Google Drive support
    :: libgnome-keyring optionally requires gnome-keyring: key storage service (or use any other service implementing org.freedesktop.secrets)
    :: libmagick optionally requires libraw: DNG support
    :: libsecret optionally requires gnome-keyring: key storage service (or use any other service implementing org.freedesktop.secrets)
    :: openssh optionally requires x11-ssh-askpass: input passphrase in X
    :: python-pyqt5 optionally requires qt5-svg: QtSvg
    :: qt5-base optionally requires qt5-svg: to use SVG icon themes
    :: rygel optionally requires tracker-miners: Share indexed media files
    :: system-config-printer optionally requires python-pysmbc: SMB browser support
    :: vim optionally requires lua: Lua language support
    
    Packages (140) antergos-gnome-defaults-list-1.0-1  antergos-gnome-meta-1.0-1  antergos-wallpapers-0.7-3
                   archlinux-appstream-data-20180129-1  babl-0.1.38-1  baobab-3.26.1-1  brasero-3.12.2-2  cdrdao-1.2.3-10
                   cdrtools-3.02a09-1  cheese-3.26.0-1  colord-gtk-0.1.26+5+ga9d9c91-1  dleyna-connector-dbus-0.3.0-1
                   dleyna-core-0.6.0-1  dleyna-renderer-0.6.0-1  dleyna-server-0.6.0-1  dvd+rw-tools-7.1-7  eog-3.26.2-1
                   evolution-3.26.5-1  exempi-2.4.3+2+g65a8492-1  exiv2-0.26-2  file-roller-3.26.2-1  folks-0.11.4-1  gegl-0.3.26-1
                   gfbgraph-0.2.3+10+gbc03c1f-1  gmime3-3.2.0-1  gnome-autoar-0.2.2-1  gnome-backgrounds-3.26.2-1
                   gnome-calculator-3.26.0-2  gnome-calendar-3.26.3+2+g966ec1c5-1  gnome-color-manager-3.26.0+16+g3b2109b-1
                   gnome-contacts-3.26+3+g643f622-1  gnome-control-center-3.26.2+14+g5ac6a0da6-1  gnome-disk-utility-3.26.2-1
                   gnome-documents-3.26.1-1  gnome-font-viewer-3.26.0-1  gnome-keyring-1:3.27.2-1  gnome-logs-3.26.3-1
                   gnome-maps-3.26.2-1  gnome-music-3.26.1-1  gnome-online-miners-3.26.0-1  gnome-photos-3.26.3-1
                   gnome-screenshot-3.26.0-1  gnome-shell-extension-dash-to-dock-1:61-1
                   gnome-shell-extension-status-menu-buttons-0.3-2  gnome-shell-extensions-3.26.2+9+g683b5ee-1
                   gnome-sound-recorder-3.24.0.1+8+g0b8e221-1  gnome-system-monitor-3.26.0+1+g97b9578d-1  gnome-terminal-3.26.2-1
                   gnome-tweak-tool-3.26.4-1  gnome-weather-3.26.0-1  gom-0.3.3-1  grilo-0.3.4-1  grilo-plugins-0.3.5-1
                   gvfs-goa-1.34.2-1  gvfs-google-1.34.2-1  gvfs-mtp-1.34.2-1  gvfs-smb-1.34.2-1  ldb-1.3.0-1  libchamplain-0.12.16-1
                   libcryptui-3.12.2+24+gd5e5bc5-1  libcue-2.2.0-1  libdmapsharing-2.9.39-1  libgepub-0.5.2-1  libgexiv2-0.10.7-1
                   libgnomekbd-3.26.0-1  libgrss-0.7.0+16+g971c421-1  libgsf-1.14.42-1  libibus-1.5.17-1  libiptcdata-1.0.4-3
                   libmad-0.15.1b-7  libmtp-1.1.14-1  libnautilus-extension-3.26.2-3  libosinfo-1.1.0-1  libpst-0.6.71-2
                   libpwquality-1.4.0-1  libquvi-0.9.4-4  libquvi-scripts-0.9.20131130-3  libraw-0.18.7-1  libspiro-1:0.5.20150702-1
                   libxxf86misc-1.0.3-2  libytnef-1.9.2-2  libzapojit-0.0.3+11+g840627d-2  light-locker-1.8.0-1
                   light-locker-settings-1.5.3-1  lightdm-webkit2-greeter-2.2.5-1  lua-5.3.4-2  lua52-5.2.4-2  lua52-bitop-1.0.2-8
                   lua52-expat-1.3.0-3  lua52-lpeg-1.0.1-1  lua52-luajson-1.3.4-1  lua52-socket-20160311-1  nautilus-3.26.2-3
                   nautilus-sendto-3.8.6-1  network-manager-applet-1.8.11dev+12+ga37483c1-1
                   networkmanager-openvpn-1.8.1dev+10+ge4d8cda-2  networkmanager-pptp-1.2.4-3  openvpn-2.4.4-1  osinfo-db-20170813-1
                   pamac-6.2.4-1  perl-encode-locale-1.05-3  perl-file-listing-6.04-4  perl-html-parser-3.72-5  perl-html-tagset-3.20-6
                   perl-http-cookies-6.04-2  perl-http-daemon-6.01-5  perl-http-date-6.02-4  perl-http-message-6.14-1
                   perl-http-negotiate-6.01-4  perl-io-html-1.001-3  perl-libwww-6.31-1  perl-lwp-mediatypes-6.02-4
                   perl-net-http-6.17-1  perl-try-tiny-0.30-1  perl-uri-1.73-1  perl-www-robotrules-6.02-4  pkcs11-helper-1.22-2
                   polari-3.26.2-1  pptpclient-1.10.0-1  python-psutil-5.4.3-1  python-pysmbc-1.0.15.8-1  qt5-svg-5.10.1-1
                   qt5ct-0.34-2  seahorse-3.20.0+105+gb31e32fe-1  shared-color-targets-0.1.7-1  smbclient-4.7.4-1
                   telepathy-idle-0.2.0-2  telepathy-logger-0.8.2-2  telepathy-mission-control-5.16.4-2  tevent-1:0.9.34-1
                   totem-3.26.0+1+g4e309671-1  totem-plparser-3.26.0-1  tracker-miners-2.0.4-1  transmission-gtk-2.93-1
                   xdg-user-dirs-0.16-1  xdg-user-dirs-gtk-0.10+9+g5b7efc6-1  xorg-appres-1.0.4-1  xscreensaver-5.38-1  zip-3.0-7
                   lightdm-1:1.24.0-3
    
    Total Removed Size:  442.68 MiB
    
    

    Is there any way I can fix that? This is a fresh install of antergos.

  • @siarhei-khilko sudo pacman -R antergos-gnome-meta is needed also

    sudo pacman -Rsnc lightdm
    Prüfe Abhängigkeiten...
    :: git benötigt optional perl-libwww: git svn
    
    Pakete (25) antergos-wallpapers-0.7-3  gnome-shell-extension-status-menu-buttons-0.3-2
                gnome-shell-extensions-3.26.2+9+g683b5ee-1  libxxf86misc-1.0.3-2  light-locker-1.8.0-1
                light-locker-settings-1.5.3-1  lightdm-webkit2-greeter-2.2.5-1  perl-encode-locale-1.05-3
                perl-file-listing-6.04-4  perl-http-cookies-6.04-2  perl-http-daemon-6.01-5  perl-http-date-6.02-4
                perl-http-message-6.14-1  perl-http-negotiate-6.01-4  perl-io-html-1.001-3  perl-libwww-6.31-1
                perl-lwp-mediatypes-6.02-4  perl-net-http-6.17-1  perl-try-tiny-0.30-1  perl-uri-1.73-1
                perl-www-robotrules-6.02-4  python-psutil-5.4.3-1  xorg-appres-1.0.4-1  xscreensaver-5.38-1
                lightdm-1:1.24.0-3
    
    

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Thanks for your help! That fixed the issue.

lightdm115 uninstalling2 Posts 14Views 1189
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.