• [installation] theme and login problem


    Hello,

    First i’m really new to this forum and to antergos, and somehow to linux also.

    I get a theme error, asking me to choose betwin default theme and fallback theme, both are not doing anything except fallback give me a blank screen and default a black one.

    i tried to search and to do some repair myself but i can’t get into commands line cause it ask me a login that seems to not be the one i put when installing through cnuchi.

    i tried to re-install 3 times and my log never works at this stage so i don’t know how to go through.

    if somone got an idea, please !

    https://forum.antergos.com/topic/5778/fresh-installation-login-theme-problem

    This is exactly my problem, in these topic they talk about 3 digit number to log in but what is it ? Where to find it ?

  • do you enable autologin on installation?

    You can try getting to ext based TTY3 by pressing [ctrl+Alt+F3]
    there you will be able to login and you can change the autologin by editing sudo nano /etc/lightdm/lightdm.conf
    and unhash the autologin:

    #autologin-user="yourusername"
    

    save the file by [ctrl+X]
    and reboot

    If lightdm fails again or you do not have autologin enabled you can change the loginmanager according to the DE (Desktop environment) you are using sddm for KDE/Plasma or GDM for GNOME (gtk based DE)

    sudo pacman -S gdm
    sudo systemctl -f enable gdm
    

    or

    sudo pacman -S sddm sddm-kcm
    sudo systemctl -f enable sddm
    

    then reboot

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • This post is deleted!
  • Thanks i will try all that when i’ll be back home, i’ll edited this post to let you know if it works or not.
    By the way thanks for answer

    Edit : Ok, so i re-install with autologin on, but when it boot after instalation it still have an error with the theme, wich bring me on the white or black screen.

    Then when i go to tty3 ( or 2 or whatever) it ask me to login, and this is where i can’t log with anything i put on the instalation. they ask my name, my computer’s name, my user name, but none of all that stuff seems to be recognize as my login. so i can’t type any command before i succed to log in, but i don’t know how…

    i thought with autologin it would skip this part where it ask me to login in tty3 but no

    Edit-bis : i thought about going in the file with the antergos live version on the usb i used for install. i’ve been able to modify the lighdm.conf file, and now i’ll try to login properly and to fix these “theme” error

  • @On1yOne said in [installation] theme and login problem:

    Then when i go to tty3

    Hi!
    When reached tty3 you must type:
    username hit ‘Enter’
    password hit 'Enter’
    then you type the commands @joekamprad posted above

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • Hi 🙂

    When in tty3 it put me this :

    "Antergos Linux 4.14.4-1-ARCH (tty3)

    <your computer’s name> login : "

    If i hit just enter without anything type, it just put back those 2 lines again, it don’t ask for password

    Edit : when i installed antergos, it ask me computer’s name, user name, my name, and a password. but it seems the only thing that have been take into account is my computer’s name cause neither my name or my user name seems to be the login. it never told me my password was wrong tho.

    Is it possible that my user name was not usable ? it’s the same as my user name here…

  • @On1yOne said in [installation] theme and login problem:

    <your computer’s name> login : "

    when this appear type your username

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto

    When i type my username :

    <your computer’s name> login : 0n1yOne

    it then ask my password, wich i type, and then it give me :

    “Login incorrect”

    i have done the installation 3 times already, so i’m sure i type my name and my password as i wanted to. but nothing cnchi asked me during installation seems to work here…

  • @On1yOne i don’t know if you have the password from your user or root different.
    Instead of typing your username try to type root and then the password

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto gosh, i was absolutely sure to have tried this.

    But as i’m a “let’s verify this” guy, i verified this. and it happen that i’m now log in, shame on me that i’ve not tried that before.

    I can go ahead now thanks to you !

  • @On1yOne said in [installation] theme and login problem:

    0n1yOne

    try:

    0n1xOne

    may keyboard setting is wrong

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad

    i succeed log in with root as username. i type sudo pacman -s gdm and sudo systemctl -f enable gdm , and reboot, now it run well, i had the graphic screen asking my username and password. the username i provide during installation was not working so i tried root this time, and it works.

    i think i will have to figure out why i have to be connected through root, and i will also have to create another user as it’s not recommanded for a beginners like me to learn on root.

    But for now i’m happy that i was able to get on my final version of antergos for the first time 🙂 thank you guys

  • Login to Desktop environment as root is not only not recommended, it is highly insecure and never should be used!

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • i agree with @joekamprad, please don’t give up!
    try this command in a terminal:

    cat /etc/passwd | grep "/home" |cut -d: -f1 |head -1
    this command will return you the right username (maybe you wrote one character wrong while installing)

    afer that, if your user is right you can change it’s password, or even fix the username.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • I have to 3rd @joekamprad and @fernandomaroto - You should pretty much never log in to DE with root.

    Curious, what Desktop Environment did you select during installation? I have seen some theme errors with some of them.

  • @fernandomaroto Oh well i hesitate about asking for more help, i thought it would be to much asking, but hey, since you offer me more help, i’m gonna take it !

    i’ll be able to type the line you gave me in a moment, but i’ll post here what’s my result.

    For the record, i tried to add a new user with adduser, but this gave me a bunch of error about groups 100 and username incorrect.

    Then i tried with gnome, in the graphical settings window ( i know, what a shame… ) but it seems that the windows instantly close itself when i reach the user settings. it seems like it’s not working as intended.

    @palanthis hello 🙂 i choose gnome ! cause it’s the only one i knew from my only previous linux experience

  • How about

    useradd -m -g users -G wheel,video,power,storage -s /bin/bash on1yone

    Some people will say otherwise, but old-school wisdom says “Linux doesn’t like mixed-case in usernames”.

    If it accepts that, follow it up with

    passwd on1yone

    Oh, and… Hello! XD And… GNOME isn’t one of the ones I have seen the problem with.

  • @Palanthis i tried this, it gave me back :

    useradd : group 100 does not exist
    useradd : the GROUP= configuraton in /etc/default/useradd will be ignored
    useradd : invalid username 'On1yOne"

    @fernandomaroto when i type your command line, it give me nothin back.

    it’s like :
    [ [email protected]<mycomputersname> ~]# cat /etc/passwd | grep “/home” |cut -d: -f1 |head -1
    [ [email protected]<mycomputersname> ~]#

    Edit: don’t know if it has any meaning, but i tried to look into etc/passwd, by only typing “cat /etc/passwd”, it show me a lot of stuff about /bin/nologin

    i saw somewhere that it was a bad idea to use digit number in usernames, maybe that’s the problem?

  • Thinking…

    +1 @joekamprad I always add sddm and remove lightdm. I just prefer the look of sddm.

  • There is something wrong with installation or the user error is caused by login to DE as root, what as far as i know is not be possible at all by default…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

Posts 38Views 1163
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.