• Gdm login language


    HI, I installed deepin successfully. But after reboot l got lightdm failed error. So i disabled lightdm and enabled gdm. I got the login screen. But for my shock language changed to hindi instead of English. I can’t type my password in English. Is there any work around. I am entirely new to antergos. Thanks.

  • can you type in this comand in a Terminal or over TTY3 (when login screen appears press [Ctrl+Alt+F3] )

    localectl
    

    If your systemlocale is set to hindi you need to change this to englisch by this:

    edit /etc/locale.gen (sudo nano /etc/locale.gen)to fit to this setting by unhashing (uncomment) the locale you want to use e.g…
    this ones:

    en_GB.UTF-8 UTF-8  
    en_GB ISO-8859-1
    

    and comment out (hashing) the hindi one #hi_IN UTF-8
    the regenerate locale:

    sudo locale-gen
    

    and reboot

  • I did as per ur advice, language is changed to english but since x11 Layout is in(india) all letters are coming only in hindi. Also in tty login i am able to type in english only. In gdm window only i am getting hindi letters and unable to use onscreen keyboard also.

  • keymap are configured with

    sudo nano /etc/vconsole.conf
    

    and change t to the keymap you want

    KEYMAP=uk
    

    to see what you have inside:

    cat /etc/vconsole.conf
    
  • I also did the above. No use. Still hindi letters. For your information this is i think 20 or 21st failed attempt at antergos. Strange to see hindi as i did not choose that. Also i installed and used fedora, mint, manjaro for months, all are successful at the attempt.

  • @Kowshik
    maybe you should check /etc/X11/ or better, /etc/X11/xorg.conf.d/00-keyboard.conf

    OBS: but i didn’t know GNOME / GDM use it (since is wayland now).

  • Thanks.It worked and i am able to login.

    I don’t like the gnome view. I have issues with lightdm which is a pending issue. So is there any other option to use antergos. Is there any antergos de which is not using lightdm or gdm.
    Please suggest.

  • @Kowshik i use sddm here
    install, enable and reboot with sudo pacman -S sddm sddm-kcm && sudo systemctl enable -f sddm && reboot

  • @fernandomaroto, one question, i dont have separate home partition. Is this any way related to light dm failed to start issue.

  • @Kowshik said in Gdm login language:

    @fernandomaroto, one question, i dont have separate home partition. Is this any way related to light dm failed to start issue.

    no, lightdm usually cause this error messages or black/blank screens at boot (in every install i did), not related with partitions.

  • @fernandomaroto For me enabling sdm stuck at grub before login screen. Since language issue is resolved i mark it as solved.
    Thanks for all for the support.

  • @Kowshik said in Gdm login language:

    For me enabling sdm stuck at grub before login screen

    It shouldn’t happen, Did you change something else when trying solutions?

    Since language issue is resolved i mark it as solved.

    Ok, you’re welcome!

  • I didn’t change anything. It gets stuck also unable to go to tty window

  • Also i got into non graphical boot and gave sysyemctl, it shows no error.

    After that i tried lts kernel also same result.
    I wonder why its stuck when there is no issues shown in systemctl.

  • @Kowshik said in Gdm login language:

    Also i got into non graphical boot and gave sysyemctl, it shows no error

    so you’re not stuck at grub but between grub and the login manager.
    This may be related with video card, but i’m not familiar with this.
    Please post your pc specifications, maybe someone can help you if this is the case.

  • @Kowshik said in Gdm login language:

    no issues shown in systemctl.

    you want to say systemctl status lightdm/gdm/sddm ???

    please open a new thread on you r issue, –closing– here.

login121 gdm44 language31 Posts 16Views 1340
Locked
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.