• Boot loop after SSD installation on UEFI


    Hello everyone,

    In my quest of finding the Linux distro that suits me best, I wanted to check out Antergos. I’ve already installed numberous distributions on my machine, and by having done so, I’ve never met any problems at all…

    But during the installation of Antergos as a main (no other OS on the hard drive), I’ve had a big disaster that I can’t explain. The installation per se went very smoothly. I had on my SSD the /boot/efi, formatted in Fat32 format, another one with a swap, and a third partition for /. On my secondary drive, the home folder. When I booted back after installation, I found myself in a boot loop. I didn’t even had the opportunity to access the BIOS setting menu since the computer was booting never endlessly.

    Once the SSD disconnected, I could change my boot, and was able to boot on USB stick. But since the SSD was disconnected, I couldn’t attempt to salvage it. I reconnected it, keeping the boot on my usb stick, but once again, I was in a boot loop.

    I now have bought a second SSD drive. When connected, the computer is no longer in a boot loop. But I have to reinstall the system again. And I now fear doing so since, if it goes again in a boot loop, I have no idea how to salvage any of those two drives.

    Is there any problem known for an installation on /boot/efi and booting UEFI ? This is the first time I meet this, and I’ve installed almost any big distribution.

    Thank you for any advice.

  • may booting before in bios-legacy mode, and bootloader persist into mbr of ssd?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad I’m not very sure what bios-legacy mode is… I have a MSI Z77A-G43 as a motherboard, and the computer is hand built. I used the default standard for the installation so I believe it was via a /boot/efi partition set as a grub on the ssd. Should I try the MBR ?

  • my idea comes from you are saying other major distros work without this problem, so it cann be that they setup boo in legacy mode (old-style-bios-grub-in-mbr-mode) and the grub entry inside the mbr is still on the ssd.
    So take a look inside UEFI-Settings (uefi-bios) and take care that boot is NOT set to legacy!

    Also helpfull to reset the SSD by build in security erase, or overwriting with zeros from Livesystem (Antergos installer) (sudo dd if=/dev/zero of=/dev/sdX X needs to be replaced with the letter of the drive you want to erase!!!)
    https://wiki.archlinux.org/index.php/Solid_State_Drives/Memory_cell_clearing

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad Ok, I will check that. But should I install using the GPT or is it more recommended to put it as MBR ?

  • Modern systems should work fine on UEFI legacy is only needed if you are on a buggy Board or having windows installed aside in legacy mode…

    You can also choose systemdboot without grub, you have that value on a dropdown menu while installing.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad I rebooted and checked the bios. It is not in UEFI legacy mode. My last installation (Linux Mint) was working fine with that same settings. So I’m not sure at all why the boot loop happened.

    I’ll try the systemd option on install… I hope it won’t loop again on boot…

    Wish me luck !

  • i hope it works, as systemdboot is more simple to setup!

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad Well, weirdly enough, I cannot manage to get the boot to work at all now. Luckily, I’m not in a boot loop. But I can try all the devices listed in my boot, nothing takes up (No valid OS, please insert media). Even if I point towards the SSD drive directly. I’m not sure what’s happening at all…

    Thank you for your help though…

  • new install? and finished without errors?
    What exactly you are choosing on install?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad Yup, fresh install with formatting of all my drives (both SSD and HDD are recognised).

    On the SSD :

    512 Mb for /boot (using systemd)
    8196 Mb for /swap
    8196 Mb for /var
    Rest (out of a 250 Gb SSD) for root (/)

    On the HDD
    All for /home

    Installation finishes without a single error and ask for booting back after installation. But then, no possibility to point to the SSD in the boot option of the UEFI BIOS Menu… I see though the SSD as Sata 1 on the fast options (F11 on my system), and pointing to that one gives me an error (no valid os). I have a UEFI : no device found available, and I was pointing to that one with Mint and other distros. So I’m not sure why it doesn’t appear there…

    And I still fear installing with GRUB (even though I’m sure it will be in the bios since I’ll be in /boot/efi)… :/

  • you can easely erase the grub from mbr:
    sudo dd if=/dev/zero of=/dev/sdX bs=446 count=1
    replace X with the letter of the device you want to erase the mbr…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad Weirdly enough, I’ve tried my luck with an installation of Manjaro, using the GPT, and the following :

    On the SSD :

    • 512 Mb of /boot/efi, fat32
    • 8196 Mb for the swap
    • Rest for /

    On the HDD :

    • All for Home

    Basically, exactly the same settings as what I used with Antergos this morning, setting that put my SSD into a boot loop before even reaching grub.

    And it worked like a charm, everything being recognised flawlessly in the UEFI BIOS Menu. I’ve booted using the UEFI for my drive, and it works…

    My conclusion is that there is something that either went wrong during the initial installation, or something with my setup that do not work with Antergos…

    At least I’ve a system back and running now, which is a big relief already.

    Many thanks for your dedicated help. It is much appreciated.

  • That is weird. I have 5 computers running in Antergos in UEFI mode with no issues. I also set my VMs to UEFI and they work fine. I would be curious of the details of the chipset on your motherboard so we can look into this issue further for future reference.

  • @Palanthis For the details on my motherboard, this is not the latest of the latest anymore…

    But here are the specs of it.
    The motherboard is MSI Z77A-G43, using a chipset type Intel Z77 Express, with an Intel Core i5-3570K at a 3.40 Ghz , on a LGA1155 Socket. The speed is the normal speed and I don’t run any overclocking on it. The system has also 8 Gb of Ram.

    For the graphics card, if necessary, this is a nVidia GTX 660.

    As mentioned before, it is not the latest and the most recent machine, but it still runs the games I want very nicely.

  • Awesome! That’s a good rig. Nothing “weird” there. Should work fine. Now I am really curious what happened. Did you do expert partitioning initially or just let the installer do it? If expert, you had /boot/efi on SDA1?

  • To be totally honest, I’ve no idea on what happened. It might be nothing to do with antergos and might also be a failure of the ssd. But I was a bit scared to try the same thing again.

    For anything partitioning, I always do it fully manually. I’m used to a rather simple partitioning system with /boot/efi as the first partition on sda1, then I place the swap on sda2, and finally i place the root in sda3. Sometimes I create a /var in sda4 but i hadn’t did it this time around. On sdb1 i place /home

    And i didn’t changed anything on my partitioning scheme for antergos. But for a reason it entered a boot loop I have never met.

    I had to buy another ssd to replace the first one since it is locking my computer ; I need to unplug the ssd to be able to get to the bios. And the bios is only showing what’s connected at boot time. As the ssd is disconnected, it doesn’t come in the bios. And even if I plug it back the ssd remains unrecognized. So it must be connected to be able to be recognized by the system but it put the computer in a boot loop. I this have no choice and I even don’t know how I should access such a drive. Hence why I had to buy a new ssd.

    Now it is entirely possible that it is something related to the ssd itself. It’s not the youngest anymore either and maybe a failure occurred.

    All I know is that i’ve Found one topic with the exact same things happening as me. But I don’t know how the guy managed to access its drive. For me i can’t reach that ssd any more due to the boot loop.

    Hope this all help

  • @Vampyrebe can ypu check the drive info with hdparm?

    sudo hdparm -I /dev/sda

    Would be interesting if the disc is in a locked/frozen state To get the drive in kinda virgin state try:
    Memory_cell_clearing

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad Actually, no, I can’t. I’ve spent my sunday, trying to get that SSD to work again. The problem that I face is, as soon as I connect my drive before boot, it jumps to the boot loop, without even reaching grub at any point. I’m not even able to get to the bios menu. So I disconnect it, and there I can boot again. If I connect it at a later point after boot, it simply is not showing in the system. Unlike an USB key which appears, here I simply have nothing. So I need to connect it before boot… which sends me back in the boot loop.

    I’m totally unable to see it if I connect it after boot.

  • sounds defective to me …

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

installation220 boot191 ssd22 loop3 Posts 22Views 560
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.