• reorder icons on dash bar freezes gnome


    Hi. I have a strange problem with gnome .
    I Installed gdm to use wayland session and have energy saver on but when i try to reorder icons in the menu bar (dash to dock or the standard gnome bar) , I freeze the system and I am not even able to reach console via ctrl alt F2, F3 etc. so I wait a little and then the only way out is to press power button.
    I switched to the default icon theme adawita but no luck even there.
    so my question is:

    • Am I the only one who cannot reorde icons position?
    • is there a way to restart the pc without having to press power button even when console is not reachable?
    • btw. I am not able to start gnome account settings in gnome settings … any idea is welcome…
  • wayland session

    • try Gnome on Xorg session to see if the problem persists. (on Login Screen Lightm/GDM)

    Give us some systeminfo:

    sudo pacman -S inxi
    inxi -Fxxc0 | curl -F [email protected] https://ptpb.pw/?u=1
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • hi
    the command gives this
    inxi -Fxxc0 | curl -F [email protected] https://ptpb.pw/?u=1
    /etc/host.conf: riga 7: comando “127.0.0.1 geopcs” errato
    https://ptpb.pw/8S_Q

    the host.conf error is the solution for long start up time in firefox from arch wiki
    the same problem (I mean the icon reorder that freezes everything) is also in gnome xorg session.

  • Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
    System: Host: geopc Kernel: 4.9.67-1-lts x86_64 bits: 64 gcc: 7.2.1
    Desktop: Gnome 3.26.2 (Gtk 3.22.26) dm: gdm Distro: Antergos Linux
    Machine: Device: laptop System: Dell product: XPS 13 9350 serial: N/A
    Mobo: Dell model: 09JHRY v: A00 serial: N/A
    UEFI: Dell v: 1.5.1 date: 08/18/2017
    Chassis: type: 9 serial: N/A
    Battery BAT0: charge: 57.5 Wh 105.0% condition: 54.8/57.5 Wh (95%)
    volts: 8.5/7.6
    model: SMP DELL JHXPY53 serial: 416 status: Full
    CPU: Dual core Intel Core i7-6560U (-MT-MCP-)
    arch: Skylake rev.3 cache: 4096 KB
    flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8832
    clock speeds: min/max: 400/3200 MHz 1: 699 MHz 2: 699 MHz
    3: 699 MHz 4: 700 MHz
    Graphics: Card: Intel Iris Graphics 540 bus-ID: 00:02.0 chip-ID: 8086:1926
    Display Server: N/A drivers: modesetting (unloaded: fbdev,vesa)
    tty size: 80x24
    Audio: Card Intel Sunrise Point-LP HD Audio
    driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:9d70
    Sound: Advanced Linux Sound Architecture v: k4.9.67-1-lts
    Network: Card: Intel Wireless 8260
    driver: iwlwifi bus-ID: 3a:00.0 chip-ID: 8086:24f3
    IF: wlp58s0 state: up mac: e4:b3:18:29:1b:e3
    Drives: HDD Total Size: 512.1GB (65.7% used)
    ID-1: /dev/nvme0n1 model: THNSN5512GPU7_NVMe_TOSHIBA_512GB size: 512.1GB
    serial: 46AS12IET5ZV firmware: 57DA4103
    Partition: ID-1: / size: 19G used: 6.2G (34%) fs: xfs dev: /dev/nvme0n1p4
    ID-2: /boot size: 976M used: 51M (6%) fs: ext4 dev: /dev/nvme0n1p2
    ID-3: /home size: 457G used: 307G (68%)
    fs: xfs dev: /dev/nvme0n1p3
    Sensors: System Temperatures: cpu: 52.5C mobo: 27.8C
    Fan Speeds (in rpm): cpu: N/A
    Info: Processes: 246 Uptime: 28 min Memory: 1793.8/15895.3MB
    Init: systemd v: 235 Gcc sys: 7.2.1
    Client: Shell (bash 4.4.121 running in gnome-terminal-) inxi: 2.3.53

  • ls ~/.local/share/gnome-shell/extensions
    

    to show what extensions you are running plz.

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Hi, I’m getting the same problem here.

    Earlier today I had problems with icons for applications staying on dash to dock after they were closed, similar to this thread, so I don’t know if the two problems are related:

    https://forum.antergos.com/topic/8628/gnome-3-buggy-in-antergos

    I removed all extensions, then reinstalled from gnome-shell-extensions website. Now the icons for applications not in my favourites list don’t show on dash to dock when they are running.

    When I saw this post I also tried re-ordering icons in dash to dock and my system froze, it needed the power button to force power off. I’ve tried removing dash to dock, restarting the computer under both Wayland and Xorg, freeze still happens. Clicking on ‘Users’ in Gnome Settings/Details also causes a freeze, other options under Details seem OK.

    I’ve also tried turning off all gnome shell extensions using Tweak Tool, still get the same problem.

    inxi -Fxxc0 output is:

    System:    Host: desktop Kernel: 4.14.4-1-ARCH x86_64 bits: 64 gcc: 7.2.1
               Desktop: Gnome 3.26.2 (Gtk 3.22.26) dm: gdm Distro: Antergos
    Machine:   Device: desktop System: ASUS product: All Series serial: N/A
               Mobo: ASUSTeK model: Z87M-PLUS v: Rev X.0x serial: N/A
               BIOS: American Megatrends v: 0311 date: 04/18/2013
    CPU:       Quad core Intel Core i5-4570 (-MCP-)
               arch: Haswell rev.3 cache: 6144 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 25596
               clock speeds: min/max: 800/3600 MHz 1: 3198 MHz 2: 3198 MHz
               3: 3198 MHz 4: 3198 MHz
    Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
               bus-ID: 00:02.0 chip-ID: 8086:0412
               Display Server: wayland (X.Org 1.19.5 )
               drivers: intel (unloaded: modesetting,fbdev,vesa)
               Resolution: [email protected]
               OpenGL: renderer: Mesa DRI Intel Haswell Desktop
               version: 4.5 Mesa 17.2.6 (compat-v: 3.0) Direct Render: Yes
    Audio:     Card-1 Intel 8 Series/C220 Series High Def. Audio Controller
               driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:8c20
               Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
               driver: snd_hda_intel bus-ID: 00:03.0 chip-ID: 8086:0c0c
               Card-3 Hewlett-Packard
               driver: USB Audio usb-ID: 003-003 chip-ID: 03f0:e207
               Sound: Advanced Linux Sound Architecture v: k4.14.4-1-ARCH
    Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
               driver: r8169 v: 2.3LK-NAPI port: e000
               bus-ID: 03:00.0 chip-ID: 10ec:8168
               IF: enp3s0 state: up speed: 100 Mbps duplex: full
               mac: 74:d0:2b:7a:ea:af
               Card-2: Edimax EW-7711UTn nLite Wireless Adapter [Ralink RT2870]
               driver: rt2800usb v: 2.3.0 usb-ID: 003-002 chip-ID: 7392:7711
               IF: wlp0s20u4 state: N/A mac: N/A
    Drives:    HDD Total Size: 1000.2GB (8.5% used)
               ID-1: /dev/sda model: WDC_WD10EZEX size: 1000.2GB
               serial: WD-WMC1S6669964
    Partition: ID-1: / size: 28G used: 19G (70%) fs: ext4 dev: /dev/sda3
               ID-2: /boot size: 236M used: 54M (24%) fs: ext2 dev: /dev/sda1
               ID-3: /home size: 882G used: 55G (7%) fs: ext4 dev: /dev/sda4
               ID-4: swap-1 size: 7.67GB used: 0.00GB (0%)
               fs: swap dev: /dev/sda2
    Sensors:   System Temperatures: cpu: 30.0C mobo: 115.0C
               Fan Speeds (in rpm): cpu: 0 fan-1: 565 fan-2: 999 fan-3: 517 fan-4: 0 fan-5: 0
    Info:      Processes: 227 Uptime: 30 min Memory: 2539.2/7670.9MB
               Init: systemd v: 235 Gcc sys: 7.2.1
               Client: Shell (bash 4.4.121 running in gnome-terminal-) inxi: 2.3.53
    

    Output of ls ~/.local/share/gnome-shell/extensions is:

    [email protected]
    [email protected]
    [email protected]
    gnome-shell-trash-extension
    [email protected]
    [email protected]
    [email protected]m
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    [email protected]m
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    [email protected]
    

    I’ve found some advice on gnome shell problems on the Arch wiki but haven’t had chance to try it yet:

    https://wiki.archlinux.org/index.php/GNOME/Troubleshooting

  • I can reproduce this also, it is not related to extensions, as it also happens without any extension enabled.

    crash log:

    https://ptpb.pw/fjfJ

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • temporary fix - downgrade package gjs to version 1.50.2-1 and it no longer happens
    https://www.reddit.com/r/archlinux/comments/7iadeq/dragging_icon_from_dock_on_gnome_freezes_mouse/

    sudo pacman -S downgrade
    downgrade gjs
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @giorsat

    Further to my post above, I found this on Arch forums:

    https://bbs.archlinux.org/viewtopic.php?id=232494

    The solution seems to be to downgrade the gjs package to V 1.50.2-1
    download it from:

    https://archive.archlinux.org/packages/g/gjs/gjs-1.50.2-1-x86_64.pkg.tar.xz

    and install it:

    cd Downloads

    sudo pacman -U gjs-1.50.2-1-x86_64.pkg.tar.xz

    Ignore upgrades for gjs for now, in Pamac go to ‘Preferences’ in hamburger menu, top right. Under the General tab, go to ‘Ignore upgrades for:’ click ‘add’, scroll down list and tick gjs.

    Hope this works for you, seems OK here after a quick check, icons appear and disappear from dock as they should, with no freezes after reordering icons.

  • WORKS FOR ME TOOO! downgrade gjs solves the icon reordering problem!

    anyway, is there a way to control my pc when gnome freezes and there is not ctrl alt fsomething working?

  • @giorsat If your user-session is frozen there is not realy a way to get back into this session, and if periferal input devices (mouse / keyboard) not working no way as the only input device working in this state is the power button 😉
    I use ssh to get into the system on freezing, i use my android smartphone with juicessh for this.
    simple install ssh and enable it to start on every boot:

    sudo pacman -S openssh
    sudo systemctl start sshd 
    sudo systemctl enable sshd
    

    Secure_Shell

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • fixed today, you can remove gjs from ignorepkg !

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad well the question is: how could it be that such a flawed package has passed testing and become official?

  • https://security.archlinux.org/package/gjs – archlinux bug reporting

    But also upstream can be issued:
    https://gitlab.gnome.org/GNOME/gjs/issues

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

icons39 dash14 bar8 reorder1 Posts 14Views 719
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.