• lightdm-webkit-themes not working


    Hi everyone!

    This may seem like quite a basic thing, but for some reason none of the webkit themes other than Antergos’ one seems to be working on my system. I specifically would like to install lightdm-webkit-theme-aether, but it when I execute sudo systemctl restart lgihtdm it tries to restart, but fails with a black screen and a blinking cursor. I have already attempted to manually set the correct theme in /etc/lightdm/lightdm-webkit2-greeter.conf as well as in /etc/lightdm/lightdm.conf but nothing seems to be working over here.

    Any suggestions would be greatly appreciated, and thanks!

  • In addition, this is the output when I run lightdm --test-mode --debug.

    [[email protected] ~]$ lightdm --test-mode --debug
    [+0.00s] DEBUG: Logging to /home/keegan/.cache/lightdm/log/lightdm.log
    [+0.00s] DEBUG: Starting Light Display Manager 1.24.0, UID=1000 PID=23479
    [+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /var/lib/flatpak/exports/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /home/keegan/.local/share/flatpak/exports/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
    [+0.00s] DEBUG: Running in user mode
    [+0.00s] DEBUG: Using Xephyr for X servers
    [+0.00s] DEBUG: Registered seat module local
    [+0.00s] DEBUG: Registered seat module xremote
    [+0.00s] DEBUG: Registered seat module unity
    [+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
    [+0.01s] DEBUG: Monitoring logind for seats
    [+0.01s] DEBUG: New seat added from logind: seat0
    [+0.01s] DEBUG: Seat seat0: Loading properties from config section Seat:*
    [+0.01s] DEBUG: Seat seat0: Starting
    [+0.01s] DEBUG: Seat seat0: Creating user session
    [+0.01s] DEBUG: Loading users from org.freedesktop.Accounts
    [+0.01s] DEBUG: User /org/freedesktop/Accounts/User1000 added
    [+0.02s] DEBUG: Seat seat0: Can't login unknown user 'antergos'
    [+0.02s] DEBUG: Seat seat0: Creating greeter session
    [+0.02s] DEBUG: Seat seat0: Creating display server of type x
    [+0.02s] DEBUG: Could not run plymouth --ping: Failed to execute child process ?plymouth? (No such file or directory)
    [+0.02s] DEBUG: Seat seat0: Starting local X display
    [+0.02s] DEBUG: XServer 1: Logging to /home/keegan/.cache/lightdm/log/x-1.log
    [+0.02s] DEBUG: XServer 1: Writing X server authority to /var/run/lightdm/root/:1
    [+0.02s] WARNING: Error reading existing Xauthority: Failed to open file ?/var/run/lightdm/root/:1?: Permission denied
    [+0.02s] WARNING: XServer 1: Failed to write authority: Failed to open X authority /var/run/lightdm/root/:1: Permission denied
    [+0.02s] DEBUG: XServer 1: Launching X Server
    [+0.02s] DEBUG: Launching process 23484: /usr/bin/Xephyr :1 -seat seat0 -auth /var/run/lightdm/root/:1 -nolisten tcp
    [+0.02s] DEBUG: XServer 1: Waiting for ready signal from X server :1
    [+0.02s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
    [+0.02s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
    [+0.02s] WARNING: Could not enumerate user data directory /var/lib/lightdm-data: Error opening directory '/var/lib/lightdm-data': Permission denied
    [+0.64s] DEBUG: Process 23484 terminated with signal 11
    [+0.64s] DEBUG: XServer 1: X server stopped
    [+0.64s] DEBUG: XServer 1: Removing X server authority /var/run/lightdm/root/:1
    [+0.64s] DEBUG: Seat seat0: Display server stopped
    [+0.64s] DEBUG: Seat seat0: Stopping session
    [+0.64s] DEBUG: Seat seat0: Session stopped
    [+0.64s] DEBUG: Seat seat0: Stopping display server, no sessions require it
    [+0.64s] DEBUG: Seat seat0: Stopping; greeter display server failed to start
    [+0.64s] DEBUG: Seat seat0: Stopping
    [+0.64s] DEBUG: Seat seat0: Stopped
    [+0.64s] DEBUG: Required seat has stopped
    [+0.64s] DEBUG: Stopping display manager
    [+0.64s] DEBUG: Display manager stopped
    [+0.64s] DEBUG: Stopping daemon
    [+0.65s] DEBUG: Exiting with return value 1
    [[email protected] ~]$ 
    

    Hope this helps, and thanks in advance:grinning;.

  • [+0.02s] DEBUG: Could not run plymouth --ping: Failed to execute child process ?plymouth? (No such file or directory)

    It’s trying to call plymouth. Do you have that installed? I would wager not.

  • Thank you so much😀. Turns out I just ran across the solution myself (mere seconds before you posted) from an earlier thread here😄. For others with this issue, here’s the link:

    https://forum.antergos.com/topic/3928/black-screen-with-light-locker/6

    Thank you for the help though @Palanthis! I really thought I would need it…

  • Awesome. Glad you got it working, Keegan! Mine was a shot in the dark. lol.

Posts 5Views 998
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.