• Gnome 3 buggy in Antergos


    Hi y’all!

    So, I’ve been using Fedora for a while and wanted to explore the world of Arch. Installed Antergos, but Gnome is so buggy!

    Icons stay in the dock even after app is closed (not added to favourites)

    When trying to choose different numix Icons in tweaks/settings it defaults to the ‘standard’ gnome (adwaita?) icons

    All icons from shut down meny disappears, so I have to shutdown/restart from terminal

    I must add that I tinkered a little with Dash to dock, but nothing out of the ordinary. The only extra gnome tweak I’ve added, is the one making the dock transparent. Disablet it, but still no cigar.

    This has never happened in Fedora, any solutions?

    Thanks!

  • @aiphoenix said in Gnome 3 buggy in Antergos:

    gnome tweak I’ve added, is the one making the dock transparent.

    do you remove this or only disable it?
    dash to dock has build in transparency…

    may try to do so, and reinstall dash-to-dock also

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • I meant the top panel transparency, sorry. It seems that going into the gnome extension website and disable everything that came preinstalled did the trick. Then I could only reinstall the ones I needed. Will test a little more. 🙂

  • yea i like it this way too, as i use some extensions from the browser install, i change to go with all extensions from there, and use extensions update notification to get informed about updates:

    https://extensions.gnome.org/extension/1166/extension-update-notifier/

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • The not refreshing icons issue in Dash to Dock appeared recently. Not the first bug in this extension, and surely not the last one. And I think it’s not Arch-specific. We’ll have to wait for it to be fixed.

    Take a look at my game. Or at another one

  • i never had have this issue… do you run wayland session?

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • @joekamprad said in Gnome 3 buggy in Antergos:

    do you run wayland session?

    Currently I do, but last night I was working with X, and it looked the same.

    Take a look at my game. Or at another one

  • would be nice to get some logs but i am not sure from what 😉

    may:
    journalctl | grep dash-to-dock

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • @joekamprad said in Gnome 3 buggy in Antergos:

    journalctl | grep dash-to-dock

    Well, I’m not sure if it’s going to help much, but here you are:

    gru 10 12:12:25 asuspro gnome-shell[978]: JS WARNING: [/usr/share/gnome-shell/extensions/[email protected]/utils.js 34]: reference to undefined property Symbol.toPrimitive
    gru 10 12:13:17 asuspro gnome-shell[978]: Extension "[email protected]" had error: downloading info: 2
    gru 10 12:13:53 asuspro gnome-shell[2572]: JS WARNING: [/usr/share/gnome-shell/extensions/[email protected]/utils.js 34]: reference to undefined property Symbol.toPrimitive
                                               MyDash<[email protected]/usr/share/gnome-shell/extensions/[email protected]/dash.js:838:17
                                               MyDash<[email protected]/usr/share/gnome-shell/extensions/[email protected]/dash.js:838:17
                                               ThemeManager<[email protected]/usr/share/gnome-shell/extensions/[email protected]/theming.js:195:9
    gru 10 12:25:14 asuspro gnome-shell[978]: JS WARNING: [/usr/share/gnome-shell/extensions/[email protected]/utils.js 34]: reference to undefined property Symbol.toPrimitive
    gru 10 15:11:55 asuspro gnome-shell[1017]: JS WARNING: [/usr/share/gnome-shell/extensions/[email protected]/utils.js 34]: reference to undefined property Symbol.toPrimitive
    gru 10 18:51:51 asuspro gnome-shell[971]: JS WARNING: [/usr/share/gnome-shell/extensions/[email protected]/utils.js 34]: reference to undefined property Symbol.toPrimitive
    

    Take a look at my game. Or at another one

  • To be more specific: on my device the icon representing just opened app appears in dock after delay of 20 second. It also vanishes 20 seconds after I close the app. Temporarily I installed the Taskbar extension to replace broken Dash to Dock features.

    Take a look at my game. Or at another one

  • Ok, here is how i did it. I did a clean Antergos install, updated all gnome extensions via website, and enabled the ones i needed one by one.

    That did the trick for me, and I have no more issues (expet that the numix round icons are not working, but I can live with that).

    On the other hand; set up Antergos completely now, and I love it. Aur! ❤

  • @aiphoenix said in Gnome 3 buggy in Antergos:

    I did a clean Antergos install

    I’d have to be really desperate to install Antergos from scratch on this machine: all my current work, and archives are stored here. 😕

    The good news is: Numix Circle icons work perfectly for me. 🙂

    0_1513039331697_Zrzut ekranu z 2017-12-12 01-38-45.png

    Take a look at my game. Or at another one

  • @piotr Thankfully I had just started tinkering with Antergos. It’s going to be my daily driver now on my home PC (have a win 10 partition for games and HBO Nordic tho).

  • Guys, has anyone managed to find a solution other than installing all the system from scratch yet? Not that I couldn’t live with it, but I used to be proud of my polished Antergos working with absolutely no errors…

    BTW: this seems to have nothing to do with the Dash to Dock extension itself. Even if I uninstall the extension, Dash icons still behave the same way.

    Take a look at my game. Or at another one

  • @piotr Top panel transparency breaks stuff in gnome 3.26. Try turning off all extensions using the Tweak Tool and see if problem persists. From there you can enable one at a time in order to troubleshoot.

    I gave up on terminal and top panel transparency after 3.26

    alt text

  • @underclock said in Gnome 3 buggy in Antergos:

    I gave up on terminal and top panel transparency after 3.26

    Well, I’ve never used any of above on this machine.

    Take a look at my game. Or at another one

  • @piotr The problem could still be an extension.

    Try hitting Alt-F2 r
    then Alt-F2 lg

    This will bring up a window which could aid in finding the problem.
    alt text

  • @underclock said in Gnome 3 buggy in Antergos:

    This will bring up a window which could aid in finding the problem.

    Thanks. Unfortunately none of extensions reported errors. And I’m still afraid it may have nothing to do with extensions at all.

    Take a look at my game. Or at another one

  • @piotr i would try to uninstall dash-to-dock extension from repo and use the one from gnome-shell-extensions side… https://extensions.gnome.org/extension/307/dash-to-dock/

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • @joekamprad Sure, this was the first thing I tried. Even having no D2D extension installed I still have the very same delay of 20 second in appearing and disappearing application icons.

    Take a look at my game. Or at another one

gnome267 buggy1 Posts 26Views 1047
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.