• Keyboard layout won't change at all, any ideas?


    System Locale: LANG=en_GB.UTF-8
    VC Keymap: uk
    X11 Layout: gb
    X11 Model: pc105
    X11 Options: terminate:ctrl_alt_bksp

    I have an x270 with a uk keyboard layout.
    All of my configurations point to a uk keyboard layout (Lenovo x270).
    But for some reason, the ’ " ’ is switched with ’ @ ’ and the the GBP Sterlin Pound Symbol is replaced with #, it seems like it’s following the US layout instead. it’s very annoying especially when you’re programming,

    It wasn’t like this before, it changed recently after I updated the system.

    Any ideas guys? I checked the xorg configs as well, it all points towards the right keymap settings 😕

    Many thanks!

  • still on GNOME Desktop?
    what gives: localectl

    As i know you can set every keyboard you want inside gnome-control-center
    0_1512589926348_Bildschirmfoto vom 2017-12-06 20-51-45.png

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad

    Thank you so much! I wasn’t aware of this setting, mine was defaulted to English (US) a quick change to English (US) helped!

    Many thanks,
    donbibi

  • English (GB) is what you set it to 😉
    There is a bug for Gnome DE that after install keyboard is set to default (US)

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

keyboard65 layout14 Posts 4Views 463
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.