• Shutdown interface is plain white when using a PNG wallpaper


    Hi. I’m new here in antergos but kinda experimented with linux. (used manjaro for years, and Debian/Ubuntu based distros before i discovered Arch) I’m using a fresh install of the Antergos Deepin community version.

    The “shutdown interface” as it’s called in Deepin’s documentation (the screen where you can shutdown, restart, logout, etc…) appears plain white all the time in my fresh install. The clicking and the mouse still works and if i randomly click, i can find the buttons and click them to shutdown, reboot and such, making the thing nearly unusable.

    I tried to change the themes, still the same problem. Same too if it’s in dock mode or extended mode. The problem doesn’t seem to appear on the liveCD.

    Am I the only one with this problem? Any workarounds i can use to fix it?
    Thanks :)

  • @maxlefou
    @Keegan is the Deepin expert here!
    Anyway, it sounds like you could solve it by changing a theme. But don’t ask me how, I’m not using Deepin… :)

  • Hi there!

    Thank you @manuel for bringing this thread to my attention:grinning:. I somehow missed it earlier.

    Anyways, this kind of sounds like either an issue due to missing packages, or a hardware issue. Could you please make sure that all the deepin packages are intalled first? To do so, just run sudo pacman -S deepin deepin-extra and choose “y” to install (or hopefully just re-install) them all. This way, you should definitely have all the packages installed correctly for sure. If this does not work, perhaps you could share your computer specs? They might be helpful in solving this issue…

    P.S. after running sudo pacman -S deepin deepin-extra, please reboot for the changes to actually take effect. Thank you!

    Hope this helps and good luck:grinning:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan Reinstalled packages, rebooted, still same problem.
    I’m not very surprised tho. If it had worked, it would mean the antergos deepin liveCD doesn’t install deepin correctly from the beginning :p

    Here’s my specs in hope it can help:
    CPU: Intel® Core™ i3 CPU 530 @ 2.93GHz
    GPU: Nvidia GeForce GTX 960 with official driver 387.34
    RAM: 8Gb + 4Gb dedicated from the GeForce
    Kernel: 4.14.3-1-ARCH (haven’t tested on the lts one)
    Feel free to ask if you need more details :)

  • :o

    I just got some interesting info :o as i was messing around.

    I was using a custom wallpaper. I tried to revert to one of the default wallpapers randomly to see if it changes anything

    and it actually worked! the shutdown screen works now!

    So the problem seems to come from the use of custom wallpapers :/ Great, it’s top in my top 5 features i need :s
    I’m also wondering if it’s actually linked to antergos or just deepin in general. I’ll test on my virtual manjaro system.

  • @maxlefou said in Shutdown interface is plain white:

    GPU: Nvidia GeForce GTX 960 with official driver 387.34

    Here we go! My best guess is that it might have something to do with your NVIDIA card.I have to leave for work now (it’s only 6:30 AM here) but when I get back I’ll see if I can help some more:grinning:.

    Good luck and be back soon! (in about 9 hours actually).

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • Ok after some more tries, it appears the problem comes from the specific pic i was using for wallpaper.

    I’m trying to extract the exif and info about the pic to see if it helps tracking the bug :p

  • So the pic i was using was 4.5Mb (yeah it’s a big pic :p )
    It’s originally a drawing of some of my co-workers in a project. he did it with a graphic tablet i think.

    Here’s the info i extracted with imagemagick about it. I’m gonna report the problem on deepin’s github too, in case it happens to deepin in general:

    Image: /mnt/windaube/Users/Max/hubiC/projets renpy/kwk-final/src/festival1.png
      Format: PNG (Portable Network Graphics)
      Mime type: image/png
      Class: DirectClass
      Geometry: 3280x2161+0+0
      Resolution: 118.11x118.11
      Print size: 27.7707x18.2965
      Units: PixelsPerCentimeter
      Type: TrueColorAlpha
      Endianess: Undefined
      Colorspace: sRGB
      Depth: 8-bit
      Channel depth:
        red: 8-bit
        green: 8-bit
        blue: 8-bit
        alpha: 1-bit
      Channel statistics:
        Pixels: 7088080
        Red:
          min: 0  (0)
          max: 255 (1)
          mean: 95.7473 (0.37548)
          standard deviation: 54.4738 (0.213623)
          kurtosis: 0.277808
          skewness: 0.42904
          entropy: 0.897501
        Green:
          min: 0  (0)
          max: 255 (1)
          mean: 76.9401 (0.301726)
          standard deviation: 48.9539 (0.191976)
          kurtosis: -0.122275
          skewness: 0.598215
          entropy: 0.876845
        Blue:
          min: 0  (0)
          max: 255 (1)
          mean: 71.4957 (0.280375)
          standard deviation: 43.669 (0.171251)
          kurtosis: -0.243083
          skewness: 0.268763
          entropy: 0.864059
        Alpha:
          min: 255  (1)
          max: 255 (1)
          mean: 255 (1)
          standard deviation: 0 (0)
          kurtosis: -3
          skewness: 0
          entropy: -nan
      Image statistics:
        Overall:
          min: 255  (1)
          max: 0 (0)
          mean: 193.954 (0.760605)
          standard deviation: 56.0434 (0.219778)
          kurtosis: -0.157274
          skewness: 0.65948
          entropy: -nan
      Rendering intent: Perceptual
      Gamma: 0.45455
      Chromaticity:
        red primary: (0.64,0.33)
        green primary: (0.3,0.6)
        blue primary: (0.15,0.06)
        white point: (0.3127,0.329)
      Background color: white
      Border color: srgba(223,223,223,1)
      Matte color: grey74
      Transparent color: none
      Interlace: None
      Intensity: Undefined
      Compose: Over
      Page geometry: 3280x2161+0+0
      Dispose: Undefined
      Iterations: 0
      Compression: Zip
      Orientation: Undefined
      Properties:
        date:create: 2017-11-06T13:45:54+01:00
        date:modify: 2017-11-06T13:45:54+01:00
        png:bKGD: chunk was found (see Background color, above)
        png:cHRM: chunk was found (see Chromaticity, above)
        png:gAMA: gamma=0.45455 (See Gamma, above)
        png:IHDR.bit-depth-orig: 8
        png:IHDR.bit_depth: 8
        png:IHDR.color-type-orig: 6
        png:IHDR.color_type: 6 (RGBA)
        png:IHDR.interlace_method: 0 (Not interlaced)
        png:IHDR.width,height: 3280, 2161
        png:pHYs: x_res=11811, y_res=11811, units=1
        png:sRGB: intent=0 (Perceptual Intent)
        png:tIME: 2017-11-06T12:37:02Z
        signature: 989743e87a1d4781b4322976b7cd85fb6b84db5b1598666cb317156293b31608
      Artifacts:
        filename: /mnt/windaube/Users/Max/hubiC/projets renpy/kwk-final/src/festival1.png
        verbose: true
      Tainted: False
      Filesize: 4.51MiB
      Number pixels: 7088080
      Pixels per second: 17288000B
      User time: 0.400u
      Elapsed time: 0:01.410
      Version: ImageMagick 6.9.9-25 Q16 x86_64 2017-12-01 http://www.imagemagick.org
    

    Problem resolved anyway. I just need to rebake the pic in another format. :p
    Thanks for the help. ^^

    EDIT: After more tries, it appears the problem occurs with ANY picture in PNG format. JPG works perfectly right.

  • @maxlefou So if you feel this is solved, would you mark thread as such?

  • Hmmm… perhaps this is why all of Deepin’s official pictures are in .jpg format. I never really knew the reason for it until now.

    Thank you @maxlefou for teaching me something new today:grinning:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

Posts 10Views 162
Log in to reply