• Unable to boot - error resume: hibernation device


    Hello, my laptop was running fine yesterday, and ran pacman -sYu
    Unfortunately today I am unable to boot the device, I get an error regarding hibernation.
    Another point to mention is that I am using an encrypted drive.
    https://imgur.com/a/EvJtk

  • Hi there!

    It appears your UUIDs are off by a few digits. To recover the correct ones, it’s best to find out what the correct values are, using the command lsblk -f. If you could copy / paste the output (or take a screenshot of it if you have to) that would be great:grinning:.

    Thanks!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • I have managed to mount the encrypted drive, and use arch-chroot to get into it.
    When I am there if I run lsblk -f I get https://imgur.com/a/MhMkr
    I have then ran blkid as that didnt give me an UUIDs, which returns https://imgur.com/a/zuEjd
    fstab https://imgur.com/a/5sWQK
    If I check AntergosBoot which /dev/sda1 The menu entries include linux /vmlinuz-linux root=UUID=66a5c25b-b346-45c3-8b02-fda3ef815986 rw cryptdevice=/dev/disk/by-uuid/655c25c6-3e1f-44d0-8d1d-9d0891e31eb3:cryptAntergos quiet resume=UUID=8151a712-0097-42c6-a5ba-dffd6912357a The resume UUID matches up with the UUID for swap when checking fstab

  • If all the UUIDs match up, then I don’t know what to tell you:disappointed:. But at least we’re closer to the solution now that you have managed to chroot into your system:grinning:.

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • @Keegan It wasn’t easy but I fixed it.
    So I tried mkinitcpio -p linux and that failed, with a similar error to pacman about libtinfo. Isolated that down to ncurses which I had blocked in pacman due to an issue with my SBT. Allowed ncurses to update, and that let me run mkinitcpio -p linux and voila. However I have literally 0 idea how it broke in the first place.

  • Yay !!!

    At least it’s fixed now:grinning:. I’m so glad you were able to figure it out!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

  • So bit of an issue. It’s happened again, and I have no idea what the cause it.
    Also not sure how to to mark it as unsolved @Keegan

  • Sorry about that, jsut made it “unsolved” again.

    As for your issue, I regret to say that I am insanely busy atm, so I do not really have the adequate time to help right now. However, perhaps there is someone else who can?

    Thanks!

    Keep trying, never give up. In the end, you will find that it was all worth it

    My ISO:
    https://rebornos.wordpress.com
    Linux Basics: https://linuxbasicssite.wordpress.com

Posts 8Views 186
Log in to reply