• can't install anything from yaourt behind proxy


    Hi everyone, I got a problem installing anything from AUR using yaourt.

    I am behind a proxy that have been setup for all users through a script /etc/profile.d/proxy.sh exporting proxy all_proxy http_proxy https_proxy ftp_proxy to the correct address. All works fine with pacman (install, updates, …)

    I had issues with curl when used manually, had to create ~/.curlrc and add proxy="http://wwwcache.univ-orleans.fr:3128"
    but now i can curl https://aur.archlinux.org without problem and install packages manually using:
    git clone https://aur.archlinux.org/somepackage.git && cd somepackage && makepkg -si

    but still, no way to make use of yaourt or cower

    I also tried this solution, but package-query-ssl3 seems to have disappeared from AUR…

    yaourt -Sua
    curl error: SSL connect error
    curl error: SSL connect error

    I’m out of ideas

    PS: tried this just in case (would be surprising as curl https works tho) but still nothing can't install anything from yaourt !!

    [edit] I’m sorry, I dumbly put this topic in the same section than the previous cited one… even if it should be part of the Pacman & Package upgrade section, did no find how to move it tho, my bad

  • @t4mmi do you try to say sudo to keep your proxy settings?

    edit /etc/sudoers
    and add this line:

    Defaults env_keep += “http_proxy https_proxy ftp_proxy all_proxy no_proxy”

    logout > login and should work

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Thanks for the reply, yet I already fixed sudoers exports (forgot to mention it)…

    curl ssl error occurs before going sudo, Yaourt is run as user

  • so that the proxy settings are taken from the bashrc. In the bashrc the following is entered for the use of a proxy server:

    export http_proxy="http://USER:[email protected]:PORT"
    export https_proxy="http://USER:[email protected]:PORT"
    export ftp_proxy="http://USER:[email protected]:PORT"
    

    In order for yaourt to work with sudo via a proxy server, it still needs to be in /etc/sudoers
    try with this:

    Defaults env_keep += "http_proxy"
    Defaults env_keep += "https_proxy"
    

    get this from german archwiki on yaourt…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Thanks again, but as I said, I already modified my /etc/sudoers to keep the proxy variables “user-defined”.
    and I do not see why this would be a problem as yaourt does NOT run as super user…

    For the ~/.bashrc, I do not use it as my proxy settings are defined for all users in a /etc/profile.d/ script that export all proxy variables :
    proxy all_proxy http_proxy https_proxy ftp_proxy no_proxy
    and there uppercase versions… (don’t know if proxy is usefull tho, added it after completing the .curlrc)
    And yes I tried to switch back to a .bashrc proxy settings, still no functional Yaourt.

  • You are right i overread this…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Thanks but pacman is fine, proxy settings run fine for everything…
    Even manual build/installation packages from AUR works fine,

    I can use curl to manually retrieve http and https urls with my privileges and sudo, but unfortunately yaourt cannot

    the only problem I have is directly linked to Yaourt and its use of curl that does not keep my ~/.curlrc “proxy” setting…

  • O. K. As i read here it is may related to proxy itself: https://bbs.archlinux.org/viewtopic.php?id=219403

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

Posts 10Views 169
Log in to reply