• System update for months now!


    Whenever I try to upgrade, This happens…
    I have to igore the packages to complete the update, so they always end up not being updated.
    I’ve tried refresing the keys, but the same error.
    Regards
    XoitX

    (409/409) checking keys in keyring [#####################################################] 100%
    downloading required keys…
    :: Import PGP key 256E/1A60DC44245D06FEF90623D6EEEEE2EEEE2EEEEE, “Gaetan Bisson [email protected]”, created: 1998-03-24? [Y/n]
    :: Import PGP key 256E/DBE7D3DD8C81D58D0A13D0E76BC26A17B9B7018A, “Alad Wenter [email protected]”, created: 2017-09-07? [Y/n]
    (409/409) checking package integrity [#####################################################] 100%
    error: antergos-alerts: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is marginal trust
    :: File /var/cache/pacman/pkg/antergos-alerts-17.11.18-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: antergos-mirrorlist: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is marginal trust
    :: File /var/cache/pacman/pkg/antergos-mirrorlist-20170930-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: python-pydbus: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is marginal trust
    :: File /var/cache/pacman/pkg/python-pydbus-0.6.0-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: antergos-welcome: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is marginal trust
    :: File /var/cache/pacman/pkg/antergos-welcome-0.3-2-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: fzf: signature from “Ambrevar [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/fzf-0.17.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: package-query: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is marginal trust
    :: File /var/cache/pacman/pkg/package-query-1.9.r380-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: pamac: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is marginal trust
    :: File /var/cache/pacman/pkg/pamac-6.2.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: qutebrowser: signature from “Ambrevar [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/qutebrowser-1.0.4-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: yaourt: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is marginal trust
    :: File /var/cache/pacman/pkg/yaourt-1.9-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: failed to commit transaction (invalid or corrupted package)
    Errors occurred, no packages were upgraded.

  • https://antergos.com/wiki/de/system-admin/package-management/antergos-wont-update-due-to-broken-signing-system-keyring-refresh-doesnt-work/

    first try this:

    sudo pacman-key --init
    sudo pacman-key --populate archlinux antergos
    sudo pacman-key --refresh-keys
    sudo pacman -Syyu
    

    if it do not help:

    sudo pacman -U http://repo.antergos.info/antergos/x86_64/antergos-keyring-20170524-1-any.pkg.tar.xz
    
  • While this is by no means a good policy or even a permanent fix, if you are absolutely desperate to update those packages, you could keep pacman from checking it’s keys when updating until we find a permanent solution for you. To do so, just open /etc/pacman.conf and wherever it says SigLevel= Whatever Just Happens To Be Here... simply change it to SigLevel = Never. This should allow you to update your packages successfully for now, although due to security reasons, this is NOT a good policy to use permanently. But if there’s a package that just has to be upgraded, then this should probably fix it until we get this issue sorted out here.

    Hope this helps and good luck!

  • @joekamprad I tried both,

    sudo pacman-key --init
    https://ptpb.pw/sEd3

  • @Keegan I’ll keep it in mind, however I’d rather fix it properly as I’ve had this problem for months now.

  • you will need to clean the pacman cache first:

    sudo pacman -Scc
    

    On systems not updated for longer time it is a bit hackery to get this working back again…

    and try again with update:

    sudo pacman -Syu
    

    If keyerror persist clean keyring away:

    sudo pacman -Sc
    sudo mv /etc/pacman.d/gnupg /etc/pacman.d/gnupg.old
    pacman-key --init
    sudo pacman-key --populate archlinux antergos
    sudo pacman-key --refresh-keys
    sudo pacman -Syyu
    
  • @joekamprad said in System update for months now!:

    sudo pacman -Syyu

    It’s screwed up even more now… now idea what’s going on.

    vlc-2.2.7-1-x86_64 10.2 MiB 861K/s 00:12 [#####################################################] 100%
    (12/12) checking keys in keyring [#####################################################] 100%
    downloading required keys…
    :: Import PGP key 4096R/E240B57E2C4630BA768E2F26FC1B547C8D8172C8, “Levente Polyak [email protected]”, created: 2011-11-08? [Y/n]
    (12/12) checking package integrity [#####################################################] 100%
    error: antergos-alerts: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/antergos-alerts-17.11.18-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: antergos-mirrorlist: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/antergos-mirrorlist-20170930-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: python-pydbus: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/python-pydbus-0.6.0-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: antergos-welcome: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/antergos-welcome-0.3-2-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: package-query: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/package-query-1.9.r380-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: gcab: signature from “Jan Alexander Steffens (heftig) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/gcab-0.7+16+g4bc4be1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: libstemmer: signature from “Jan Alexander Steffens (heftig) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/libstemmer-0+337-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: appstream-glib: signature from “Jan de Groot [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/appstream-glib-0.7.4-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: archlinux-appstream-data: signature from “Antonio Rojas [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/archlinux-appstream-data-20171017-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: pamac: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/pamac-6.2.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: vlc: signature from “Levente Polyak (anthraxx) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/vlc-2.2.7-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: yaourt: signature from “Antergos Build Server (Automated Package Build System) [email protected]” is unknown trust
    :: File /var/cache/pacman/pkg/yaourt-1.9-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] n
    error: failed to commit transaction (invalid or corrupted package (PGP signature))
    Errors occurred, no packages were upgraded.

  • @joekamprad said in System update for months now!:

    sudo pacman -Sc
    sudo mv /etc/pacman.d/gnupg /etc/pacman.d/gnupg.old
    pacman-key --init
    sudo pacman-key --populate archlinux antergos
    sudo pacman-key --refresh-keys

    do you run all this commands?

    Then do the following procedure:

    wget http://repo.antergos.info/antergos/x86_64/antergos-keyring-20170524-1-any.pkg.tar.xz
    sudo pacman -U antergos-keyring-20170524-1-any.pkg.tar.xz
    wget http://mirror.clarkson.edu/archlinux/core/os/x86_64/archlinux-keyring-20171020-1-any.pkg.tar.xz
    sudo pacman -U archlinux-keyring-20171020-1-any.pkg.tar.xz
    sudo pacman -Sc
    sudo mv /etc/pacman.d/gnupg /etc/pacman.d/gnupg.old
    sudo pacman-key --init
    sudo pacman-key --populate archlinux antergos
    sudo pacman-key --refresh-keys
    sudo pacman -Syyu
    
  • @joekamprad said in System update for months now!:

    you will need to clean the pacman cache first

    sudo paccache -rk0

  • @judd I get this now

    ==> ERROR: The keyring file /usr/share/pacman/keyrings/antergos.gpg does not exist.

  • @joekamprad said in System update for months now!:

    /etc/pacman.d/gnupg

    You can try doing --force at your own risk

    # pacman-key --init && pacman-key --populate archlinux antergos && pacman-key --refresh-keys
    
  • I solved it.

    I had to change siglevels in pacman.conf to never.
    I had it in conf 2 times. so there were problems
    then I manually upgraded it
    sudo pacman -U http://repo.antergos.info/antergos/x86_64/antergos-keyring-20170524-1-any.pkg.tar.xz
    then init populated and refreshed keys
    and finally siglevel back to defaults.
    now upgrade works fine. Thnaks for all the help!!
    The reference tp the post actually helped…

  • you can see pacman is very secure ;)
    Last exit works, so system is back up and running now?

  • @joekamprad Yea man, really appreciate the power of pacman. It contains all of arch power I guess.
    Is there somewhere I can learn how all this works? the keyring thing and what exactly is going on? I see some keys from years ago and I don’t get it.

  • @xoitx777 said in System update for months now!:

    Is there somewhere I can learn how all this works? the keyring thing and what exactly is going on? I see some keys from years ago and I don’t get it.

    https://wiki.archlinux.org/index.php/Pacman/Package_signing

    https://wiki.archlinux.org/index.php/Pacman

system128 months2 now1 Posts 15Views 2001
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.