• Antergos on VM blank screen after booting


    I have installed Antergos on Virtualbox to make other things.

    So basically, host OS is Antergos and guest OS is Antergos too.
    VM Antergos runs with XFCE.

    On the VM Antergos I have an issue: after starting VM, after the boot screen I get to a blank screen. Then I can login because I just type blindly my password but this is not really convenient.
    On the blank screen the only thing I see is the mouse arrow.

    At first I thought is was a light-dm problem, so I switched from light-dm to gdm, however nothing has changed.
    I have read about same kind of issue in the past which was then fixed with a Virtualbox upgrade.
    I have correctly (it seems) installed Guest additions and Extension pack.

    Any idea?
    Thanks

  • Not sure that link fixes my problem. I do not need to lock my screen, I need to see the greeting screen (the one where I type my login password).

  • @ase11 said in Antergos on VM blank screen after booting:

    On the VM Antergos I have an issue: after starting VM, after the boot screen I get to a blank screen.

    I experienced the same problem yesterday installing Antergos through my own iso, but i hadn’t time to test it. I’m guessing there are some virtualbox package missing inside Antergos install.

    OBS: just to be sure if is the same error.
    I enter the password at lightdm then the screen got Black, If i change virtualbox screen resolution, it appears again, but instantly feezes and you’ll need to keep changing resolution over and over to see what’s happening…
    Can you confirm if is the same error?

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto said in Antergos on VM blank screen after booting:

    I enter the password at lightdm then the screen got Black,

    I enter the password on a blank screen, so my screen turns blank right after the boot screen.
    I did not play with resolution settings, yet.

    PS: launching a live session does not face this issue, so I guess it’s really tied to the login (password) screen. I am now re-installing a persistent version with automatic logging in. Let’s see what happens.

  • I’ve used Antergos with Xfce in VirtualBox for quite a while. It has worked OK so far.
    But I’ll install it now to check if something has changed. Let’s see.

  • I had the same issue with Gnome DM, though.

  • @ase11
    Actually I had a weird problem with Gnome in VM. It installed OK, but using the VM required a click outside the VM window always. For example, I started a terminal in the VM window. It didn’t show up before I clicked somewhere outside of the VM window!

    All other DEs have behaved OK, only Gnome did this.

  • OK. Xfce in VM works as expected, but VirtualBox guest modules do not seem to work (e.g. window resize does not work properly).

    Oracle had this problem already in version 5.2.0. They were aware of the problem, and provided guest additions ISO version 5.2.1 which fixed these problems. But it seems not to be available by Oracle anymore.

    One thing to try is to downgrade to version 5.1. I haven’t tried it so not sure if it fixes anything.

    EDIT: downgraded virtualbox to 5.1.30 inside VM. Didn’t fix window resize problem, but otherwise works as the newest version.

    EDIT2: just noticed there was no linux-headers package in the VM, and for that reason the virtualbox-guest-dkms didn’t even compile! Pamac showed nothing by default…
    Well now I installed linux-headers and now VirtualBox guest additions work OK.

    @developers why is linux-headers no more installed by default? I think it should be, one way or the other. Sorry about adding your already high workload, but the package used to be there.

  • That’s weird anyway because in my VM resizing works perfectly (I am on 5.2.2).

  • Ok guys the issue is confirmed due to the password input at login. After installing Antergos VM with automatic login I get to XFCE desktop without any problem.

  • Update: re-installed Virtualbox following @hector tutorial and installing ISO 17.12 fixed it. I do not know why but now no blank screen at login anymore.

booting26 blank14 Posts 12Views 145
Log in to reply