• Mouse movement triggers screen when lid is closed


    I’ve set my screen to turn off when I close the lid, in all power options.

    If I close the lid, and open it again without touching the mouse, it will turn the screen on when I open it, as expected.

    However, if I close the lid, move the mouse, then open the screen, I’ve noticed that it turns on as soon as a mouse movement is made. The expected behaviour is that the screen stays off so long as the lid is closed.

    Any fix?

  • You can start installing tlp, which will give you information doing by console as root # tlp-stat

    inxi -Fxxc0 This syntax of command by console is for you to provide more information about your hardware, if you do not have installed inxi, please install it like sudo pacman -S inxi

    ?

  • Here is the output. Items marked xxx were removed by me.

    +++ System Info
    System         = Dell Inc. Inspiron 13-7359
    BIOS           = 01.06.00
    Kernel         = 4.13.12-1-ARCH #1 SMP PREEMPT Wed Nov 8 11:54:06 CET 2017 x86_64
    /proc/cmdline  = BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=xxx rw quiet
    Init system    = systemd 
    Boot mode      = UEFI
    
    +++ TLP Status
    State          = enabled
    Last run       = unknown
    Mode           = unknown
    Power source   = AC
    
    Notice: tlp.service is not enabled -- invoke "systemctl enable tlp.service" to correct this!
    Notice: tlp-sleep.service is not enabled -- invoke "systemctl enable tlp-sleep.service" to correct this!
    Notice: systemd-rfkill.service is not masked -- invoke "systemctl mask systemd-rfkill.service" to correct this!
    
    +++ Processor
    CPU model      = Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz
    
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq  =   400000 [kHz]
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq  =  3100000 [kHz]
    /sys/devices/system/cpu/cpu0/cpufreq/energy_performance_preference = balance_performance
    /sys/devices/system/cpu/cpu0/cpufreq/energy_performance_available_preferences = default performance balance_performance balance_power power 
    
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq  =   400000 [kHz]
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq  =  3100000 [kHz]
    /sys/devices/system/cpu/cpu1/cpufreq/energy_performance_preference = balance_performance
    /sys/devices/system/cpu/cpu1/cpufreq/energy_performance_available_preferences = default performance balance_performance balance_power power 
    
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_min_freq  =   400000 [kHz]
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_max_freq  =  3100000 [kHz]
    /sys/devices/system/cpu/cpu2/cpufreq/energy_performance_preference = balance_performance
    /sys/devices/system/cpu/cpu2/cpufreq/energy_performance_available_preferences = default performance balance_performance balance_power power 
    
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_min_freq  =   400000 [kHz]
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_max_freq  =  3100000 [kHz]
    /sys/devices/system/cpu/cpu3/cpufreq/energy_performance_preference = balance_performance
    /sys/devices/system/cpu/cpu3/cpufreq/energy_performance_available_preferences = default performance balance_performance balance_power power 
    
    /sys/devices/system/cpu/intel_pstate/min_perf_pct      =  12 [%]
    /sys/devices/system/cpu/intel_pstate/max_perf_pct      = 100 [%]
    /sys/devices/system/cpu/intel_pstate/no_turbo          =   0
    /sys/devices/system/cpu/intel_pstate/turbo_pct         =  22 [%]
    /sys/devices/system/cpu/intel_pstate/num_pstates       =  28
    
    x86_energy_perf_policy: program not installed.
    
    /sys/module/workqueue/parameters/power_efficient       = Y
    /proc/sys/kernel/nmi_watchdog                          = 1
    
    +++ Undervolting
    PHC kernel not available.
    
    +++ Temperatures
    CPU temp               =    56 [°C]
    Fan speed (fan1)       =     0 [/min]
    
    +++ File System
    /proc/sys/vm/laptop_mode               =     0
    /proc/sys/vm/dirty_writeback_centisecs =   500
    /proc/sys/vm/dirty_expire_centisecs    =  3000
    /proc/sys/vm/dirty_ratio               =    20
    /proc/sys/vm/dirty_background_ratio    =    10
    
    +++ Storage Devices
    /dev/sda:
      Model     = SanDisk Z400s 2.5 7MM 256GB             
      Firmware  = Z2327012
      APM Level = 128
      Status    = active/idle
      TRIM      = supported
      Scheduler = deadline
    
      Runtime PM: control = on, autosuspend_delay =   -1
    
    
    +++ SATA Aggressive Link Power Management
    /sys/class/scsi_host/host0/link_power_management_policy  = max_performance
    
    +++ AHCI Host Controller Runtime Power Management
    /sys/bus/pci/devices/0000:00:17.0/ata1/power/control = on
    
    +++ PCIe Active State Power Management
    /sys/module/pcie_aspm/parameters/policy = default (using bios preferences)
    
    +++ Intel Graphics
    /sys/module/i915/parameters/enable_rc6       =  1 (enabled)
    /sys/module/i915/parameters/enable_dc        = -1 (use per-chip default)
    /sys/module/i915/parameters/enable_fbc       =  1 (enabled)
    /sys/module/i915/parameters/enable_psr       =  0 (disabled)
    /sys/module/i915/parameters/modeset          = -1 (use per-chip default)
    /sys/module/i915/parameters/semaphores       =  0 (disabled)
    
    +++ Wireless
    bluetooth = on
    wifi      = on
    wwan      = none (no device)
    
    hci0(btusb)                   : bluetooth, not connected
    wlp1s0(iwlwifi)               : wifi, connected, power management = on
    
    +++ Audio
    /sys/module/snd_hda_intel/parameters/power_save            = 0
    /sys/module/snd_hda_intel/parameters/power_save_controller = Y
    
    +++ Runtime Power Management
    Device blacklist = (not configured)
    Driver blacklist = amdgpu nouveau nvidia radeon (default)
    
    /sys/bus/pci/devices/0000:00:00.0/power/control = on   (0x060000, Host bridge, skl_uncore)
    /sys/bus/pci/devices/0000:00:02.0/power/control = on   (0x030000, VGA compatible controller, i915)
    /sys/bus/pci/devices/0000:00:04.0/power/control = on   (0x118000, Signal processing controller, proc_thermal)
    /sys/bus/pci/devices/0000:00:14.0/power/control = on   (0x0c0330, USB controller, xhci_hcd)
    /sys/bus/pci/devices/0000:00:15.0/power/control = auto (0x118000, Signal processing controller, intel-lpss)
    /sys/bus/pci/devices/0000:00:15.1/power/control = auto (0x118000, Signal processing controller, intel-lpss)
    /sys/bus/pci/devices/0000:00:16.0/power/control = on   (0x078000, Communication controller, mei_me)
    /sys/bus/pci/devices/0000:00:17.0/power/control = on   (0x010601, SATA controller, ahci)
    /sys/bus/pci/devices/0000:00:1c.0/power/control = auto (0x060400, PCI bridge, pcieport)
    /sys/bus/pci/devices/0000:00:1f.0/power/control = on   (0x060100, ISA bridge, no driver)
    /sys/bus/pci/devices/0000:00:1f.2/power/control = on   (0x058000, Memory controller, intel_pmc_core)
    /sys/bus/pci/devices/0000:00:1f.3/power/control = on   (0x040300, Audio device, snd_hda_intel)
    /sys/bus/pci/devices/0000:00:1f.4/power/control = auto (0x0c0500, SMBus, i801_smbus)
    /sys/bus/pci/devices/0000:01:00.0/power/control = on   (0x028000, Network controller, iwlwifi)
    
    +++ USB
    Autosuspend         = enabled
    Device whitelist    = (not configured)
    Device blacklist    = (not configured)
    Bluetooth blacklist = disabled
    Phone blacklist     = disabled
    WWAN blacklist      = enabled
    
    Bus 002 Device 003 ID xxx control = on,   autosuspend_delay_ms =  2000 -- ASIX Electronics Corp. AX88179 Gigabit Ethernet (ax88179_178a)
    Bus 002 Device 002 ID xxx control = auto, autosuspend_delay_ms =     0 -- Genesys Logic, Inc.  (hub)
    Bus 002 Device 001 ID xxx control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 3.0 root hub (hub)
    Bus 001 Device 008 ID xxx control = on,   autosuspend_delay_ms =  2000 -- Intel Corp.  (btusb)
    Bus 001 Device 007 ID xxx control = on,   autosuspend_delay_ms =  2000 -- Elan Microelectronics Corp.  (usbhid)
    Bus 001 Device 006 ID xxx control = auto, autosuspend_delay_ms =  2000 -- Sunplus Innovation Technology Inc.  (uvcvideo)
    Bus 001 Device 005 ID xxx control = on,   autosuspend_delay_ms =  2000 -- STMicroelectronics Sensor Hub (usbhid)
    Bus 001 Device 003 ID xxx control = on,   autosuspend_delay_ms =  2000 -- <unknown> (usbhid)
    Bus 001 Device 004 ID xxx control = on,   autosuspend_delay_ms =  2000 -- MosArt Semiconductor Corp. Wireless Keyboard/Mouse (usbhid)
    Bus 001 Device 002 ID xxx control = auto, autosuspend_delay_ms =     0 -- Genesys Logic, Inc. 4-port hub (hub)
    Bus 001 Device 001 ID xxx control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 2.0 root hub (hub)
    
    +++ Battery Status
    /sys/class/power_supply/BAT0/manufacturer                   = Sanyo
    /sys/class/power_supply/BAT0/model_name                     = DELL 4K8YH63
    /sys/class/power_supply/BAT0/cycle_count                    = (not supported)
    /sys/class/power_supply/BAT0/charge_full_design             =   4180 [mAh]
    /sys/class/power_supply/BAT0/charge_full                    =   3556 [mAh]
    /sys/class/power_supply/BAT0/charge_now                     =   4180 [mAh]
    /sys/class/power_supply/BAT0/current_now                    =      1 [mA]
    /sys/class/power_supply/BAT0/status                         = Full
    
    Charge                                                      =  117.5 [%]
    Capacity                                                    =   85.1 [%]
    
    +++ Suggestions
    * Install ethtool to disable Wake On LAN (WOL)
    * Install smartmontools for disk drive health info
                                                                                                                                                                
    ➜  ~ inxi -Fxxc0
    Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
    System:    Host: xxx Kernel: 4.13.12-1-ARCH x86_64 bits: 64 gcc: 7.2.0
               Desktop: KDE Plasma 5.11.4 (Qt 5.9.3) dm: lightdm Distro: Antergos Linux
    Machine:   Device: laptop System: Dell product: Inspiron 13-7359 serial: N/A  Chassis: type: 9 serial: N/A
               Mobo: Dell model: 0WJF7F v: A00 serial: N/A UEFI: Dell v: 01.06.00 date: 02/25/2016
    Battery    BAT0: charge: 45.1 Wh 117.5% condition: 38.4/45.1 Wh (85%) volts: 12.5/10.8
               model: Sanyo DELL 4K8YH63 serial: 480 status: Full
    CPU:       Dual core Intel Core i7-6500U (-HT-MCP-) arch: Skylake rev.3 cache: 4096 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10372
               clock speeds: min/max: 400/3100 MHz 1: 2081 MHz 2: 632 MHz 3: 500 MHz 4: 500 MHz
    Graphics:  Card: Intel HD Graphics 520 bus-ID: xxx chip-ID: xxx
               Display Server: N/A drivers: modesetting (unloaded: fbdev,vesa) tty size: 171x21
    Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: xxx chip-ID: xxx
               Sound: Advanced Linux Sound Architecture v: k4.13.12-1-ARCH
    Network:   Card: Intel Wireless 3165 driver: iwlwifi bus-ID: xxx chip-ID: xxx
               IF: wlp1s0 state: up mac: xxx
    Drives:    HDD Total Size: 256.1GB (16.8% used)
               ID-1: /dev/sda model: SanDisk_Z400s_2. size: 256.1GB serial: xxx
    Partition: ID-1: / size: 68G used: 33G (49%) fs: ext4 dev: /dev/sda6
               ID-2: swap-1 size: 8.44GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
    Sensors:   System Temperatures: cpu: 48.0C mobo: 27.8C
               Fan Speeds (in rpm): cpu: N/A
    Info:      Processes: 179 Uptime: 1:10 Memory: 3256.3/7843.8MB Init: systemd v: 235 Gcc sys: 7.2.0
               Client: Shell (zsh 5.4.2 running in yakuake) inxi: 2.3.51
    
    
  • @asdfasdfvful said in Mouse movement triggers screen when lid is closed:

    Notice: tlp.service is not enabled -- invoke "systemctl enable tlp.service" to correct this!
    Notice: tlp-sleep.service is not enabled -- invoke "systemctl enable tlp-sleep.service" to correct this!
    Notice: systemd-rfkill.service is not masked -- invoke "systemctl mask systemd-rfkill.service" to correct this!
    

    Notice: tlp.service is not enabled – invoke “systemctl enable tlp.service” to correct this!
    Notice: tlp-sleep.service is not enabled – invoke “systemctl enable tlp-sleep.service” to correct this!
    Notice: systemd-rfkill.service is not masked – invoke “systemctl mask systemd-rfkill.service” to correct this!

    and then reboot

    ?

  • I have done so.

    Extra log:

    --- TLP 1.0 --------------------------------------------
    
    +++ Configured Settings: /etc/default/tlp
    TLP_ENABLE=1
    TLP_DEFAULT_MODE=AC
    TLP_PERSISTENT_DEFAULT=0
    DISK_IDLE_SECS_ON_AC=0
    DISK_IDLE_SECS_ON_BAT=2
    MAX_LOST_WORK_SECS_ON_AC=15
    MAX_LOST_WORK_SECS_ON_BAT=60
    CPU_HWP_ON_AC=balance_performance
    CPU_HWP_ON_BAT=balance_power
    SCHED_POWERSAVE_ON_AC=0
    SCHED_POWERSAVE_ON_BAT=1
    NMI_WATCHDOG=0
    ENERGY_PERF_POLICY_ON_AC=performance
    ENERGY_PERF_POLICY_ON_BAT=powersave
    DISK_DEVICES="sda sdb"
    DISK_APM_LEVEL_ON_AC="254 254"
    DISK_APM_LEVEL_ON_BAT="128 128"
    SATA_LINKPWR_ON_AC=max_performance
    SATA_LINKPWR_ON_BAT=min_power
    AHCI_RUNTIME_PM_TIMEOUT=15
    PCIE_ASPM_ON_AC=performance
    PCIE_ASPM_ON_BAT=powersave
    RADEON_POWER_PROFILE_ON_AC=high
    RADEON_POWER_PROFILE_ON_BAT=low
    RADEON_DPM_STATE_ON_AC=performance
    RADEON_DPM_STATE_ON_BAT=battery
    RADEON_DPM_PERF_LEVEL_ON_AC=auto
    RADEON_DPM_PERF_LEVEL_ON_BAT=auto
    WIFI_PWR_ON_AC=off
    WIFI_PWR_ON_BAT=on
    WOL_DISABLE=Y
    SOUND_POWER_SAVE_ON_AC=0
    SOUND_POWER_SAVE_ON_BAT=1
    SOUND_POWER_SAVE_CONTROLLER=Y
    BAY_POWEROFF_ON_AC=0
    BAY_POWEROFF_ON_BAT=0
    BAY_DEVICE="sr0"
    RUNTIME_PM_ON_AC=on
    RUNTIME_PM_ON_BAT=auto
    USB_AUTOSUSPEND=1
    USB_BLACKLIST_BTUSB=0
    USB_BLACKLIST_PHONE=0
    USB_BLACKLIST_WWAN=1
    RESTORE_DEVICE_STATE_ON_STARTUP=0
    
    
  • @asdfasdfvful said in Mouse movement triggers screen when lid is closed:

    I’ve set my screen to turn off when I close the lid, in all power options.
    If I close the lid, and open it again without touching the mouse, it will turn the screen on when I open it, as expected.

    This still does not happen?

  • The screen is still turning on if I close the lid and move the mouse. Didn’t those services just help with retrieving stats? I don’t think it would have affected by issue.

  • @asdfasdfvful said in Mouse movement triggers screen when lid is closed:

    The screen is still turning on if I close the lid and move the mouse. Didn’t those services just help with retrieving stats? I don’t think it would have affected by issue.

    If you close the lid without touching the mouse, what happens?

  • If I close the lid, the screen turns off. If I don’t touch the mouse, it will stay off until I open it again. However, if I move my mouse when the lid is closed, the screen will turn back on.

mouse61 lid13 triggers1 movement1 Posts 9Views 694
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.