• Unable to add keyboard layout


    First i wanna say that i read this topic https://forum.antergos.com/topic/3122/how-to-change-keyboard-language
    also read https://forum.antergos.com/topic/2346/unable-to-add-keyboard-layout

    Now i am confused as to why there is this limitation that you have to change your input language at first boot, is this just for gnome 3 ? or in general for Antergos - Arch ? man this is stupid…

    Second i did a sudo nano /etc/locale.gen, uncommented the line el_GR.UTF-8 UTF-8 then did a sudo locale and got:
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC=en_US.UTF-8
    LC_TIME=en_US.UTF-8
    LC_COLLATE=en_US.UTF-8
    LC_MONETARY=en_US.UTF-8
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER=en_US.UTF-8
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT=en_US.UTF-8
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=

    Then i did a sudo localectl set-locale LANG=el_GR.UTF-8
    Then i did a sudo locale-gen and got
    Generating locales…
    en_US.UTF-8…1 done
    el_GR.UTF-8… done
    en_US.UTF-8… done

    Now i go to Settings --> Region & Language and click the “+” i type Greek and above it displays Greek, Modern (1453-) but i cant add it as input language…

  • @dreamtraveler said in Unable to add keyboard layout:

    Now i am confused as to why there is this limitation that you have to change your input language at first boot, is this just for gnome 3 ?

    “Input language” is not defined in Gnome. You’re probably speaking about “input source”. Input source is simply a physical or on-screen keyboard with a specific layout.

    No, there’s no need to reboot or logout-login if input sources are changed. All changes become immediately available in the current Xorg or Wayland session, right after running sudo locale-gen command.

    …then did a sudo locale and got:…

    sudo locale has nothing to do with input sources. It only lists regional-specific formats for displaying numbers, currency, dates, time, paper layouts, sort order, names, phones, etc.

    Then i did a sudo localectl set-locale LANG=el_GR.UTF-8

    Again, it has nothing to do with input sources. It simply sets up regional-specific display formats. It has no effect for input sources.

    Now i go to Settings --> Region & Language and click the “+” i type Greek and above it displays Greek, Modern (1453-) but i cant add it as input language…

    It can’t be explained. I don’t speak Greek, but to test your case I added Greek to my languages and input sources a few seconds ago:

    0_1512206323124_gnome-greek-input-source-01-2017.12.02.png

    And finally:

    0_1512206370308_gnome-greek-input-source-02-2017.12.02.png

    The sequence to add it is very simple:

    1. uncomment el_GR.UTF-8 UTF-8 in /etc/locale.gen, as you did

    2. run sudo locale-gen, as you did

    3. open Gnome Settings, and then Region & Language --> click + in Input Sources section --> click three vertical dots --> type in gre in input field at the bottom of the dialog --> click Other --> the list with Greek, Greek (extended), Greek (no dead keys), Greek (polytonic), Greek (simple) options opens --> click Greek --> click the Add button at the top right corner of the dialog

    All of the above without any reboots or logouts.

  • @just said in Unable to add keyboard layout:

    The sequence to add it is very simple:

    1. uncomment el_GR.UTF-8 UTF-8 in /etc/locale.gen, as you did

    2. run sudo locale-gen, as you did

    3. open Gnome Settings, and then Region & Language --> click + in Input Sources section --> click three vertical dots --> type in gre in input field at the bottom of the dialog --> click Other --> the list with Greek, Greek (extended), Greek (no dead keys), Greek (polytonic), Greek (simple) options opens --> click Greek --> click the Add button at the top right corner of the dialog

    All of the above without any reboots or logouts.
    @just
    This is what i get i can see the Greek but cant add them the button is grayed out
    0_1512222638225_Screenshot from 2017-12-02 15-30-34.png

  • @dreamtraveler I cannot reproduce your problem. Everything works fine here.

    When I was installing Greek for the 1st time, I saw Greek, Modern (1453-) somewhere too. But it doesn’t appear anymore now. Locale files, once installed, remain in the system, even if a locale was removed later. So some preliminary steps are not needed when the same locale is re-enabled, and DE just skips them.

    Try to click on Greek, Modern (1453-) - it may be a button.

    When the + button in Input Sources section is clicked for the 1st time, the Add an Input Source dialog is very small:

    0_1512227985125_gnome-greek-input-source-03-2017.12.02.png

    But the dialog’s window is resizeable. Enlarge it by dragging window’s corners:
    0_1512228039757_gnome-greek-input-source-04-2017.12.02.png

    If you see the More… button - three vertical dots - click it. You should see English and Others input sources:
    0_1512228135578_gnome-greek-input-source-05-2017.12.02.png

    Click on Others button. A huge list of all available input sources will appear:
    0_1512228205314_gnome-greek-input-source-06-2017.12.02.png

    Now, when I start typing gre all Greek input sources are presented, without an intermediate Greek, Modern (1453-) step:
    0_1512228343647_gnome-greek-input-source-07-2017.12.02.png

    Resize the dialogs and click everywhere within them, even if something seems to be grayed out. Don’t count on colors. Click and see what happens.

  • @dreamtraveler

    Run only this on console:

    $ export LANG=el_GR.UTF-8

    ?

  • @just said in Unable to add keyboard layout:

    Resize the dialogs and click everywhere within them, even if something seems to be grayed out. Don’t count on colors. Click and see what happens.

    yeah resizing did it thank you

  • @dreamtraveler said in Unable to add keyboard layout:

    yeah resizing did it thank you

    An example of perversive Gnome 3 design principles. Let’s make DE as less user friendly as possible.

    Why show a Menu button? A user might easily find out all installed apps. We’ll remove menu button.

    Why show applications icons when Applications button is clicked? We’ll remove the icons. A user must know all installed apps without any clue, without menu, without apps icons.

    Why auto-resize a window to fit all available items? A user must know that some elements are hidden. We won’t auto-resize a window.

    Why show up a scrollbar within it? A user might figure out that more items are available. We won’t show a scrollbar.

    Why add visual clues to window borders? A user might figure out that a window may be enlarged. It would help him to see all available items. We won’t add visual clues.

    Go figure.

  • @just said in Unable to add keyboard layout:

    @dreamtraveler said in Unable to add keyboard layout:

    yeah resizing did it thank you

    An example of perversive Gnome 3 design principles. Let’s make DE as less user friendly as possible.

    Why show a Menu button? A user might easily find out all installed apps. We’ll remove menu button.

    Why show applications icons when Applications button is clicked? We’ll remove the icons. A user must know all installed apps without any clue, without menu, without apps icons.

    Why auto-resize a window to fit all available items? A user must know that some elements are hidden. We won’t auto-resize a window.

    Why show up a scrollbar within it? A user might figure out that more items are available. We won’t show a scrollbar.

    Why add visual clues to window borders? A user might figure out that a window may be enlarged. It would help him to see all available items. We won’t add visual clues.

    Go figure.

    you forgot to mention the hardcoded “Computer” in Nautilus…

layout7 unable43 keyboard45 Posts 8Views 237
Log in to reply