• Problem installing SDDM


    Hi there

    I’m having an issue with trying to switch from lightdm to SDDM. I have installed SDDM and ran

    sudo systemctl disable lightdm
    sudo systemctl enable sddm
    

    It then tells me that the symbolic link has been created. I then reboot the computer but after getting to the black screen it just hangs. I can use ctl-alt-f2 to get into the command line where I can switch back to lightdm and my computer will boot again.

    Does anyone have any ideas why this may be the case?

  • @mattrbrousseau
    It seems to me that you did everything right…
    Just in case try again:
    sudo pacman -S sddm sddm-kcm
    sudo systemctl enable -f sddm
    reboot

    And if you find the same error again try:
    sudo systemctl start sddm
    see if there are errors…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • i would suggest to completely uninstall “Antergos-lightdm” to get sddm working well!

    sudo pacman -Rsc lightdm lightdm-webkit2-greeter light-locker
    

    disable all DM’s and first boot into cli > login as root > start sddm manually:

    sudo systemctl disable sddm
    

    reboot

    login as user to TTY3 [Ctrl+Alt+F3] and start the journalview:
    journalctl -f

    open TTY4 [Ctrl+Alt+F4] login as root and start sddm:

    systemctl start sddm
    

    if this is working you can automaticly enable sddm systemctl enable sddm
    If not get status:

    systemctl status sddm
    

    Go back to TTY2 and see what goes wrong…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Thanks for your help @joekamprad and @fernandomaroto. It turns out that it was that I hadn’t downloaded the sddm-kcm package as well. I had looked up sddm on the arch wiki and didn’t notice anything about having to install it so I didn’t. Thanks

installing69 sddm10 Posts 4Views 111
Log in to reply