• Set dedicated GPU as primary


    Hi guys,
    First of all my problem is to set up dedicated GPU as primary all the time
    I know that there was many topics here about this problem. However maybe in my case you will be able to help me.
    From the begining:
    My laptop have 2 GPU (intel integrated + AMD HD6370 mobile)
    In BIOS i can’t disable integrated GPU

    1. I’ve installed Antergos with Deepin DE
    2. Install xf86-video-ati and add MODULES=“radeon” in /etc/mkinitcpio.conf then run > mkinitcpio -p linux
    3. Laptop was restarted and xrandr output was:
      Providers: number : 2
      Provider 0: id: 0x69 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 2 outputs: 4 associated providers: 1 name:modesetting
      Provider 1: id: 0x43 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 0 associated providers: 1 name:ATI Mobility Radeon Graphics @ pci:0000:01:00.0

    inxi -F

    Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
               Card-2: Advanced Micro Devices [AMD/ATI] Robson CE [Radeon HD 6370M/7370M]
               Display Server: x11 (X.Org 1.19.5 ) drivers: modesetting,ati,radeon (unloaded: fbdev,vesa)
               Resolution: [email protected]
               OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile version: 3.3 Mesa 17.2.6
    
    

    when I run with DRI_PRIME=1 “program” AMD card is visible as:
    GPU: AMD CEDAR (DRM 2.50.0 / 4.13.12-1-ARCH, LLVM 5.0.0)

    To setup dedicated GPU all the time I tried to use PRIME reverse but without effect:

    1. I prepared mygpu.conf (below)
    2. Restart computer - but it hangs during loading DE - I can only access to command line with CTRL+ALT_Fx
    3. After remove this file - all works
    4. Also I tried to build Xorg but also gets error (attched logs from Xorg - good, and bad run, bad run is the old)

    Any idea how to fix this ?
    I also try blacklist “i915” but without any effect

    Section "ServerLayout"
        Identifier "layout"
        Screen 0 "radeon"
        Inactive "intel"
    EndSection
    
    
    Section "Device"
        Identifier  "radeon"
        Driver      "radeon"
    EndSection
    
    
    Section "Screen"
        Identifier "radeon"
        Device "radeon"
    EndSection
    
    
    Section "Device"
        Identifier  "intel"
        Driver      "i915"
    EndSection
    
    
    Section "Screen"
        Identifier "intel"
        Device "intel"
    EndSection
    

    I can’t add files so here are the links:
    xorg.old
    xorg.good

  • @szuuto welcome!!!

    Read this complete thread and you will have to do:

    https://forum.antergos.com/topic/8466/amd-graphics-card-problems?page=1

  • @judd Hi,
    I read this and try to follow this instructions however I stuck with this what I wrote. On the other hand - it is possible that AMD will have worse performance than integrated gpu intel on Linux (maybe I should try use proprietary driver - it will have better performance) ?

  • @szuuto said in Set dedicated GPU as primary:

    (maybe I should try use proprietary driver - it will have better performance) ?

    It’s a matter of trying, just that. ;)

  • Hi,
    I was tried to install proprietary drivers and I follow these steps:

    1. remove xf86-video-ati drivers - success
    2. add keys to use unofficial repositories for Catalyst - acroding to Xorg#AMD I should use Catalyst since my card is AMD HD6370 mobile - and I should have xorg116 ?? Or maybe [xorg112] - what do you think ?
    3. added to /etc/pacman.conf
     [xorg116]
     Server = http://mirror.hactar.xyz/Vi0L0/xorg116/$arch
      [catalyst]
     Server = https://mirror.hactar.xyz/Vi0L0/catalyst/$arch
    
    
    1. get updates: sudo pacman -Syuu
    2. sudo pacman -S catalyst-hook catalyst-libgl catalyst-utils acpid qt4
    3. enable Drivers and set to start on boot
    4. Problem starts here when I try > aticonfig --initial i get output:
    aticonfig: No supported adapters detected.
    

    What do you think ? Maybe I used wrong xorg ?

  • @szuuto said in Set dedicated GPU as primary:

    Maybe I used wrong xorg ?

    It is very likely, look in this list of xorg and try the one you think is more accurate:

    $ sudo pacman -Ss xorg
    [sudo] password for judd: 
    extra/xf86-input-evdev 2.10.5-1 (xorg-drivers)
        X.org evdev input driver
    extra/xf86-input-keyboard 1.9.0-2 (xorg-drivers) [instalado]
        X.Org keyboard input driver
    extra/xf86-input-libinput 0.26.0-1 (xorg-drivers) [instalado]
        Generic input driver for the X.Org server based on libinput
    extra/xf86-input-mouse 1.9.2-3 (xorg-drivers) [instalado]
        X.org mouse input driver
    extra/xf86-input-synaptics 1.9.0-1 (xorg-drivers) [instalado]
        Synaptics driver for notebook touchpads
    extra/xf86-input-vmmouse 13.1.0-3 (xorg-drivers) [instalado]
        X.org VMWare Mouse input driver
    extra/xf86-input-void 1.4.1-3 (xorg-drivers)
        X.org void input driver
    extra/xf86-video-amdgpu 1.4.0-1 (xorg-drivers)
        X.org amdgpu video driver
    extra/xf86-video-ati 1:7.10.0-1 (xorg-drivers) [instalado]
        X.org ati video driver
    extra/xf86-video-dummy 0.3.8-2 (xorg-drivers)
        X.org dummy video driver
    extra/xf86-video-fbdev 0.4.4+12+ge0bce0d-1 (xorg-drivers) [instalado]
        X.org framebuffer video driver
    extra/xf86-video-intel 1:2.99.917+800+g37a682aa-1 (xorg-drivers) [instalado]
        X.org Intel i810/i830/i915/945G/G965+ video drivers
    extra/xf86-video-nouveau 1.0.15-2 (xorg-drivers) [instalado]
        Open Source 2D acceleration driver for nVidia cards
    extra/xf86-video-openchrome 0.6.0-2 (xorg-drivers) [instalado]
        X.Org Openchrome drivers
    extra/xf86-video-vesa 2.3.4-4 (xorg-drivers xorg) [instalado]
        X.org vesa video driver
    extra/xf86-video-vmware 13.2.1-3 (xorg-drivers) [instalado]
        X.org vmware video driver
    extra/xf86-video-voodoo 1.2.5-9 (xorg-drivers)
        X.org 3dfx Voodoo1/Voodoo2 2D video driver
    extra/xorg-appres 1.0.4-1
        List X application resource database
    extra/xorg-bdftopcf 1.1-1 (xorg xorg-apps) [instalado]
        Convert X font from Bitmap Distribution Format to Portable Compiled Format
    extra/xorg-docs 1.7.1-1 (xorg) [instalado]
        X.org documentations
    extra/xorg-font-util 1.3.1-1 (xorg-fonts xorg) [instalado]
        X.Org font utilities
    extra/xorg-font-utils 7.6-4 [instalado]
        Transitional package depending on xorg font utilities
    extra/xorg-fonts-100dpi 1.0.3-3 (xorg) [instalado]
        X.org 100dpi fonts
    extra/xorg-fonts-75dpi 1.0.3-3 (xorg) [instalado]
        X.org 75dpi fonts
    extra/xorg-fonts-alias 1.0.3-1 [instalado]
        X.org font alias files
    extra/xorg-fonts-cyrillic 1.0.3-2
        X.org cyrillic fonts
    extra/xorg-fonts-encodings 1.0.4-4 (xorg-fonts xorg) [instalado]
        X.org font encoding files
    extra/xorg-fonts-misc 1.0.3-5 [instalado]
        X.org misc fonts
    extra/xorg-fonts-type1 7.7-2
        X.org Type1 fonts
    extra/xorg-iceauth 1.0.7-1 (xorg-apps xorg) [instalado]
        ICE authority file utility
    extra/xorg-luit 1.1.1-2 (xorg xorg-apps) [instalado]
        Filter that can be run between an arbitrary application and a UTF-8 terminal
        emulator
    extra/xorg-mkfontdir 1.0.7-8 (xorg xorg-apps) [instalado]
        Create an index of X font files in a directory
    extra/xorg-mkfontscale 1.1.2-1 (xorg-apps xorg) [instalado]
        Create an index of scalable font files for X
    extra/xorg-oclock 1.0.3-2
        Round X clock
    extra/xorg-server 1.19.5-1 (xorg) [instalado]
        Xorg X server
    extra/xorg-server-common 1.19.5-1 (xorg) [instalado]
        Xorg server common files
    extra/xorg-server-devel 1.19.5-1 (xorg) [instalado]
        Development files for the X.Org X server
    extra/xorg-server-xdmx 1.19.5-1 (xorg) [instalado]
        Distributed Multihead X Server and utilities
    extra/xorg-server-xephyr 1.19.5-1 (xorg) [instalado]
        A nested X server that runs as an X application
    extra/xorg-server-xnest 1.19.5-1 (xorg) [instalado]
        A nested X server that runs as an X application
    extra/xorg-server-xvfb 1.19.5-1 (xorg) [instalado]
        Virtual framebuffer X server
    extra/xorg-server-xwayland 1.19.5-1 (xorg) [instalado]
        run X clients under wayland
    extra/xorg-sessreg 1.1.1-1 (xorg-apps xorg) [instalado]
        Register X sessions in system utmp/utmpx databases
    extra/xorg-setxkbmap 1.3.1-1 (xorg-apps xorg) [instalado]
        Set the keyboard using the X Keyboard Extension
    extra/xorg-smproxy 1.0.6-1 (xorg-apps xorg) [instalado]
        Allows X applications that do not support X11R6 session management to
        participate in an X11R6 session
    extra/xorg-twm 1.0.9-1
        Tab Window Manager for the X Window System
    extra/xorg-util-macros 1.19.1-1 [instalado]
        X.Org Autotools macros
    extra/xorg-x11perf 1.6.0-1 (xorg-apps xorg) [instalado]
        Simple X server performance benchmarker
    extra/xorg-xauth 1.0.10-1 (xorg-apps xorg) [instalado]
        X.Org authorization settings program
    extra/xorg-xbacklight 1.2.1-1 (xorg-apps xorg) [instalado]
        RandR-based backlight control application
    extra/xorg-xbiff 1.0.3-3
        Watch mailboxes for new message delivery
    extra/xorg-xcalc 1.0.6-1
        Scientific calculator for X
    extra/xorg-xclipboard 1.1.3-1
        X clipboard manager
    extra/xorg-xclock 1.0.7-1
        X clock
    extra/xorg-xcmsdb 1.0.5-1 (xorg-apps xorg) [instalado]
        Device Color Characterization utility for X Color Management System
    extra/xorg-xconsole 1.0.7-1
        Monitor system console messages with X
    extra/xorg-xcursorgen 1.0.6-1 (xorg-apps xorg) [instalado]
        Create an X cursor file from PNG images
    extra/xorg-xdm 1.1.11-6
        X Display Manager
    extra/xorg-xdpyinfo 1.3.2-1 (xorg-apps xorg) [instalado]
        Display information utility for X
    extra/xorg-xdriinfo 1.0.5-2 (xorg-apps xorg) [instalado]
        Query configuration information of DRI drivers
    extra/xorg-xedit 1.2.2-1
        Simple text editor for X
    extra/xorg-xev 1.2.2-1 (xorg-apps xorg) [instalado]
        Print contents of X events
    extra/xorg-xeyes 1.1.1-3
        Follow the mouse/SHAPE extension X demo
    extra/xorg-xfd 1.1.2-1
        Displays all the characters in a font using either the X11 core protocol or
        libXft2
    extra/xorg-xfontsel 1.0.5-1
        Point and click selection of X11 font names
    extra/xorg-xgamma 1.0.6-1 (xorg-apps xorg) [instalado]
        Alter a monitor's gamma correction
    extra/xorg-xhost 1.0.7-1 (xorg-apps xorg) [instalado]
        Server access control program for X
    extra/xorg-xinit 1.3.4-4 [instalado]
        X.Org initialisation program
    extra/xorg-xinput 1.6.2-1 (xorg-apps xorg) [instalado]
        Small commandline tool to configure devices
    extra/xorg-xkbcomp 1.4.0-1 (xorg-apps xorg) [instalado]
        X Keyboard description compiler
    extra/xorg-xkbevd 1.1.4-1 (xorg-apps xorg) [instalado]
        XKB event daemon
    extra/xorg-xkbutils 1.0.4-2 (xorg-apps xorg) [instalado]
        XKB utility demos
    extra/xorg-xkill 1.0.4-1 (xorg-apps xorg) [instalado]
        Kill a client by its X resource
    extra/xorg-xload 1.1.2-1
        System load average display for X
    extra/xorg-xlogo 1.0.4-2
        Draw [old] X logo
    extra/xorg-xlsatoms 1.1.2-1 (xorg-apps xorg) [instalado]
        List interned atoms defined on server
    extra/xorg-xlsclients 1.1.3-1 (xorg-apps xorg) [instalado]
        List client applications running on a display
    extra/xorg-xlsfonts 1.0.5-1
        List available X fonts
    extra/xorg-xmag 1.0.6-1
        Magnify parts of the screen
    extra/xorg-xman 1.1.4-1
        Unix manual page viewer
    extra/xorg-xmessage 1.0.4-2
        Display a message or query in a window
    extra/xorg-xmodmap 1.0.9-1 (xorg-apps xorg) [instalado]
        Utility for modifying keymaps and button mappings
    extra/xorg-xpr 1.0.4-2 (xorg-apps xorg) [instalado]
        Print an X window dump from xwd
    extra/xorg-xprop 1.2.2-1 (xorg-apps xorg) [instalado]
        Property displayer for X
    extra/xorg-xrandr 1.5.0-1 (xorg-apps xorg) [instalado]
        Primitive command line interface to RandR extension
    extra/xorg-xrdb 1.1.0-2 (xorg-apps xorg) [instalado]
        X server resource database utility
    extra/xorg-xrefresh 1.0.5-1 (xorg-apps xorg) [instalado]
        Refresh all or part of an X screen
    extra/xorg-xset 1.2.3-1 (xorg-apps xorg) [instalado]
        User preference utility for X
    extra/xorg-xsetroot 1.1.1-2 (xorg-apps xorg) [instalado]
        Classic X utility to set your root window background to a given pattern or
        color
    extra/xorg-xvidtune 1.0.3-2
        Video mode tuner for Xorg
    extra/xorg-xvinfo 1.1.3-1 (xorg-apps xorg) [instalado]
        Prints out the capabilities of any video adaptors associated with the
        display that are accessible through the X-Video extension
    extra/xorg-xwd 1.0.6-1 (xorg-apps xorg) [instalado]
        X Window System image dumping utility
    extra/xorg-xwininfo 1.1.3-1 (xorg-apps xorg) [instalado]
        Command-line utility to print information about windows on an X server
    extra/xorg-xwud 1.0.4-2 (xorg-apps xorg) [instalado]
        X Window System image undumping utility
    community/boinc-nox 7.8.4-1
        Berkeley Open Infrastructure for Network Computing for desktop without Xorg
        dependencies
    community/xf86-video-qxl 0.1.5-5 (xorg-drivers)
        Xorg X11 qxl video driver
    
  • Hi,
    thanks for help - but I already resolved the problem.

    For some reason fglrx was disabled - so I needed enable this and also install video drivers for intel integrated card since after reboot he want to use it to start xorg.
    Also after reboot I could run aticonfig --initial and switch to dedicated GPU.

    However - it looks like CATALYST drivers are not so efficent like on Windows.

  • @szuuto
    You could add this to the wiki… You’re the first people here that managed to install AMD drivers. I just gave up some time ago :)

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @szuuto congratz!

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Hi all,
    I will present below step by step what I’ve done:
    background hardware: Lenovo G570 ( GPU integrated: Intel , GPU dedicated: AMD HD6370 mobile)
    background software: Xorg 1.19 / clean system with Desktop Deepin

    1. sudo pacman-key -r 653C3094
    2. sudo pacman-key --lsign-key 653C3094
    
    3. in sudo nano /etc/pacman.conf add:
    [xorg116]
    Server = http://mirror.hactar.xyz/Vi0L0/xorg116/$arch
    [catalyst]
    Server = https://mirror.hactar.xyz/Vi0L0/catalyst/$arch
    
    # Xorg 1.19 use libxfont2 but Xorg 1.16 use libxfont so we need instal libxfont and remove libxfont2
    4. sudo pacman -U https://archive.archlinux.org/packages/l/libxfont/libxfont-1.5.3-1-x86_64.pkg.tar.xz
    5. remove libxfont2 using AUR
    
    update system (downgrade):
    6. sudo pacman -Syuu
    install AMD Catalyst drivers + hwinfo + screenfetch:
    7. sudo pacman -S catalyst-hook catalyst-libgl catalyst-utils acpid qt4 hwinfo screenfetch
    
    Enable Drivers and set to start on boot:
    8. sudo systemctl enable atieventsd
    9. sudo systemctl start atieventsd
    10. sudo systemctl enable catalyst-hook
    11. sudo systemctl start catalyst-hook
    
    At this moment when we get hwinfo --gfxcard we should see two drivers for AMD card (radeon + fglrx)
    So we need black list radeon and run fgrlx
    12. echo "blacklist radeon" >> /etc/modprobe.d/modprobe.conf 
    13. modprobe fglrx
    Check that /etc/modules-load.d/catalyst.conf contains fglrx if not add them
    
    install intel drivers
    14. sudo pacman -S xf86-video-intel
    
    update GRUB - remove "nomodeset" options from this file
    15. sudo nano boot/grub/grub.cfg
    
    16. reboot
    in my case desktop won't start - so we need open console CTRL+ALT+Fx
    and now we can run:
    17. aticonfig --initial
    verify that fglrx is active and radeon is not active (hwinfo --gfxcard)
    set Dedicated GPU to be sure it will be used:
    18. aticonfig --px-dgpu
    restart desktop:
    19. systemctl restart lightdm.service
    
    FINISH - in my case Dedicated GPU is in use (I can run amdcccle / screenfetch - shows GPU AMD)
    

    However yesterday I made some changes in AMDCCCLE and now my computer use only intel again :/ - reinstall drivers doesn’t help - My desktop try to start but I can only see mouse and black screen - I think I need remove permanent all files and components related to AMD and install again.
    So my suggestion is install only needed drivers and before making changes be sure you will not broke anything :)

Posts 10Views 361
Log in to reply