• auto mount internal HHD


    well I just made the switch , windows 10 drove me up the wall !! So I went running to linux , tryed many distros but antergos won out . BUT being a noob to linux I got a issue , I am using a 500 gb 850 samsung evo that I managed to reformat to ex4 I want to use as storage , I can see the drive in linux just fine but every time I want to access it I got to enter a password then I can use it Grrrr ! :anguished: how do I stop this and just have the drive auto mount . I have looked at 10 youtube vids nothing is working , seems I do not have root access or I cant get it to wok acording to the vids ( note these were for linux mint ) is it different for this version ?

    And on another note I cant get my canon ip1800 to work tryed installing all the PPD files form the updater but no joy , tryed using different drivers but I have no option for my exact model / Linux sees the printer just fine , sees it as a usb printer just cant print anything !

  • @brothergc
    welcome here!

    for hd:
    you need to add the storage to your /etc/fstab
    get the UUID for the device with this command:

    ls -l /dev/disk/by-uuid/
    create the mountpoint:
    sudo nano mkdir /mnt/DATA
    then add the device to the existing fstab file:
    sudo nano /etc/fstab

    ...
    UUID=put here the UUID for your device	/mnt/DATA     ext4    rw,relatime,discard,data=ordered	0  2
    ...
    

    The fstab(5) file can be used to define how disk partitions, various other block devices, or remote filesystems should be mounted into the filesystem.
    https://wiki.archlinux.org/index.php/Fstab

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad I tryed what you suggested but no joy , sudo just keeps running in the background in my terminal , even after 10 min of time. maybe I too much of a noob maybe it is my system is just too new it is a intel kabby lake I5 and a intel 270 chipset which might not be suppoeted but guessing here

  • bind it may is the solution, as this is what i do for my documents, they are onto another HD and i bind them to my home:

    UUID=""long-long--uuid-number""	/mnt/DATA      ext4    defaults,discard        0  2
    /mnt/DATA	/home/""yourusername""/DATA	auto	bind	0 0
    

    needs you to create the folder DATA under your users home as normal user…

    May i was wrong on the mount options inside the fstab line and it will work if you simple use this: defaults,discard

    UUID=""long-long--uuid-number""	/mnt/DATA      ext4    defaults,discard        0  2
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Joe why cant I just manualy edit the fstab file ? would not that be much more simple then all these commands ?

    Aslo do you know where the Nvidia x config files are ? ( directory location ) I am trying to get my settings to auto load

  • @brothergc well in gnome 3 you can do a sudo nautilus it will open your file manager with root rights but you need to be carefull what files you change also try sudo blkid to find the UUID of your drive.

  • @dreamtraveler said in auto mount internal HHD:

    @brothergc well in gnome 3 you can do a sudo nautilus it will open your file manager with root rights but you need to be carefull what files you change also try sudo blkid to find the UUID of your drive.

    thank you for the reply , I tryed what you siggested but I get "command not found " I suspect its because I am using a mate desktop but thanks just the same

  • @brothergc the file manager in mate is marco so try a sudo marco

  • @brothergc i do not give you comands, only fstab lines. The only comand i give was to findout the uuid of your ssd…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • UUID=""long-long--uuid-number""	/mnt/DATA      ext4     defaults,discard,noatime,user  0  2
    

    example with a UUID inside:
    UUID=5fub8587-0068-45ec-a945-15394170vv89 /mnt/DATA ext4 defaults,discard,noatime,user 0 2

    may need also bind under your home, to get access without password:
    /mnt/DATA /home/""yourusername""/DATA auto bind 0 0

    inside your /etc/fstab must do the job !

    thanks to @dreamtraveler reminds me to check this again…

    with Nvidia x config files you want to autoload settings from nvidia-settings tool? this is a bit tricky, as it do not have a autostarter itself…

    you need to create one (aka .desktop file) :
    nano ~/.config/autostart/nvidia.desktop

    and put the following inside:

    [Desktop Entry]
    Type=Application
    Name=nvidia            
    Comment=autoload nvidia-settings
    Exec=nvidia-settings --config ~/.nvidia-settings-rc --load-config-only
    

    save the file with [Ctrl+X]
    this is the command to load the settings from the file nvidia-settings create if you press save settings
    ( ~/.nvidia-settings-rc)

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • but back to topic… i just try to reproduce your problem, and i can see that a ssd formatted with ext4 is shown up inside nautilus and i do not need password to open, and this without any fstab hacking…

    may you need to change the owner of the drive only to get what you want?

    sudo chown -R *username* */mountpoint/name*
    where username needs to be changed to your username and /mountpoint/name to the mountpoint of the ssd (/mnt/DATA/)

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in auto mount internal HHD:

    but back to topic… i just try to reproduce your problem, and i can see that a ssd formatted with ext4 is shown up inside nautilus and i do not need password to open, and this without any fstab hacking…

    may you need to change the owner of the drive only to get what you want?

    sudo chown -R *username* */mountpoint/name*
    where username needs to be changed to your username and /mountpoint/name to the mountpoint of the ssd (/mnt/DATA/)

    well I entered in the id of the drive then I rebooted now I cant access the drive at all I copied the id of the drive from terminal I am about to give up I probaly got in over my head here beeing a noob windows I know linux I do not perhaps you could recomend a easier distro as this version seems to lock me out of root access with out using a terminal command line .

  • by default we have sudo what gives you root access inside terminal.
    If you want to run a graphical program as root ( not a good idea at all, but helpfull sometimes) you can install gksu (if you are using GNOME or similar) and then you are able to run texteditor or filebrowser as root by open it via terminal with gksu gedit (texteditor) or gksu nautilus (filebrowser), other programms like gparted (partion manager) are configured to run with gksu by default and if you start them from menu it asks for password.

    You will need to get same basic knowledge on linux for all distros also the easy ones…but permissions and root access are the same, also the file structure.

    all files under /home/username/ are owned by your user, all others are default owned by root. some are executable as normal user (normal programms) others not… (like mount command or other administrative commands) this is the same under windows.

    If you do not understand something, you can easely leran it here and we all are helpfull on giving you the information.

    Keep in mind that you try the best to give all information we need: if a command fails give the error message, if you want to do something, say exactly what you want to do (in your own words).

    And if you are scared about using the terminal, it is way more easy to help from remote if you can copy paste into terminal, instead of giving instructions on which program you need to open and where you need to save something e.t.c.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @brothergc said in auto mount internal HHD:

    @joekamprad said in auto mount internal HHD:

    but back to topic… i just try to reproduce your problem, and i can see that a ssd formatted with ext4 is shown up inside nautilus and i do not need password to open, and this without any fstab hacking…

    may you need to change the owner of the drive only to get what you want?

    sudo chown -R *username* */mountpoint/name*
    where username needs to be changed to your username and /mountpoint/name to the mountpoint of the ssd (/mnt/DATA/)

    well I entered in the id of the drive then I rebooted now I cant access the drive at all I copied the id of the drive from terminal I am about to give up I probaly got in over my head here beeing a noob windows I know linux I do not perhaps you could recomend a easier distro as this version seems to lock me out of root access with out using a terminal command line .

    First remove the entries you put in /etc/fstab (or put a # infront of the line to exclude (comment out) this entry

    #UUID=5fub8587-0068-45ec-a945-15394170vv89	/mnt/DATA ext4 defaults,discard,noatime,user 0 2
    

    so you do not need to paste this in if you need it later.

    reboot system.

    open filebrowser and go to other placesthere you will find the data hdd … if you try to open it asks for password and mount it.

    This is the normal way … if you want to have it accessable without password and automounted you need to use fstab.

    Depending on how you want to use it.
    I have my private data on a second internal drive like your ssd and all my pictures, documents, videos, and music are saved there.

    To get them without password as default i automount the drive under /mnt/data and the specific folders (pictures, documents, videos, and music) are linked to this folders under my /home/user/pictures /home/user/documents e.t.c. (user needs to be replaced with username) this is done also over /etc/fstab:

    UUID=1fgtg4366-35256-45dc-a23425-15394132ff89	/mnt/daten      ext4    defaults        0 2
    /mnt/daten/Bilder	/home/killajoe/Bilder	auto	bind	0 0
    /mnt/daten/Dokumente	/home/killajoe/Dokumente  auto    bind    0 0
    /mnt/daten/Videos	/home/killajoe/Videos  auto    bind    0 0
    /mnt/daten/Musik	/home/killajoe/Musik  auto    bind    0 0
    
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in auto mount internal HHD:

    @brothergc said in auto mount internal HHD:

    @joekamprad said in auto mount internal HHD:

    but back to topic… i just try to reproduce your problem, and i can see that a ssd formatted with ext4 is shown up inside nautilus and i do not need password to open, and this without any fstab hacking…

    may you need to change the owner of the drive only to get what you want?

    sudo chown -R *username* */mountpoint/name*
    where username needs to be changed to your username and /mountpoint/name to the mountpoint of the ssd (/mnt/DATA/)

    well I entered in the id of the drive then I rebooted now I cant access the drive at all I copied the id of the drive from terminal I am about to give up I probaly got in over my head here beeing a noob windows I know linux I do not perhaps you could recomend a easier distro as this version seems to lock me out of root access with out using a terminal command line .

    First remove the entries you put in /etc/fstab (or put a # infront of the line to exclude (comment out) this entry

    #UUID=5fub8587-0068-45ec-a945-15394170vv89	/mnt/DATA ext4 defaults,discard,noatime,user 0 2
    

    so you do not need to paste this in if you need it later.

    reboot system.

    open filebrowser and go to other placesthere you will find the data hdd … if you try to open it asks for password and mount it.

    This is the normal way … if you want to have it accessable without password and automounted you need to use fstab.

    Depending on how you want to use it.
    I have my private data on a second internal drive like your ssd and all my pictures, documents, videos, and music are saved there.

    To get them without password as default i automount the drive under /mnt/data and the specific folders (pictures, documents, videos, and music) are linked to this folders under my /home/user/pictures /home/user/documents e.t.c. (user needs to be replaced with username) this is done also over /etc/fstab:

    UUID=1fgtg4366-35256-45dc-a23425-15394132ff89	/mnt/daten      ext4    defaults        0 2
    /mnt/daten/Bilder	/home/killajoe/Bilder	auto	bind	0 0
    /mnt/daten/Dokumente	/home/killajoe/Dokumente  auto    bind    0 0
    /mnt/daten/Videos	/home/killajoe/Videos  auto    bind    0 0
    /mnt/daten/Musik	/home/killajoe/Musik  auto    bind    0 0
    
    

    Ok I got the drive access back and it is showing the proper id , but everytime I try to access it something called “polkit” is requiring a password . If I unmount the driver then try to remount no password is needed BUT if I reboot , then I need to re enter my password weird . I just do not need a password protected drive as I keep any sensitive items on a removable HHD for safe keeping . basicly this drive has nothing on it right now could that be a issue ? All the drive will be used for is storing game files from steam , music files and such .
    Oh and the drive has no name , it shows up and is ID corectly as a "500 b samsung 850 evo ssd " just no lablel ( IE like game drive , ect ) No big deal for me with that just pointing that out just in case

    Also to the poster above I tryed you suggestion on saving nvidia settings , now when I save the settings I get a folder on my desktop that replaces the shortcut I created to the nvidia control panel and my short cut disapears

  • @brothergc said in auto mount internal HHD:

    but everytime I try to access it something called “polkit” is requiring a password

    password is needed for mounting, as it is not mounted automaticly on bootup…

    If you bind it under your users home directory you do not need a password anymore, it is accessable like a folder under your home then.

    You can label the drive with gparted:
    0_1512163004380_gparted.png

    @brothergc said in auto mount internal HHD:

    Also to the poster above I tryed you suggestion on saving nvidia settings , now when I save the settings I get a folder on my desktop that replaces the shortcut I created to the nvidia control panel and my short cut disapears

    I do not get what you want to say here?
    nvidia-setting save the settings as a file under your home (not on the desktop) ~/.nvidia-settings-rc
    (~ = /home/"useraname) so if nvidia-settings do not create a file .nvidia-settings-rc you can change directory to your users home folder and the name to .nvidia-settings-rc on saving the settings…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad

    well I screwed the pooch , thought I would just uninstall polkit but when I rebooted , would not boot just a black screen so I wiped the drive clean and tried to reload my install disk , all I got was a splash screen , when I tried to hit the live disk option it would do something but that too would black screen tried 2 different install disks of antergos . :(
    Right now I am forced to run windows 10 had to reinstall it , shame I was realy starting to grow fond of this distro .
    I wanted to say I appreciate all the help , I give it a go after the holidays and try making a fresh install disk maybe give KDE a shot I liked the dolphin manager

    Again THANKS !!! I will be back now I gotta fight with windows 10 Grrrr . nothing like it having apps appear on your pc with out your permission or stupid edge browser auto launching

  • You are welcome!
    Sorry for your screwed experience .
    And we will be here when you come back!

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in auto mount internal HHD:

    You are welcome!
    Sorry for your screwed experience .
    And we will be here when you come back!

    well looks like it was a short recess ROFL windows was peving me off sound going in and out so I started digging around the net and found a community version of antergos that had nvidia support that disk worked seems the vid support in the official disk was wonkey . so I installed that and I am back . Had the experience already to install the correct drivers for my gtx1060 . For some reason the control panel is remembering the digital viberance setting but not the contrast setting . But its better then what I had .
    What impresses me with antergos is the stablity . . Guess when I get off the xmas season and these 60 hr work weeks Ineed to start learning linux . Part of my problem right now is I just don’t have much free time . again Thank you VERY much for your patience . Wishing You and Yours a Merry Christmas :)

mount15 internal6 hhd2 auto9 Posts 32Views 679
Log in to reply