• Recuperar arranque Antergos luego de instalar otra distro linux


    Buenas.

    ¿Sería posible recuperar el arranque de antergos luego de haber instalado otra distro?

    Me explico:

    Tengo una netbook que tenía dual boot debian 8 (sda1) / windows 8.1 (sda5).

    En una partición aparte (sda8) instalé antergos. Siguiendo el instalador, creo que el grub se instaló en la partición sda3 (EFI system parttion)(/boot/efi)

    La máquina tiene sistema EFI y particionado GPT.

    Hasta quí funcionó bien.
    Arrancaba Antergos, Windows y Debian.

    Pero luego instalé linuxmint 18.3.
    Y ahora arranca linuxmint, debian y windows pero perdí el arranque de antergos.
    Aparece listada en el grub, pero no puede arracar (sale mensaje de kernel panic)

    Creo que puede ser porque instale el grub (de linuxmint) directamente en sda, en vez de hacerlo en algún otro lugar (¿sda3? ¡/boot/efi?..) o no hacerlo en absoluto

    ¿Podré recuperar el arranque de antergos o tendré que reinstalarla completamente?

    Por orden de preferencia cuáles de estas alternatvas creen posibles:

    1. Solucionar el problema, poder arrancar todos los sistemas sin reinstalarlos.

    2. Recuperar arranque Antergos (y Windows) (después trato de reinstalar linuxmint correctamente)

    3. Reinstalar Antergos y linuxmint

    Lo que creo que todavía no entiendo es cómo instalar más de una distro linux en un sistema EFI con una partición /boot separada (ya lo había intentado en otra máquina con BIOS tradicional y no logré manejarme con una /boot separada. tuve que reinstalar todo sin /boot separada)

    Pego salida de fdisk -l

    $ sudo fdisk -l
    [sudo] password for minto: 
    Disk /dev/sda: 465,8 GiB, 500107862016 bytes, 976773168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: 3FFF1131-9C2B-41D3-BDAC-FF60991F23F8
    
    Device         Start       End   Sectors   Size Type
    /dev/sda1       2048  52430847  52428800    25G Linux filesystem
    /dev/sda2  104859648 105474047    614400   300M Windows recovery environment
    /dev/sda3  105474048 105678847    204800   100M EFI System
    /dev/sda4  105678848 105940991    262144   128M Microsoft reserved
    /dev/sda5  105940992 210798591 104857600    50G Microsoft basic data
    /dev/sda6  210798592 263231487  52432896    25G Linux filesystem
    /dev/sda7  263231488 271620095   8388608     4G Linux swap
    /dev/sda8  271620096 345014271  73394176    35G Microsoft basic data
    /dev/sda9  345016320 759449599 414433280 197,6G Microsoft basic data
    /dev/sda10 759449600 976773119 217323520 103,6G Linux filesystem
    /dev/sda11  52430848 104859647  52428800    25G Linux filesystem
    
    Partition table entries are not in disk order.
    

    ¿Algún problema con que la tabla de particiones no esté en orden? A sda 11 la creé última quitándole un poco de espacio a sda1
    Acaración /dev/sda8 es una partición ext4 y contiene a antergos (originalmente era ntfs pero a formateé. No sé por qué el código dice Microsoft basic data

    Con la imagen de gparted se entiende mejor.

    0_1511882591886_Screenshot from 2017-11-28 12-19-29.png

    EDITO: aporto más datos. Éste es el mensaje de error que sale cuando selecciono Antergos en el grub que instaló linuxmint:

    kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
    CPU: 1 PID: 1 Comm: swapper/0 Not tainted 4.13.12-1ARCH #1
    Hardware name: Intel corporation powered cassmate PC Intel powered classmate PC, BIOS MPBYT10A,00F,0039,2016.0622
    Call Trace:
    dump_stack+0x63/0x0b
    panik+0xe4/0x23d
    mount_block_root+0x278/0x2ab
    ? set_debug_rdata+0x17/ox17
    mout_root+0x6a/0x6d
    prepare_namespace+0x134/0x16c
    kernel_init_freeable+0x1ec/0x205
    ? reset_init+0xe0
    ...(3 líneas más)
    ---[ end kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
    

    (Lo transcribí a mano así que puede haber algún error de tipeo)

    Muchas gracias.!

  • @laurentius
    Si tiene el arranque UEFI, no debe mezclarlo con el arranque del BIOS (como parece haber hecho al instalar Mint). Entonces ahora estás usando el arranque de BIOS a través de Mint.

    Puedes arreglar eso en Mint:

    • crear un nuevo archivo /boot/grub/custom.cfg
    • copie el menuentry de Antergos de /boot/grub/grub.cfg en /boot/grub/custom.cfg
    • en /boot/grub/custom.cfg, corrige la línea initrd para que sea algo así como:
      initrd /boot/intel-ucode.img /boot/initramfs-linux.img

    Si no ha instalado el paquete intel-ucode, haga que sea como sigue:
    initrd /boot/initramfs-linux.img

    También hay otras formas (y quizás mejores) de solucionarlo, pero probablemente sea la más fácil.

  • Muchas gracias, manuel por la respuesta.

    Desde mint, he creado el archivo /boot/grub/custom.cfg, el cual se ve así:

      GNU nano 2.5.3          File: /boot/grub/custom.cfg                           
    
    menuentry 'Arch Linux (rolling) (on /dev/sda8)' --class gnu-linux --class gnu -$
            insmod part_gpt
            insmod ext2
            set root='hd0,gpt8'
            if [ x$feature_platform_search_hint = xy ]; then
              search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt8 --hint-e$
            else
              search --no-floppy --fs-uuid --set=root f46814f1-ca32-4fef-b124-5d5ed$
            fi
            linux /boot/vmlinuz-linux root=UUID=f46814f1-ca32-4fef-b124-5d5ed25edcc$
            initrd /boot/intel-ucode.img /boot/initramfs-linux.img
    }
    submenu 'Advanced options for Arch Linux (rolling) (on /dev/sda8)' $menuentry_i$
            menuentry 'Antergos Linux (on /dev/sda8)' --class gnu-linux --class gnu$
                    insmod part_gpt
                    insmod ext2
                    set root='hd0,gpt8'
                    if [ x$feature_platform_search_hint = xy ]; then
                      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt8 $
    

    Edité cada línea intrd primero para que quede asi
    initrd /boot/initramfs-linux.img

    No funcionó. El msmo mensaje de error en todas las entradas de antergos.

    Luego las volví a modificar para que queden así:
    initrd /boot/intel-ucode.img /boot/initramfs-linux.img

    Tampoco funcionó.
    A /boot/grub/grub.cfg no lo toqué.

    El paquete intel-ucode no lo he instalado en mint. No está en los repositorios oficiales de mint.

    Saludos.

  • @laurentius
    The intel-ucode is a package of Antergos, and it may already be installed there. The booting of Antergos however should work even without the intel-ucode package in the initrd line.

    Did you notice a new boot menu entry after you created /boot/grub/custom.cfg? You should select that new entry. You can rename the entry to anything you like (e.g. ‘Antergos’), so it will not be mixed with the original in /boot/grub/grub.cfg.

    El intel-ucode es un paquete de Antergos, y puede que ya esté instalado allí. Sin embargo, el arranque de Antergos debería funcionar incluso sin el paquete intel-ucode en la línea initrd.

    ¿Notó una nueva entrada en el menú de inicio después de haber creado /boot/grub/custom.cfg? Debe seleccionar esa nueva entrada. Puede cambiar el nombre de la entrada a cualquier elemento que desee (por ejemplo, ‘Antergos’), por lo que no se mezclará con el original en /boot/grub/grub.cfg.

  • Oh! Perdón. No había notado la nueva entrada, al final del grub.
    Funciona! Estoy en Antergos ahora.
    El tema está resuelto.

    ¿Qué sugieren, dejar ahora las cosas así o reinstalar el cargador de arranque desde Antergos?

    Muchas gracias.

  • @laurentius
    Eso depende de ti. Como dijiste, esto funciona ahora, así que no hay una razón convincente para cambiar. Pero el BIOS es tecnología antigua, e Intel planea retirar su soporte después de 2020.

    Si lo desea, puede reinstalar Mint primero y luego Antergos, ya que Antergos debería poder arrancar todos sus sistemas operativos actuales sin trabajo adicional.

Posts 6Views 120
Log in to reply