• [SOLVED] How to disable KVM module?


    Hey,

    I have a ThinkPad X270 and after every installation of Antergos I get 4 messages saying that KVM was disabled by BIOS. How can I disable the KVM module not to receive that message on boot?

    Thanks for the help!

  • @jmpargana said in How to disable KVM module?:

    How can I disable the KVM module not to receive that message on boot?

    systemctl stop kvm.service
    systemctl disable kvm.service

  • @jmpargana

    lsmod | grep kvm
    lsmod | grep virtio
    

    will give you info about the modules, if modules are loaded you must blacklist them, but i do not know if this will make the error message dissapear… if your CPU support it you can enable virtualization inside Bios, may you can make use of it for virtualmachine …

  • @joekamprad

    [[email protected] ~]$ lsmod | grep kvm
    kvm                   516096  0
    irqbypass              16384  1 kvm
    [[email protected] ~]$ lsmod | grep virtio
    [[email protected] ~]$ 
    

    This is the output of both those commands. Could you explain me how to blacklist them? I’ll can just test if the error message goes away.

    And do you mean the module can be useful when using a virtualmachine like virtualbox?

    Thank you for your help!

  • @judd I tried both your commands, but it says in Terminal that the service is not active as answer to stop, and the service is not loaded as answer to disable. I still get the error massage at boot though.

    Thanks you

  • @jmpargana said in How to disable KVM module?:

    I still get the error massage at boot though.

    You could make a mask
    systemctl mask kvm.service and then reboot

  • @judd

    [[email protected] ~]$ sudo systemctl mask kvm.service
    Unit kvm.service does not exist, proceeding anyway.
    Created symlink /etc/systemd/system/kvm.service → /dev/null.
    [[email protected] ~]$ 
    

    This was the output and after boot I still received the message.

  • So if you do not want to see more KVM you can do this through the grub:

    https://forum.antergos.com/topic/7776/acpi-error-method-parse-execution-failed-_pr-cpu0-_pdc/10

  • @jmpargana said in How to disable KVM module?:

    Unit kvm.service does not exist

    i am not sure if this systemd service exists at all…

    @jmpargana said in How to disable KVM module?:

    And do you mean the module can be useful when using a virtualmachine like virtualbox?

    yes ;)

    sudo nano /etc/modprobe.d/blacklist.conf
    

    and insert like this:

    install kvm /bin/false
    

    save the file [ctrl+X] and reboot

  • @joekamprad
    Thank you! That worked :)

  • easy one :)

  • Solved ???

    0_1511903825772_solved.png

Posts 12Views 1335
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.