• Update breaks Cheese


    Hi guys,

    Just did the latest update (after backup) and something on it is breaking Cheese. I use it for viewing my CCTV camera & it was working fine but now it goes unresponsive at 1st then says no device found. Any idea which of these is the culprit?

    Replace gtk3-print-backends with extra/gtk3? [Y/n] y
    resolving dependencies…
    looking for conflicting packages…

    Packages (42) cmake-3.10.0-2 efivar-32-1 expat-2.2.5-1 gawk-4.2.0-1
    gmime3-3.0.4-1 gtk-update-icon-cache-3.22.26+47+g3a1a7135a2-3
    gtk3-3.22.26+47+g3a1a7135a2-3
    gtk3-print-backends-3.22.26-1 [removal] hwids-20171003-1
    ldb-1.3.0-1 lib32-alsa-lib-1.1.5-1 lib32-libjpeg-turbo-1.5.2-2
    lib32-libpciaccess-0.14-1 lib32-ncurses-6.0+20170902-1
    lib32-nvidia-utils-387.34-1 libatomic_ops-7.4.8-1
    libgweather-3.26.1-1 libjpeg-turbo-1.5.2-2
    libmicrohttpd-0.9.56-1 libreoffice-fresh-5.4.3-4 libuv-1.17.0-1
    libwbclient-4.7.3-1 linux-lts-4.9.65-1 nvidia-387.34-5
    nvidia-utils-387.34-1 pciutils-3.5.6-1 pipewire-0.1.7-1
    python-setuptools-1:38.2.1-1 python2-simplejson-3.13.2-1
    qt5-base-5.9.3-1 qt5-styleplugins-5.0.0.20170311-3
    qt5-svg-5.9.3-1 reflector-2017.11-1 reiserfsprogs-3.6.27-1
    smbclient-4.7.3-1 telepathy-idle-0.2.0-2 tevent-1:0.9.34-1
    usbutils-009-1 wine-2.22-1 wireless-regdb-2017.03.07-1
    wpa_actiond-1.4-3 xfsprogs-4.13.1-1

    Total Download Size: 299.61 MiB

    I am connected via USB so wonder if it is the usbutils?

  • same here:

    cheese                                                                                                                               130 ↵
    
    (cheese:11634): Gtk-WARNING **: Theme parsing error: cheese.css:7:35: The style property GtkScrollbar:min-slider-length is deprecated and shouldn't be used anymore. It will be removed in a future version
    
    ** (cheese:11634): WARNING **: cheese-window.vala:1121: gnome-video-effects is not installed.
    ** Message: cheese-application.vala:211: Error during camera setup: No device found
    
    
    (cheese:11634): Clutter-CRITICAL **: clutter_actor_hide: assertion 'CLUTTER_IS_ACTOR (self)' failed
    
    (cheese:11634): cheese-CRITICAL **: cheese_camera_device_get_name: assertion 'CHEESE_IS_CAMERA_DEVICE (device)' failed
    
    (cheese:11634): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
    
    (cheese:11634): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed
    
    (cheese:11634): GLib-GIO-CRITICAL **: g_settings_schema_key_type_check: assertion 'value != NULL' failed
    
    (cheese:11634): GLib-CRITICAL **: g_variant_get_type_string: assertion 'value != NULL' failed
    
    (cheese:11634): GLib-GIO-CRITICAL **: g_settings_set_value: key 'camera' in 'org.gnome.Cheese' expects type 's', but a GVariant of type '(null)' was given
    
    (cheese:11634): GLib-CRITICAL **: g_variant_unref: assertion 'value != NULL' failed
    
    ** (cheese:11634): CRITICAL **: cheese_preferences_dialog_setup_resolutions_for_device: assertion 'device != NULL' failed
    
    

    but usbcam is working fine:

    Nov 28 20:39:45 empowered64 kernel: media: Linux media interface: v0.10
    Nov 28 20:39:45 empowered64 kernel: Linux video capture interface: v2.00
    Nov 28 20:39:45 empowered64 kernel: gspca_main: v2.14.0 registered
    Nov 28 20:39:45 empowered64 kernel: gspca_main: spca561-2.14.0 probing 04fc:0561
    Nov 28 20:39:45 empowered64 kernel: input: spca561 as /devices/pci0000:00/0000:00:1a.1/usb4/4-1/input/input17
    Nov 28 20:39:45 empowered64 kernel: usbcore: registered new interface driver spca56
    

    0_1511898621352_Bildschirmfoto vom 2017-11-28 20-49-53.png
    /usr/bin/wxcam

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad Dont know if you have Nvidia but that is what was causing my problem. I installed all the updates except Nvidia 387.34-5 plus utils 34-1 and all works now.

  • Correction - it worked until i rebooted my pc & it broke again :rolling_eyes:

  • nvidia too here…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad Well I can tell you what it is NOT. It not … Nvidia, Wine or usbutils. What it is that breaks Cheese is a real issue for me as it is broken on a fresh install too.

  • i do not find a solution here too… and yes it is only cheese with that problem… i do not find similar problems at the net also…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad Not only Cheese it seems. On the fresh install VLC wont work either.

  • vlc is working here too:
    0_1512113912038_Bildschirmfoto vom 2017-12-01 08-38-20.png

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Probably some dependency of cheese package is failing. I’d guess gtk3, but note that this is just a guess.

Posts 10Views 242
Log in to reply