• KDE won't start after login only cursor


    Hello,

    I installed KDE desktop in my Asus Netbook 1015.
    I have a display problem.

    1. I run this command:
    sudo pacman -S xf86-video-intel mesa-libgl
    

    Now I can login with lightdm.
    But only cursor appeared after kde splash screen.

    1. I tried startkde and error message is
    $DISPLAY is not set or cannot connect to the X server
    

    Can anyone give me a tips ?

    Thank you

  • @codecafe24 said in KDE won't start after login only cursor:

    $DISPLAY is not set or cannot connect to the X server

    I could paste the result of inxi console

    sudo pacman -S inxi
    inxi -Fxxc0???

  • thanks for reply.
    here is the screenshot:

    0_1511811851965_antergos-kde.jpg

  • You can try console to regenerate the image in this way as root:

    # mkinitcpio -p linux

    Paste the result here, please ?

  • I’d recommend installing something lighter than KDE, for example Xfce, since it seems to be a less powerful machine.

  • @manuel thanks for tip
    This is my backup pc.
    KDE consume less memory already :)

  • @judd thanks for help

    KDE started after reboot.
    I completed some task yesterday.
    I’m not sure which one is fixed the problem.
    I renamed .local and .config folders
    and run this
    export DISPLAY=:0.0 ; startx

    Thank you again.
    Have a nice day.

  • @codecafe24
    If you want to find out which action did the trick, you could check if removing

    export DISPLAY=:0.0
    

    before semicolon brings the problem up again.

login79 kde114 cursor13 Posts 8Views 168
Log in to reply