• Can't install Aplications through PlayOnLinux

    Hello! I recently migrated from Debian to Antergos, and I was very happy to see PlayOnLinux being offered in the installation.

    After installing and setting up my work environment, I went on to Install Hearthstone through PoL. The thing is that whenever I try to Install it, I got stuck in “Creating Virtual Drive”.

    Whenever I get stuck on this screen I notice that another “window” it’s in pt-br, but i think in english it’s something like "Loader of Wine Windows Applications"
    Here is a screenshot
    https://i.imgur.com/zuNaofQ.png (See wine mono installer and wine).
    And I can’t intereact with that “windows” in any way.

    Keep in mind I already have Mono and a System version of wine installed.

    To try to solve this I also tried uninstalling both Wine and PoL that came with my Antergos installation and reinstalling both of them of no success.

    I also installed wine-mono and wine-gecko and some other dependencies, but also got no luck.

    This is when trying to install with the official scripts.

    I think someone here said that installing through “Install a non-listed program” would work. And I could kinda install it, but after installing the battle.net it kept crashing (i’m pretty new on Linux, so I don’t know how to solve this, and this is why i would prefer if I could install though the official PoL scripts).

    Anyway, anyone can help me on this issue?


    Edit: The other topic I found with an issue similar to mine was this one:

    But I can’t seem to make it work

  • I can look into this some. I also tried to install WoW through the PoL front-end and it winds up puking. I know it was listed as working at some point, but who knows what Blizzard has changed since then.

  • @namelessking ​i have been using Lutris lately to install my game, works great for me but you have to configure it manually or look online for the best configuration. i know this isn’t much help but more of a recommendation. i got swtor when PoL wasn’t working with it.

  • @lemler3 Now I tried and I can’t even install unlisted programs. I get the same problem.
    I will try lutris! Nice to know that swtor is working. Can you share the configurations you used to get it working?

  • @lemler3 Hey! Lutris totally did it for me on Hearthstone. I got no sound, but the game is working great!

    I’ll try SWTOR very soon. 🙂


  • @namelessking glide i could help ill have to look at my swtor set config im not st home atm

  • Yeah I can’t install anything in playonlinux either, I always get
    wine: Unhandled page fault on read access to 0x00000004 at address 0x1ce83ce:0x7eb32c64 (thread 0022), starting debugger...

  • @namelessking said in Can't install Aplications through PlayOnLinux:

    I think someone here said that installing through “Install a non-listed program” would work

    That’s how i always install with playonlinux…

    One thing you can try is recheck if some package is still missing (and then resintall) with:
    sudo pacman -S $(pactree -u playonlinux) --needed

    OBS: Keep in mind that not every package will work after install under playonlinux, some need trial and error at planonlinux configuration and some will never work as far as i know.
    One thing you can do is check on internet if someone managed to install and run your game/program at playonlinux too.

    Portergos site

    Still in love with Antergos (default OS)

    Linux newbie since 06/2016

  • Well this was a listed program so it should work with the playonlinux scripts but after selecting the setup file to install it it just gives the error and crashes there (before the setup window pops up showing the usual install options, etc.). I will try the pacman command though.

  • Nope there was no packages missing.

  • @MachinaeWolf
    i have no more ideas now…

    Portergos site

    Still in love with Antergos (default OS)

    Linux newbie since 06/2016

  • I get the same problem on my Antergos install…

    You can use your system Wine version through POL, however for some reason in-app wine version manager fails to set up various different wine versions (only happens on arch-based distros)

  • @MaCroX95 So there’s some weird arch bug but if it can be installed with the native wine version then it could be installed and later manually changed to the proper wine version to run it? Speaking of wine versions and scripts, does playonlinux keep a local copy of all those install scripts for games and programs?

  • @MachinaeWolf said in Can't install Aplications through PlayOnLinux:

    installed and

    just an idea trying uninstalling wine and install “wine-staging”

    "the run winecfig"
    install the goodies
    then trying configuring with wine config

    for me most games work with the default setting but there is always wineHQ to help you out

Posts 14Views 2030
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.