• Cron Job not running


    Hi guys,

    I have set some cron jobs in crontab, however lately they do not run. I am using cronie.
    I tried to check the cronie log but I cannot find it under /var/log where it should be (also according to Arch Wiki and other sources).
    The other weird thing is that systemctl says that cron is active and running and

    ps aux | grep crond
    

    returns

    root       531  0.0  0.0  19524  1444 ?        Ss   Nov23   0:00 /usr/bin/crond -n
    ase11   21609  0.0  0.0  10888  2100 pts/2    S+   09:01   0:00 grep crond
    

    Thanks for your help.

  • @ase11

    did you use

    sudo crontab -e
    

    or just

    crontab -e
    

    ?

  • @ase11
    Have those cron jobs ever worked in your current system, or just lately failed? It was somewhat unclear for me.

    A tool for sending logs: https://forum.antergos.com/topic/10586/eat-logs
    Install eat: wget -q https://github.com/manuel-192/eat/raw/master/PKGBUILD && makepkg -sic

  • I have used

    crontab -e
    

    so without sudo.

    From what I could see only lately these failed.

  • Just try using

    sudo crontab -e
    

    I’m new on linux but I had similar problem, when I was setting job using crontab without sudo it didn’t work but with sudo everything works fine.

  • Yeah after your first post I thought the same and now I am running crontab with sudo.
    Later I let you know if that worked.

  • I can confirm sudo made the trick and now it’s working. Thanks.

running19 cron5 job4 Posts 7Views 498
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.