• How do I install nvidia drivers on a fresh install of antergos?


    I know you guys must have this question daily by now, but I may have a special case here. I’m trying to install Nvidia Drivers (without bumblebee) on a Optimus Laptop. I don’t want to use Bumblebee and prefer using the Nvidia Driver instead. I’ve checked online and usually the first steps is to uninstall the nouveau driver, the weird part is I do not have any of the nouveau drivers. I do not have nouveau-dri, xf86-video-nouveau nor lib32-mesa-libgl. I’ve tried installing the nvidia package, reboot and black screen with white cursor. I’ve tried doing nvidia-xconfig to generate the xorg.conf and now I get a completely black screen. I’ve tried changing TTY and startx from there still nothing. I’ve worked with Nvidia Optimus laptops before on my Arch Linux install and doing this solved it, but not on Antergos. Why? I installed GNOME 3 and disabled proprietary drivers when installing.

  • @Drakota said in How do I install nvidia drivers on a fresh install of antergos?:

    disabled proprietary drivers when installing

    depending on your hardware, you need to configure graphic inside BIOS…

    And remove the generated xorg.conf (e.g. : sudo rm /etc/X11/xorg.conf) It will disturb future configurations and is not needed.

    The topic is not clear > do you want to get bumblebee working, or do you want to run on nvidia card only?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @Drakota You do not provide any info about the hardware and the video card.

    If you want always and unconditionally run on nVidia GPU only on Optimus laptop, then the only choice is to use Prime.

  • @just @joekamprad I should have been more precise about m’y intentions and my hardware, I have a GTX 960M GPU. My objective is to only run on my discrete card, but the BIOS does not let me disable the intel one unfortunately.

  • Ok. Prime remains the easiest way to go.

Posts 6Views 218
Log in to reply