• HTTP/NFS Connectiity Problems


    Hello,

    I have some problems with my gigabit Ethernet connection performance between my laptop (Latest Antergos KDE) and my QNAP NAS server (runs NFS v4). More specifically:

    • When I use the browser to upload a large file to NAS the speed is about 10MB/sec while with the Linux mint 18.2 Cinnamon live cd 45MB/sec

    • I tried AutoFS as well by setting the /net -hosts --timeout=60 in the autofs.master. For a reason I have to restart the autofs service every time I login. Anyway, in this case when I upload a large file to QNAP the connection is frozen and I can’t see any connection from my laptop. Moreover I have to restart the router. The connection seems slow anyway. I tried the same with the Linux Mint (I used /net -hosts -fstype=nfs4,rw, I don’t know if I can’t use the same with Antergos) and the speed is about 110MB/sec. I tried Antergos with direct connection with the NAS without any problem.

    I can’t understand where the problem is. I was ready to replace the cables or the router.

  • @nakanoXF
    Have you tried changing the NFS parameters in mount? See

    man nfs
    

    You could try change rsize and/or wsize larger, e.g. 1048576 (or some large multiple of 1024) bytes.
    And make sure to set nfsvers to 4.

  • @manuel said in HTTP/NFS Connectiity Problems:

    nfsvers

    The only change I’ve done so far is at the autofs.master in order to include :

    /net -hosts --timeout=60

    How can I set NFS v4 in the autofs.master? Or do I have to create a separate file as Wiki says?

    Moreover, there is a problem already with the browser download as I said before that doesn’t have a relation with NFS.

  • @nakanoXF

    man auto.master
    

    On the configuration line, just add mount options in the end.

    Alternatively, you could just temporarily disable autofs and see is the mount command, see

    man mount
    

    with these (or some other) options make any difference.

httpnfs1 connectiity1 Posts 4Views 92
Log in to reply