• Slow boot and Nvidia driver


    Hi folks,

    After a decade in the walled garden I finally dumped OS X a few months ago for Ubuntu on an XPS 15 9560. Ubuntu has been excellent, but the more I read about the Arch rolling release world the more I like it, and Antergos sounds like the distro for me!

    I have finally got Antergos (GNOME DE) installed after a couple of days struggling with graphics card and UEFI issues using antergos-nvidia-17.9-2-x86_64.iso :)

    So here are my first two questions as a fresh new Antergos user…

    NVIDIA

    The first thing I did on successful login was to pacman -Ss nvidia which installed the new 387 official driver. Oops - that’s the version that caused a black screen on Ubuntu, and sure enough it killed my Antergos install. I booted to the recovery shell, uninstalled the nvidia packages and removed xorg.conf to get back in.

    So now I’m wondering what the best way is to install the 384 version and not have pacman update it to the broken 387. I found this: https://forum.antergos.com/topic/2774/how-to-downgrade-a-package/2, so I guess I should do something like this:

    pacman -U nvidia-384.90-1-x86_64.pkg.tar.xz
    pacman -U nvidia-utils-384.90-1-x86_64.pkg.tar.xz
    pacman -U nvidia-settings-384.90-1-x86_64.pkg.tar.xz
    

    And then add the following to /etc/pacman.conf :

    nvidia nvidia-utils nvidia-settings
    

    Am I on the right track?

    SLOW BOOT

    After selecting Antergos in my Grub menu, my boot takes a really long time until the login screen is displayed. I’ve run the systemd diagnostics:

    systemd-analyze
    # Startup finished in 10.980s (firmware) + 10.942s (loader) + 1.720s (kernel) + 940ms (userspace) = 24.584s
    
    systemd-analyze blame
    #           613ms dev-nvme0n1p6.device
    #           361ms NetworkManager.service
    #           230ms upower.service
    #           164ms ufw.service
    #           131ms systemd-timesyncd.service
    #            70ms [email protected]
    #           ...
    
    systemd-analyze critical-chain
    #graphical.target @940ms
    #└─lightdm.service @925ms +14ms
    #  └─systemd-user-sessions.service @920ms +4ms
    #    └─network.target @920ms
    #      └─NetworkManager.service @558ms +361ms
    #        └─dbus.service @539ms
    #          └─basic.target @537ms
    #            └─paths.target @537ms
    #              └─org.cups.cupsd.path @537ms
    #                └─sysinit.target @536ms
    #                  └─systemd-timesyncd.service @405ms +131ms
    #                    └─systemd-tmpfiles-setup.service @394ms +9ms
    #                      └─systemd-journal-flush.service @349ms +44ms
    #                        └─systemd-journald.service @303ms +45ms
    #                          └─systemd-journald-dev-log.socket @300ms
    #                            └─system.slice @293ms
    #                              └─-.slice @283ms
    

    All the services load quickly and firmware is pre-grub, so the only slow thing seems to be the loader. What is that, and is there any way I can speed this up? Is there something else that could be delaying my boot?

    Thanks in advance for any advice :)

  • @evaljim said in Slow boot and Nvidia driver:

    pacman -Ss nvidia

    you want to say pacman -S nvidia as option -Ss is a search term ;)

    and welcome wholeheartedly to Antergos community! Feel free to say hello to all the nice fellas here:
    SAY HELLO!

    To downgrade nvidia you need to have also the buildtime kernel to downgraded! and this will caus a lot of packages to downgrade too…

    And if you are sure that the GTX 1050 nvidia chipset (is it what you have inside?) is not working with nvidia-387 ?
    As i have another user with this card who can not get Antergos installed… … and yea the Nvidia-ISO 17.9 has the nvidia-384 !

    There is also a wiki page on Archwiki: https://wiki.archlinux.org/index.php/Dell_XPS_15_9560

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • i just build nvidia-384 against current kernel, so you can try installing from my packages repo:

    wget http://www.kamprad.net/Downloads/antergos-packages/nvidia-384-384.69-1-x86_64.pkg.tar
    sudo pacman -U nvidia-384-384.69-1-x86_64.pkg.tar
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Thanks for helping @joekamprad !

    @joekamprad said in Slow boot and Nvidia driver:

    you want to say pacman -S nvidia as option -Ss is a search term ;)

    Oops!
    But yeah - I did successfully install it.

    and welcome wholeheartedly to Antergos community! Feel free to say hello to all the nice fellas here:
    SAY HELLO!

    Thanks! And done :)

    To downgrade nvidia you need to have also the buildtime kernel to downgraded! and this will caus a lot of packages to downgrade too…

    Really? The packages I got seemed to install fine. nividia-settings ran fine too, although it was missing the Prime options for switching between the cards (and also missing nvidia-select and nvidia-switch - are they part of a different package?). I tried setting up my xorg.conf as per this guide, but it resulted in a black screen on reboot so I removed everything again: https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Using_nvidia

    And if you are sure that the GTX 1050 nvidia chipset (is it what you have inside?) is not working with nvidia-387 ?
    As i have another user with this card who can not get Antergos installed… … and yea the Nvidia-ISO 17.9 has the nvidia-384 !

    Honestly, I’m not sure now. I’m starting to suspect it’s just the xorg.conf. I had 384 running fine on Ubuntu, but when I upgraded to 387 everything seemed OK until I switched to the Nvidia card and rebooted - black screen. So I booted to root shell, used nvidia-select to switch back to the Intel card, rebooted and downgraded to 384 again.

    Your nvidia-17.9-2-x86_64.iso was the only one of the many I tried that let me into the Live environment to install, so thanks for that too!

    There is also a wiki page on Archwiki: https://wiki.archlinux.org/index.php/Dell_XPS_15_9560

    I did look at that, but I was just looking for the same setup I have in Ubuntu (official Nvidia driver & Nvidia settings with the option to switch between Intel & GTX1050).

    I’m going to take a look at my Ubuntu xorg.conf to see if I can spot anything.

    Interestingly, once I’d installed the nvidia stuff, I’m pretty sure it booted a lot quicker, even though I still hadn’t enabled the Nvidia driver yet. Another side effect was that I lost access to some resolutions in my display settings (including 1920x1080 which was annoying). Removing the nvidia packages fixed that though, and I’m back to painfully long boots.

  • @evaljim said in Slow boot and Nvidia driver:

    Prime options for switching between the cards

    https://forum.antergos.com/topic/7961/antergosprime-brings-optimus-prime-functionality-to-antergos

    As far as i understan it needs some setup to get intel><nvidia PRIME working, but there is a package now…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in Slow boot and Nvidia driver:

    https://forum.antergos.com/topic/7961/antergosprime-brings-optimus-prime-functionality-to-antergos

    As far as i understan it needs some setup to get intel><nvidia PRIME working, but there is a package now…

    Thanks! I’ll check that out and report back :)

  • Still no success up until now :( The script reinstalls nvidia-utils (387 obviously) and my system won’t boot. I’ve tried changing the script to install the latest 384 from the ALA but that also isn’t working - perhaps I need an earlier minor version. I’m going to start again with a fresh install from your nvidia installer, check the exact Nvidia version used by that and start from there. Hopefully I’ll get time tonight. If and when I get this working I’ll write a guide for other XPS 15 users.

Posts 7Views 277
Log in to reply