• MPV (hardware acceleration)


    Hi all. How to enable hwdec in mpv player. I mean, which packages and libraries need to be installed to enable hardware acceleration in mpv. Watch how the mpv eats the processor resources without accelerating, it’s tough.

  • @Sabur said in MPV (hardware acceleration):

    hwdec

    run mpv with the --hwdec=‘method’ option.

    To make this persistent, add the line hwdec=method to your configuration file (mpv.conf)

    hwdec=auto-copy
    hwdec-codecs=all
    

    http://jlk.fjfi.cvut.cz/arch/manpages/man/mpv.1

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • I tried this combination, dos’t work, the program is still used by software video processing. Don’t know, what’s wrong.

  • mpv --hwdec-codecs=h264 scoobydoo.mp4

    Playing: scoobydoo.mp4
    (+) Video --vid=1 () (h264 720x400 25.000fps)
    (+) Audio --aid=1 --alang=und (
    ) (aac 2ch 44100Hz)
    AO: [pulse] 44100Hz stereo 2ch float
    VO: [opengl] 720x400 => 720x402 yuv420p
    AV: 00:00:59 / 01:28:14 (1%) A-V: 0.000

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in MPV (hardware acceleration):

    mpv --hwdec-codecs=h264 scoobydoo.mp4

    with this config mpv.conf

    hwdec=vdpau
    hwdec-codecs=all
    

    get this error

    [[email protected] ~]$ mpv --hwdec-codecs=h264 Desktop/88.mkv 
    Playing: Desktop/88.mkv
     (+) Video --vid=1 '' (h264 1920x1088 23.976fps)
     (+) Audio --aid=1 --alang=eng '' (ac3 2ch 48000Hz)
    VO does not support requested hardware decoder, or loading it failed.
    AO: [pulse] 48000Hz stereo 2ch float
    VO: [opengl] 1920x1088 yuv420p
    AV: 00:00:47 / 00:16:30 (4%) A-V:  0.000
    Exiting... (Quit)
    [[email protected] ~]$
    

    with this config mpv.conf

    hwdec=auto-copy
    hwdec-codecs=all
    

    get this error

    [[email protected] ~]$ mpv --hwdec-codecs=h264 Desktop/88.mkv 
    Playing: Desktop/88.mkv
     (+) Video --vid=1 '' (h264 1920x1088 23.976fps)
     (+) Audio --aid=1 --alang=eng '' (ac3 2ch 48000Hz)
    [ffmpeg] Cannot load libnvcuvid.so.1
    [ffmpeg/video] h264_cuvid: Failed loading nvcuvid.
    Could not open codec.
    AO: [pulse] 48000Hz stereo 2ch float
    VO: [opengl] 1920x1088 yuv420p
    AV: 00:00:01 / 00:16:30 (0%) A-V:  0.000
    Exiting... (Quit)
    

    PS btw, on centos was installed gnome-player, and in preferences pick up hwdec=vdpau and all files automatic playing with hwdec and processor using 2-3%. I wanna the same effect on antergos.

  • @Sabur said in MPV (hardware acceleration):

    gnome-player

    gnome-mplayer? or totem?

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @Sabur said in MPV (hardware acceleration):

    hwdec=auto-copy
    hwdec-codecs=all

    If you adding this to your config you can not add another option to the command itself as they may disturb each other…

    If i put the two option into my ~/.config/mpv/mpv.config:

    mpv many.mkv                                                                                         
    Playing: many.mkv
     (+) Video --vid=1 (*) (h264 720x436 25.000fps)
     (+) Audio --aid=1 --alang=ger (*) 'Stereo' (aac 2ch 48000Hz)
    File tags:
     Title: AEONFLUX_PAL_GERMANY
    AO: [pulse] 48000Hz stereo 2ch float
    Using hardware decoding (cuda-copy).
    VO: [opengl] 720x436 => 1024x436 nv12
    AV: 00:05:24 / 01:29:05 (6%) A-V:  0.000
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in MPV (hardware acceleration):

    gnome-mplayer

    gnome-mplayer

  • The problem is solved. For Intel card use vaapi or auto. Nvidia requires vdpau. There must be only one configuration file mpv.conf and everything works fine=)
    Thx guys for participation in the discussion.

  • hey how do you no about my schizophrenia ???

    It was only dr. jekyll involved here 🎃

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

acceleration5 mpv1 Posts 10Views 1394
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.