• Virtualization prevents first boot on ASUS G75V


    Hello I recently installed Antergos alongside Windows 8.1 with the Graphical Installer and have been able to successfully boot the grub 2.0 menu. However upon selecting Antergos from the menu I get the following error “ASPM: Could not configure common clock” preventing me from booting Antergos - From what I understand this is a problem experienced by people with NVIDIA graphics cards and it has something to do with the BIOS virtualization options.

    If I disable the Virtualization option in my BIOS this problem goes away, HOWEVER it is replaced by another error where the computer complains about KVM being disabled by the BIOS and refusing once again to boot.

    Adding “nomodeset” to the Grub kernel line does not resolve this issue…is there anything I can do to solve it? I would like to use Antergos on my computer.

  • Hello I recently installed Antergos alongside Windows 8.1 with the Graphical Installer and have been able to successfully boot the grub 2.0 menu. However upon selecting Antergos from the menu I get the following error “ASPM: Could not configure common clock” preventing me from booting Antergos - From what I understand this is a problem experienced by people with NVIDIA graphics cards and it has something to do with the BIOS virtualization options.

    If I disable the Virtualization option in my BIOS this problem goes away, HOWEVER it is replaced by another error where the computer complains about KVM being disabled by the BIOS and refusing once again to boot.

    Adding “nomodeset” to the Grub kernel line does not resolve this issue…is there anything I can do to solve it? I would like to use Antergos on my computer.

  • Hi,

    Try disabling VT-D in BIOS. Also you could try booting using only the discrete graphics card and if that doesnt work try only using the intel card.

    Cheers!

  • Hello, it is disabling VT-D in the BIOS that causes the system to give the KVM disabled by BIOS error. Also my BIOS does not allow me to adjust the graphics settings in that way (I think this was a solution on affected Thinkpads but unfortunately my BIOS is more restricted).

  • Try removing “quiet” from the kernel boot command and add this in its place:

    nomodeset nouveau.modeset=0
    

    Once grub appears press “e”. The line you will be making the change looks something like this:

    linux /vmlinuz-linux root=UUID=letters-and-numbers-blah-blah rw resume=UUID=letters-and-numbers-blah-blah quiet
    

    Let me know the result

    Best Regards,
    Dustin

  • Okay that allowed me to boot into GNOME Shell, but I assume this means that I don’t have any 3D acceleration available? There doesn’t seem to be any compositing working in GNOME. Is there any way I can overcome this issue now that I’ve been able to boot into my OS? Would using the proprietary NVIDIA driver help? Thank you for all your help so far.

    EDIT: I tried removing nouveau and installing the nvidia drivers and now the computer goes up to the point where it launches the graphical interface and then the screen goes black and after a moment the fan starts blowing very hard but it never displays anything. I tried removing quiet and adding “nomodeset nvidia.modeset=0” to the GRUB kernel line but this did not resolve the problem. Do I need to do a fresh install of Antergos and then switch to linux-lts or something to solve this problem?

  • I was able to resolve the problem by installing the latest linux kernel (3.14.6 released today) which made Nouveau start working. I then tried installing the nvidia driver. This at first caused the same problem as before where I would get a black screen and the fan blowing hard, but I was able to resolve it by adding

    [code:3qxig960]rcutree.rcu_idle_gp_delay=1[/code:3qxig960]

    as a kernel parameter. My NVIDIA card is now working with the proprietary driver as expected.

Posts 7Views 1829
Log in to reply