• Antergos fails to boot (pciebus error)


    Hi all,

    Currently having some problems booting into antergos via my grub menu. I have currently got antergos setup alongside Windows 10 in a dual boot configuration. When selecting the antergos option sometimes it seems to work however other times I get a black screen with the last few messages saying:

    PCIe Bus Error: severity=corrected, type=Phyisical Layer, id=00e0(Receiver ID)

    device [8006:9d151] error status/mask=00000001/0000000

    [ 0] Receiver Error (First)

    The first messages are similar to:
    [Firmware Bug] : ACPI region does not cover t

    Although before it only did this ever so often, now it appears to be doing it nearly all the time. I have done some googling and tried several different pci related boot parameters to disable/surpress the messages and to disable certain active power management settings, as these have solved similar issues for other users, but no luck with any of those boot parameters.

    Any advice/help is greatly appreciated so I can get Linux working again for me!

    Thanks,
    Ell

  • @pilnet123 said in Antergos fails to boot (pciebus error):

    PCIe Bus Error: severity=corrected, type=Phyisical Layer, id=00e0(Receiver ID)

    can you give a systemsumup?

    like this:

    sudo pacman -S inxi
    inxi -Fxxc0
    

    or autoupload to pastebin and give the link only:
    inxi -Fxxc0 | curl -F [email protected] https://ptpb.pw/?u=1

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad

    Hi joekamprad,

    Please see:
    https://ptpb.pw/JWJM

    Thanks

  • @pilnet123 said in Antergos fails to boot (pciebus error):

    @joekamprad

    Hi joekamprad,

    Please see:
    https://ptpb.pw/JWJM

    Thanks

    I meant to say I ran that within the terminal on my DE - managed to get into antergos after doing numerous restarts/power off-ons, so it seems that this issue is sporadic.

  • @pilnet123
    And then the output of commands:

    df -h
    lsblk -l
    

    These are to check if there’s too little RAM or /tmp …

  • @manuel

    Hi manuel,

    Please see below:

    df -h
    Filesystem      Size  Used Avail Use% Mounted on
    dev             3.9G     0  3.9G   0% /dev
    run             3.9G  1.4M  3.9G   1% /run
    /dev/sda5        19G  9.5G  8.6G  53% /
    tmpfs           3.9G   17M  3.9G   1% /dev/shm
    tmpfs           3.9G     0  3.9G   0% /sys/fs/cgroup
    tmpfs           3.9G   34M  3.9G   1% /tmp
    /dev/sda1       256M   48M  209M  19% /boot/efi
    /dev/sda7        36G  822M   35G   3% /home
    tmpfs           789M   48K  789M   1% /run/user/1000
    
    
    lsblk -l
    NAME MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda    8:0    0 119.2G  0 disk 
    sda1   8:1    0   260M  0 part /boot/efi
    sda2   8:2    0    16M  0 part 
    sda3   8:3    0  59.1G  0 part 
    sda4   8:4    0   857M  0 part 
    sda5   8:5    0  18.6G  0 part /
    sda6   8:6    0   3.7G  0 part [SWAP]
    sda7   8:7    0  36.8G  0 part /home
    
  • @pilnet123
    RAM and /tmp seem to be OK for “normal” use I guess…

    Have you tried to use linux-lts kernel? Sometimes 4.13 kernel (the default in Antergos currently) has seen some stability problems.

  • @manuel

    I haven’t no. How would I go about using that kernel instead? Would it require a fresh install of antergos, could I keep my current DE setup?

    FYI these are the errors I am seeing as per the output from the journalctl command:

    Nov 14 17:46:47 ells-pc kernel: ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
    Nov 14 17:46:47 ells-pc kernel: (NULL device *): hwmon_device_register() is deprecated. Please convert the driver to use hwmon_device_register_with_info().
    Nov 14 17:46:47 ells-pc kernel: thermal thermal_zone9: failed to read out thermal zone (-5)
    Nov 14 17:46:47 ells-pc kernel: iwlwifi 0000:01:00.0 wlp1s0: renamed from wlan0
    Nov 14 17:46:47 ells-pc kernel: IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
    Nov 14 17:46:47 ells-pc kernel: pcieport 0000:00:1c.0: AER: Corrected error received: id=00e0
    Nov 14 17:46:47 ells-pc kernel: pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e0(Receiver ID)
    Nov 14 17:46:47 ells-pc kernel: pcieport 0000:00:1c.0:   device [8086:9d15] error status/mask=00000001/00002000
    Nov 14 17:46:47 ells-pc kernel: pcieport 0000:00:1c.0:    [ 0] Receiver Error         (First)
    Nov 14 17:46:47 ells-pc kernel: pcieport 0000:00:1c.0: AER: Corrected error received: id=00e0
    Nov 14 17:46:47 ells-pc kernel: pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e0(Receiver ID)
    Nov 14 17:46:47 ells-pc kernel: pcieport 0000:00:1c.0:   device [8086:9d15] error status/mask=00000001/00002000
    Nov 14 17:46:47 ells-pc kernel: pcieport 0000:00:1c.0:    [ 0] Receiver Error         (First)
    Nov 14 17:46:47 ells-pc kernel: IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
    Nov 14 17:46:47 ells-pc kernel: pcieport 0000:00:1c.0: AER: Corrected error received: id=00e0
    Nov 14 17:46:47 ells-pc kernel: pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e0(Receiver ID)
    Nov 14 17:46:47 ells-pc kernel: pcieport 0000:00:1c.0:   device [8086:9d15] error status/mask=00000001/00002000
    Nov 14 17:46:47 ells-pc kernel: pcieport 0000:00:1c.0:    [ 0] Receiver Error         (First)
    Nov 14 17:46:47 ells-pc kernel: IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
    Nov 14 17:46:47 ells-pc kernel: IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
    Nov 14 17:46:47 ells-pc kernel: Console: switching to colour frame buffer device 400x112
    Nov 14 17:46:47 ells-pc kernel: i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
    Nov 14 17:46:47 ells-pc systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:intel_backlight...
    Nov 14 17:46:47 ells-pc systemd[1]: Started Load/Save Screen Backlight Brightness of backlight:intel_backlight.
    Nov 14 17:46:48 ells-pc kernel: [drm] RC6 on
    
  • FYI I noticed that from the advanced options for antergos option in grub I was able to select the LTS kernel. I tried booting using this and I got the same error messages.

  • Even if it’s Ubuntu and another kernel … the error is the same

    PCI bus error at startup when booting on the home screen.

    https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1588428

    On the other hand the errors that are shown on the screen are the same: https://launchpadlibrarian.net/263296837/screenshot.jpg

  • @pilnet123
    You mentioned having tried many kernel boot parameters already. Can you list which ones?

  • @manuel said in Antergos fails to boot (pciebus error):

    @pilnet123
    You mentioned having tried many kernel boot parameters already. Can you list which ones?

    So I have tried these, none of which seem to work and the startup still hangs on the black screen with the errors:

    pci=nommconf
    pcie_aspm=off
    pci=nomsi # With this parameter I get a separate error message
    pci=noaer

    It is strange how if worked quite well for me yesterday, I would maybe get the error 10% of the time, however now i am seeing the error 90% of the time! I hope there is something I can do!

  • @pilnet123 i would try using LTS Kernel:

    sudo pacman -S linux-lts linux-lts-headers
    

    on next boot choose advanced options on bootmenu and choose linux-lts entry to boot.

    Usually your hardware should run without problems, but at the moment there are some problems with intel, i still do not know what it is caused by…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in Antergos fails to boot (pciebus error):

    @pilnet123 i would try using LTS Kernel:

    sudo pacman -S linux-lts linux-lts-headers
    

    on next boot choose advanced options on bootmenu and choose linux-lts entry to boot.

    Usually your hardware should run without problems, but at the moment there are some problems with intel, i still do not know what it is caused by…

    I did try the linux-lts kernel from the advanced options but I still got the same errors :(. I just think it is strange how the issue seems to be random

  • One thing to ask… The variable GRUB_CMDLINE_LINUX_DEFAULT in my /etc/default/grub file does not have the word splash in it… Instead the value it is just:

    quiet resume=UUID={uuid number here}

    Should I add the splash keyword to this? As I was going to try adding the pci= statements to…

  • @pilnet123
    Word “splash” shouldn’t be needed.
    But have you tried kernel parameter below?

    acpi=off
    
  • @manuel
    Yeah I tried that but when I hit enter it says the usual starting version 235 , then info about clean/files/blocks then the cursor just blinks randomly the line beneath it and it hangs on that screen.

  • @pilnet123

    I’m still looking and we’ll find it !:grin:

  • @judd said in Antergos fails to boot (pciebus error):

    @pilnet123

    I’m still looking and we’ll find it !:grin:

    Really appreciate it.

    Just seems to be looking very doubtful if this is some hardware related bug. I don’t think I can have my laptop so temperamental with Linux deciding to boot only half the time. Now when I try to boot into windows it wants to run a check disk most of the time after I have these boot issues and also sometimes my touch pad does not respond until I power off the laptop and turn it back on.

    Part of me is just thinking whether it is easier to abandon the dual boot setup and simply run antergos in a VM under Windows. But then I don’t get the slick responsive feel of KDE which I do now :(

pciebus1 fails16 error198 boot176 Posts 22Views 299
Log in to reply