• Teamviewer libraries depencies fail..


    Hi, I try install teamviewer for work and always said:

    incapaz de satisfacer la dependencia 'freetype2<2.8.1' requerida por teamviewer
    incapaz de satisfacer la dependencia 'lib32-freetype2<2.8.1' requerida por teamviewer
    

    I don’t know to resolve it.

  • @jose.alki said in Teamviewer libraries depencies fail..:

    Hi, I try install teamviewer for work and always said:

    incapaz de satisfacer la dependencia 'freetype2<2.8.1' requerida por teamviewer
    incapaz de satisfacer la dependencia 'lib32-freetype2<2.8.1' requerida por teamviewer
    

    I don’t know to resolve it.

    Hi
    I think it’s asking you to install those dependencies …

    $ sudo pacman -Ss freetype2
    [sudo] password for judd: 
    extra/freetype2 2.8.1-1 [instalado]
        Font rasterization library
    
    
  • @judd sorry, yes.
    I try install with GUI wizzard, and terminal with pacman. And Always said other depencencies in cascade :(

  • @jose.alki said in Teamviewer libraries depencies fail..:

    And Always said other depencencies in cascade

    Paste here what the console tells you when you want to install (because otherwise, from here I can not know) :)

  • @judd
    Ok, thanks
    capture 1
    The lib32-typefree have install capture 2

  • Does everything work well then teamviewer???

  • @judd Nop. As I read is the problem of the versions of the libraries

  • @jose.alki said in Teamviewer libraries depencies fail..:

    The lib32-typefree have install

    That you already installed it then?

    You would need to install freetype2

  • install the two,

    freetype2

    lib32-freetype2

    restart and you’ll tell me …

  • @jose.alki
    It seems that teamviewer needs older dependencies.
    So you could downgrade freetype2 and lib32-freetype2 with the package called downgrade.
    But there may be problems with other apps because of downgrading, so be careful…

  • @manuel

    Maybe it’s because of the symbol < that I did not pay attention to it and then degrade it?

    ‘freetype2<2.8.1’

  • @jose.alki
    Usage of downgrade assumes you have locally older versions of those packages available.

  • @manuel said in Teamviewer libraries depencies fail..:

    @jose.alki
    Usage of downgrade assumes you have locally older versions of those packages available.

    If I know that, I’m talking about the symbol <

  • @judd
    Sometimes those warning/error messages are not so easy to read… ;)

  • @manuel said in Teamviewer libraries depencies fail..:

    @judd
    Sometimes those warning/error messages are not so easy to read… ;)

    Right, but it could be for that reason that the console shot it like that

  • @judd
    Did you mix it with something else? I believe it just means freetype2 should be older than 2.8.1.

    @jose-alki
    But anyway, downgrading is not generally a good idea, since it may do harm to other apps that depend on them.

    And in this case, as teamviewer is an AUR package, a better solution would be to inform the packager of teamviewer (http://aur.archlinux.org/packages/teamviewer) of these dependency problems.

  • @manuel said in Teamviewer libraries depencies fail..:

    I believe it just means freetype2 should be older than 2.8.1.

    That’s exactly what I was referring to !!!

  • @judd
    Hmm… sorry I don’t understand… some kind of language problem I guess…

  • @jose-alki

    Read all we have said about your problem so far, then ask all the questions you have (who does not have them? :))

fail18 libraries6 teamviewer3 depencies1 Posts 30Views 1696
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.