• Dependency Cycle Error issue while updating


    Hi everyone,

    While attempting to update today using sudo pacman -Syu, I get the following warning:

    warning: dependency cycle detected:
    warning: usbmuxd will be installed before its libimobiledevice dependency

    Here is a screenshot of what happens:

    ![0_1510544410848_Screenshot_20171112_193610.png](Uploading 100%)

    Does anyone know what’s happening here, and is it safe for me to update?

    Thanks in advance!

    Matt

    edit: Not sure why, but I get an error while trying to upload my screenshot, so I copied and pasted what it says from the command line:

    :: Synchronizing package databases…
    antergos is up to date
    core is up to date
    extra is up to date
    community is up to date
    multilib is up to date
    :: Starting full system upgrade…
    resolving dependencies…
    looking for conflicting packages…
    warning: dependency cycle detected:
    warning: usbmuxd will be installed before its libimobiledevice dependency

    Packages (5) libimobiledevice-1.2.0+66+g5a85432-1 libusbmuxd-1.0.10+13+gc724e70-1 libxml2-2.9.7+4+g72182550-1 usbmuxd-1.1.0+28+g46bdf3e-1
    xf86-video-fbdev-0.4.4+12+ge0bce0d-1

    Total Download Size: 1.77 MiB
    Total Installed Size: 11.51 MiB
    Net Upgrade Size: 0.18 MiB

    :: Proceed with installation? [Y/n] n

  • Ok so I just installed libimobiledevice separately first, and then did the rest of the update and everything seems to be fine haha.

    Well that was a quick fix, I guess this issue is solved :)

    Not sure how to mark this as solved, or I would do it…

  • @mattb66 I’ve seen similar warnings with some KDE packages, but so far they never caused any problems. It is a small error with dependencies. It is wise to be careful with such warnings, but often they are just warnings.

Posts 3Views 78
Log in to reply