• Add New Printer Error: Cups Server Error


    Hi Guys,

    I’m trying to add a new printer because my old one stopped working. However, everytime I try to add it, I get the same error code: CUPS server error “Server-error-internal-error”

    I had a bug like this a few months ago for my old printer but once I added myself to the sys and wheel groups, it seemed to be fixed. Now, I’m having the same issues, and have no ideas on how to fix it. For reference, my user is part of the groups “sys”, “lp”, “wheel”, and “user”

    0_1510257735999_Screenshot from 2017-11-09 11-58-04.png

    0_1510257777168_Screenshot from 2017-11-09 12-02-43.png

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • @mach01dan said in Add New Printer Error: Cups Server Error:

    Server-error-internal-error

    you should reset cups configurations…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Hi @joekamprad Thanks for the tip. How would I go about doing this? I was thinking uninstalling/reinstalling cups.

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • i am not sure at the moment … but yes i would uninstall, search for configs leftovers and reinstall…
    configs are under /etc/cups/ :

    /etc/cups/classes.conf
    /etc/cups/cups-files.conf
    /etc/cups/cups-files.conf.default
    /etc/cups/cupsd.conf
    /etc/cups/cupsd.conf.default
    /etc/cups/printers.conf
    /etc/cups/snmp.conf
    /etc/cups/snmp.conf.default
    /etc/cups/subscriptions.conf

    so

    sudo systemctl stop org.cups.cupsd.service
    sudo systemctl disable org.cups.cupsd.service
    

    sudo pacman -Rsc cups
    sudo rm -R /etc/cups
    sudo pacman -S cups

    sudo systemctl start org.cups.cupsd.service
    sudo systemctl enable org.cups.cupsd.service
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad said in Add New Printer Error: Cups Server Error:

    sudo systemctl enable org.cups.cupsd.service

    Hi @joekamprad Thanks for the tips but it didn’t work. I still get the same error code.

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • and what say:

    systemctl status org.cups.cupsd.service
    

    and:

    journalctl --since "2 days ago" /usr/bin/cupsd
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • 0_1510268128287_Screenshot from 2017-11-09 14-54-48.png

    0_1510268137502_Screenshot from 2017-11-09 14-55-10.png

    I suspect the reason there are no logs is because I just wiped the cups.

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • do you try already setup the printer over webinterface?
    http://localhost:631

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • and what is the printer manufacturer / model / connection

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Yes I keep getting the error: Unable to copy PPD file. The printer is a Canon MF731C 733C and I’m trying to connect via IPP

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • @mach01dan said in Add New Printer Error: Cups Server Error:
    Canon MF731C

    this: Color imageCLASS MF733Cdw ???https://www.usa.canon.com/internet/portal/us/home/products/details/printers/color-laser/color-imageclass-mf731cdw/color-imageclass-mf731cdw

    Do you have the same printer running before? or is it a new one? and what driver do you install?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Yes, that printer. This is the new one since my HP hit the dust a few days ago. From what I know, the ipp connection should be driverless and I couldn’t find a driver.

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • Is available daemon running?

    systemctl status avahi-daemon.service
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • but when you say “driverless” you aretalking about IPP-everywhere printing?

    To get this running you need to set up some stuff first:

    sudo pacman -S nss-mdns
    

    start and enable avahi (if not already running):

    sudo sytsemctl start avahi-daemon.service
    sudo systemctl enable avahi-daemon.service
    

    edit nns-mdms to provide local hostname resolution:

    sudo nano /etc/nsswitch.conf
    

    and change the line starting with host to include mdns_minimal [NOTFOUND=return] before resolve and dns:

    hosts: ... mdns_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] dns ...
    

    start and enable cups-browsed service to be able to see IPP Everywhere server:

    sudo systemctl start cups-browsed.service
    sudo systemctl enable cups-browsed.service
    

    restart cups:

    sudo systemctl restart org.cups.cupsd.service
    

    and search for network printer with gnome-control-center or over webinterface of cups: http://localhost:631

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Thanks again. Yes, avahi-daemon was running. I followed the steps you gave, but it still gives the same error code.

    Ubuntu ~ Debian ~ Fedora ~ Antergos
    Dell XPS 15 9530

  • I am off for today… almost 2 in the morning here…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • But one last thinking:
    As far as I understand those printers will be setup automatically and will appear automatic inside devices printer settings when aviable…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • I’m very interested in you finding a solution…

    I had the same problem and just workarounded it copying the PPD file from manjaro and then using the web interface for cups http://localhost:631/ as you can see here

    I installed manjaro in a VM and seted bridge mode, then installed my printer and copied the file and then worked.

    This problem started a time ago and made the GUI for printers stop working here on both my PC and notebook

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • i am may not effected as i have a HP-Printer and using hp-setup to setup… via usb connection.
    This problem is related to network printing.

    The other thread from you Mr. @fernandomaroto what do the clue was adding the right URI as the other one was not a remote uri at all… (ipp://HPC4346B2ECF07.local:631/ipp/print ) special on HP printers most of them needs some properitary plugin to work correctly…

    But canon here in topic… as i can see it is not a
    IPP Everywhere™ printer, as i can not find it inside the search function here: https://www.pwg.org/dynamo/eveprinters.php
    only HP printers there…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad
    Hi joe!
    i didn’t have the problem in the old days, the printer could be removed and readded as many times as i wanted (networked). Some time later i got the same error from this post “Server-error-internal-error” and was only able to workaround to make it work.
    But since i never managed to understand what is/was wrong you may be right. The thing i wanted to know is why worked before and then stopped working, and as i said the same for both pc and notebook.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

cups13 error196 printer31 Posts 23Views 363
Log in to reply