• Plasma desktop crashorama!!!


    Starting a few weeks ago my KDE Plasma desktop started to crash seemingly at random. :anguished: It starts with a message that .conf/drkonqirc can not be written to, then .conf/plasmashellrc, kreadconfig5rc, and finally kio_desktoprc, then open applications become unstable, the panels go fully transparent, and finally everything turns black. Ctrl-Alt-Delete, pops up another message: that .conf/ksmserver-logout-greeterrc can not be launched, and the only way out (that I know of) is to turn off the computer manually and restart. Sometimes that works, often not, and a few more reboots are needed, sometimes with a “Start job” first, and sometimes two or more reboots are needed to get back to normal. That of course doesn’t last, and it crashes sooner or later again.

    Here are some of the possible solutions I have found, and investigated:

    Nuke the unwritable files and restart, or restart Plasmashell Ctrl-Alt-P; Those do seem to give me an extra hour or so, but the problem returns, and really, those are not actual solutions as they don’t address the cause. :dizzy_face:

    Baloo is hogging a bunch of resources, and nuking it will fix it; Tried it, don’t help.

    An Nvidea graphics card issue; Everything worked fine for months, and I don’t have an Nvidea card. On a Fedora bug report, as you read down the posts, the list of cards just gets longer and longer, so one can assume, that all cards are bad, or it’s not the real problem.

    “It’s wayland try X11”; I am using X11, not wayland.

    Of course there are many other possible culprits and fixes going back to when Plasma was first released, and many are marked “Solved”, but mention libs, binaries, packages, files… that are in order, or culprits I don’t have, and fixes already resolved by updates.

    Now that I have the power to upload files, here are the logs:

    [0_1510161981666_logs-2017-08-11_08-58-43.tar](Uploading 100%)

    If anyone who knows how to decipher them and can help :nerd: I would gladly appreciate it :hugging: , but I have also read that in some cases even those may not contain any clues either . :nauseated_face:

    Here are some possible clues :mag: : My other user account does not seem to be effected (no customization’s), but i don’t use it hardly at all, and when I do, not for much. The affected account does have some customization’s, but only few, and none known to be problematic as I have read so far. Evolution is always running (autostart), but it never happens when I am using it. So far it has happened many times when using Firefox, Dolphin, and/or LibreOffice.

    :confounded: :confused: :persevere:

    The flazzum you spizz, the zoider you splat!

  • @Zoidmo
    If your other user account is working properly, you could use it instead, or create another user account for normal use.
    The fact that the other account is working indicates that the failing user account has some internal problems (whatever the reason might be), but the system itself sounds to be OK.

    By the way, the logs are not visible…

  • @Zoidmo said in Plasma desktop crashorama!!!:

    [0_1510161981666_logs-2017-08-11_08-58-43.tar](Uploading 100%)

    @manuel said:
    …the logs are not visible…

    It would be so kind to fix the logs ???

  • I don’t know what to do about the log’s???

    I keep separate accounts for good reasons, the affected one is for my business, and the one I use the most, the unaffected account is sort of for emergencies and troubleshooting, which is why I did not change anything, not even the wallpaper.

    Every time I have nuked and recreated an account, either the same problems come back sooner or later, or new (sometimes worse) ones arise. I cant go through that every time something goes wrong.

    I can use the account, Which I have to daily, and often, but the constant restarting is annoying. So far it has not crashed on me while taking in client info…

    The flazzum you spizz, the zoider you splat!

  • Well, now I see (where I wasn’t looking before), I still don’t have enough privileges to upload files!!! Strangely this happens first, throwing me for a loop: [0_1510166171224_logs-2017-08-11_08-58-43.tar](Uploading 100%)

    100% of nothing complete!!!

    The flazzum you spizz, the zoider you splat!

  • What does one need to get upload privileges?? I can’t find the forum documentation anywhere!

    The flazzum you spizz, the zoider you splat!

  • the fileupload is a bit buggy and depending on the size or filetype it do not work…
    But tar.xz seem to work
    0_1510181445827_testfile.tar.xz
    pdf not…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad It acted like it uploaded just fine (only 128 KiB), but it popped up a message that I don’t have enough privileges. :cry:

    One day I will be King :crown: and super privileged!

    Is there any Forum documentation??? Because if there is, I really can’t find any. :sunglasses:

    The flazzum you spizz, the zoider you splat!

  • @Zoidmo said in Plasma desktop crashorama!!!:

    Forum documentation

    no i do not think, alt text
    is made to not need a howto for using it… (as most of the forasoftware) txt = text

    • Antergos itself do not have this, and nodebb itself have only setupguides for the software itself…

    But: Markdown-Cheatsheet
    as this is what is used …

    also tables are possible:

    Tables Are Cool
    col 3 is right-aligned $1600
    col 2 is centered $12
    zebra stripes are neat $1

    and video:

    joekamprad i3

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

Posts 9Views 148
Log in to reply