• Brother printer not working after update


    Hello,

    Since the last update,

    my printer, a Brother DCP-L2500D,
    is not working.
    It appears in the CUPS web interface as ‘idle’,
    and I am unable to change this.

    The driver installed is the brother-dcp-l2500d from the aur,

    and

    $ tail -n 100 -f /var/log/cups/error_log
    E [06/Nov/2017:11:16:38 +0000] [Client 35] Returning HTTP Forbidden for CUPS-Get-Devices (no URI) from localhost
    
    dmesg | tail
    [   26.770717] wlp3s0: associated
    [   26.770756] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
    [   27.597013] Console: switching to colour frame buffer device 170x48
    [   27.603486] radeon 0000:01:00.0: fb0: radeondrmfb frame buffer device
    [   28.130737] [drm] Initialized radeon 2.50.0 20080528 for 0000:01:00.0 on minor 0
    [   28.131691] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
    [   28.293208] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input14
    [   39.446678] usblp 2-1.2:1.0: usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x04F9 pid 0x0321
    [   39.446732] usbcore: registered new interface driver usblp
    [   81.923736] fuse init (API version 7.26)
    
    

    I tried reinstalling the driver,

    and, from the Arch wiki:

    CUPS/Troubleshooting

    Conflict with SANE
    If you are also running SANE, it’s possible that it is conflicting with CUPS. To fix this create a Udev rule marking the device as matched by libsane:

    /etc/udev/rules.d/99-printer.rules
    ATTRS{idVendor}=="vendor id", ATTRS{idProduct}=="product id", MODE="0664", GROUP="lp", ENV{libsane_matched}="yes"
    

    but nothing yet.

    Any suggestion?
    Thanks,
    Maurizio

  • @maurizio said in Brother printer not working after update:

    DCP-L2500D

    can also help to uninstall hplip and foomatic-db-engine

    Do you configure over webinterface? with http://localhost:631 ?
    you can try using your hostname instead of localhost

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad said in Brother printer not working after update:

    can also help to uninstall hplip and foomatic-db-engine

    Hi Joekamprad,
    pleased to meet you again!

    I removed the two packages, but no luck.

    @joekamprad said in Brother printer not working after update:

    Do you configure over webinterface? with http://localhost:631 ?
    you can try using your hostname instead of localhost

    I do not usually configure over webinterface,
    it’s actually a new discovery for me.
    I usually connect the printer through usb.
    To change the address, is it sufficient to change it in /etc/cups/cupsd.conf ?

  • i mean simple open inside your browser:

    http://“yourhostname”:631 but this is not working for standard Antergos config…

    But simple try to remove the printer with webinterface: http://localhost:631/printers/
    and reconfigure/add it may help: http://localhost:631/admin/

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

Posts 4Views 136
Log in to reply