• Brother printer not working after update


    Hello,

    Since the last update,

    my printer, a Brother DCP-L2500D,
    is not working.
    It appears in the CUPS web interface as ‘idle’,
    and I am unable to change this.

    The driver installed is the brother-dcp-l2500d from the aur,

    and

    $ tail -n 100 -f /var/log/cups/error_log
    E [06/Nov/2017:11:16:38 +0000] [Client 35] Returning HTTP Forbidden for CUPS-Get-Devices (no URI) from localhost
    
    dmesg | tail
    [   26.770717] wlp3s0: associated
    [   26.770756] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
    [   27.597013] Console: switching to colour frame buffer device 170x48
    [   27.603486] radeon 0000:01:00.0: fb0: radeondrmfb frame buffer device
    [   28.130737] [drm] Initialized radeon 2.50.0 20080528 for 0000:01:00.0 on minor 0
    [   28.131691] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
    [   28.293208] input: HDA ATI HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input14
    [   39.446678] usblp 2-1.2:1.0: usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x04F9 pid 0x0321
    [   39.446732] usbcore: registered new interface driver usblp
    [   81.923736] fuse init (API version 7.26)
    
    

    I tried reinstalling the driver,

    and, from the Arch wiki:

    CUPS/Troubleshooting

    Conflict with SANE
    If you are also running SANE, it’s possible that it is conflicting with CUPS. To fix this create a Udev rule marking the device as matched by libsane:

    /etc/udev/rules.d/99-printer.rules
    ATTRS{idVendor}=="vendor id", ATTRS{idProduct}=="product id", MODE="0664", GROUP="lp", ENV{libsane_matched}="yes"
    

    but nothing yet.

    Any suggestion?
    Thanks,
    Maurizio

  • @maurizio said in Brother printer not working after update:

    DCP-L2500D

    can also help to uninstall hplip and foomatic-db-engine

    Do you configure over webinterface? with http://localhost:631 ?
    you can try using your hostname instead of localhost

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in Brother printer not working after update:

    can also help to uninstall hplip and foomatic-db-engine

    Hi Joekamprad,
    pleased to meet you again!

    I removed the two packages, but no luck.

    @joekamprad said in Brother printer not working after update:

    Do you configure over webinterface? with http://localhost:631 ?
    you can try using your hostname instead of localhost

    I do not usually configure over webinterface,
    it’s actually a new discovery for me.
    I usually connect the printer through usb.
    To change the address, is it sufficient to change it in /etc/cups/cupsd.conf ?

  • i mean simple open inside your browser:

    http://“yourhostname”:631 but this is not working for standard Antergos config…

    But simple try to remove the printer with webinterface: http://localhost:631/printers/
    and reconfigure/add it may help: http://localhost:631/admin/

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • hi,
    I hope I can follow up this old post

    …been out for a while…

    I removed the printer from CUPS,
    and now if I do ‘add printer’ or’find new printer’
    there’s nothing to choose from

  • @maurizio
    By the way, which DE are you using?
    If it happens to be Xfce, probably installing gtk3-print-backends helps (or that might help anyway).

  • maurizio in Xfce 7. Okt. 2017, 20:34 say: “I recently installed Antergos XFCE”

    sudo pacman -S gtk3-print-backends
    sudo systemctl restart org.cups.cupsd.service

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @manuel said in Brother printer not working after update:

    gtk3-print-backends

    Yes, it’s xfce.
    gtk3-print-backends was already installed, I reinstalled it,
    but nothing yet.

    By the way,
    I have

    /usr/share/cups/model/brother-DCPL2500D-cups-en.ppd

    shall I make cups read this file?
    (if it makes sense)

    or:

    gtk3-print-backends asks for a uri.
    I do not have any idea of which uri to give

  • @maurizio
    You are not supposed to use gtk3-print-backends directly.

  • @maurizio
    Have you looked at instructions here?
    http://solutions.brother.com/linux

Posts 10Views 380
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.