• Wifi Not working


    Hi All,

    I went through the basics of wifi configurations and have also gone through posts with similar issues on this forum. However, I need some help connecting to my WiFi. Below is the summary of what I did:

    • Installed Antergos Deepin on my laptop (HP Pavilion AB-123tx)
    • Didn’t know about wifi configurations then (chrooting and getting wifi drivers/config)
    • I currently have access to internet via 2 options: Ethernet cable, and Phone’s hotspot
    • Even though I have configured wifi, system doesn’t connect to it (Can connect to Phone’s hotspot)
    • Just let me know if I need to post the output of any commands needed (FYI, I already did lspci, ip link, etc.)
  • @harshal259
    Do you mean USB cable tethering with your phone?

    Can you give the output of

    lspci -vnn | grep -i net
    
  • @harshal259 !

    Before giving any information command, do you enable dhcpcd and NetworkManager? So:

    systemctl enable dhcpcd.service

    systemctl enable NetworkManager.service

    and then * reboot * and then tell us ???

  • @manuel I mean sharing my phone’s internet connection via Hotspot.

    Here’s the output of above command:

    [[email protected] ~]$ lspci -vnn | grep -i net
    03:00.0 Network controller [0280]: Broadcom Limited BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 0a)
    Subsystem: Hewlett-Packard Company RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [103c:80a4]

  • @harshal259
    Did you already install broadcom-wl-dkms?

  • @manuel Yes i did install the driver yesterday. It was working fine. After rebooting, however, it isn’t connecting to the network. Also, I can see multiple copies (maybe profiles?) for the same network being displayed in WICD interface.

    I also found out that the error was due to linux headers, but i installed those too…Can’t figure out what the problem is. :/

  • @harshal259
    About the related networking services, which ones do you have enabled and active?

  • @manuel As per your suggestion, I ran the following services:

    systemctl enable dhcpcd.service

    systemctl enable NetworkManager.service

  • @harshal259
    Does it help if you disable dhcpd.service and reboot?

  • You could show also:

    lspci -vnn -d 14e4:4365
    
  • @manuel I don’t know what worked, but I am connected to my Wifi after doing the following:

    reinstalled dkms-wl package
    enable the above services and then disabled dhcpd.service and rebooted.

    Signal strength is very low. i’m standing next to the router.

    Here’s the output of the command:

    [[email protected] ~]$ lspci -vnn -d 14e4:4365
    03:00.0 Network controller [0280]: Broadcom Limited BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    Subsystem: Hewlett-Packard Company BCM43142 802.11b/g/n [103c:804a]
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at 94100000 (64-bit, non-prefetchable) [size=32K]
    Capabilities: <access denied>
    Kernel driver in use: wl
    Kernel modules: wl

    PS: Thanks for the help. But I’d like to know how to troubleshoot similar issues if I encounter them in future.

  • @harshal259
    Troubleshooting: get as much information about the problem (hardware, software, anything else related…) as you can, and then do a web search (with e.g. DuckDuckGo, Google etc).
    Use exact keywords related to the problem, and add keywords like “Antergos” or “Arch Linux”.
    Then read the links that sound “reasonable” and recent enough.
    That’s what I would do.

    If that doesn’t help, then come here and ask a question. :)

  • I am “happy” owner of HP too, but with realtek rtl card. in my case i had to change antenna value as the signal was really poor. Not sure about your card but it may be worth to check if it has more than one antenna.
    In my case:
    https://bbs.archlinux.org/viewtopic.php?id=208472
    helped. I had the same problem on all ubuntus, fedoras. I have been using antergos for 3 days now so far is good. I bought usb wireless card two days after I purchased my HP as my backup. Do the same it will save you a lot of stress.

  • Thanks for the help everyone.

    I figured out what was needed to fix my WiFi.

    Reinstalled broadcom-wl-dkms module (inspected the details and the log was showing that I need linux-lts-headers) to install that particular version of dkms module. (due to which it wasn’t working)

    did a pacman -S linux-lts-headers and post install dkms was automaticaly installed. Rebooted and got my Wifi to work. :)

  • @harshal259
    Nice work!
    Actually I’d like to see linux-lts as the default kernel of Antergos, but I understand that the latest kernel can be better for newer machines and other new-ish hardware.
    But - as you also found out - linux-lts-headers was missing even though you (presumably) were using linux-lts.

    So @developers, how about installing also linux-lts-headers whenever linux-lts is installed? That would be in-line with how linux-headers are currently. Actually, linux-lts-headers is (or at least was) required in VirtualBox VM if using linux-lts kernel.

  • @manuel said in Wifi Not working:

    So @developers, how about installing also linux-lts-headers whenever linux-lts is installed?

    This could be done in Cnchi, but once system is installed we can’t modify dependencies of existing Arch packages.

  • @karasu
    How is it done with linux and linux-headers? They seem to go together…
    Probably comes from Arch somehow?
    EDIT: sorry, its obvious what you said, I read it too quickly…
    But anyway, cnchi would be ok for me :)

  • @karasu
    I used to have a similar problem with VMs, I wasn’t able to use linux-lts there until I realized linux-lts-headers is required.
    So in cnchi, if linux-lts is selected by the user, then it would be good to install also linux-lts-headers.

  • @karasu
    How about creating an Antergos meta-package that installs both linux-lts and linux-lts-headers?
    It could be named something like linux-lts-and-headers or whatever that describes it properly?

wifi90 Posts 19Views 251
Log in to reply