• Problema al actualizar


    [[email protected] ~]$ sudo pacman -Syu
    :: Sincronizando las bases de datos de los paquetes…
    antergos está actualizado
    core está actualizado
    extra está actualizado
    community está actualizado
    multilib está actualizado
    :: Iniciando actualización completa del sistema…
    error: no se pudo abrir el archivo /var/lib/pacman/local/libsoup-2.60.1-1/desc: No existe el fichero o el directorio
    advertencia: pepper-flash: la versión instalada (1:26.0.0.137-1) es más nueva que extra (27.0.0.183-1)
    :: ¿Remplazar rfkill con core/util-linux? [S/n] s
    resolviendo dependencias…
    buscando conflictos entre paquetes…
    advertencia: no se pudieron cargar completamente los metadatos para el paquete libsoup-2.60.1-1
    error: no se pudo preparar la operación (paquete no válido o dañado)

    Este es el error que me da al intentar actualizar. ¿Cual podria ser la solución?

    Gracias.

  • @davidrobertohernandez !

    Puedes traducir este respuesta, yo lo hago con Chromium, que es el que utilizo para entender un poco mejor lo escrito en inglés.

    La respuesta sería hacer un --force en pacman, cual significa sobreescribir todos los archivos, pero es una desición personal … tal como dice mi compañero @just en ese link que te he pasado.

  • @davidrobertohernandez

    Hola:

    Te falta esa librería libsoup , vamos a ver si es cierto:

    sudo pacman -S libsoup
    

    Y vuelves a actualizar .

    Si pasas ese punto , el segundo que es la advertencia solo te indica que el paquete pepper-flash es más nuevo por la forma en que el repo de antergos guarda ese archivo , estaría bien que el “mantenedor” del repositorio cambiara la nomenclatura , en todo caso despreocúpate , cuando el repo de Antergos actualice el paquete ya lo realizará.

    Por último a la pregunta de reemplazar frkill por util-linux , contestas que si y adelante.

    Saludos.

  • Al intentar instalar libsoup, me genera el mismo error. Y aunque intente actualizar con --force, pasa lo mismo, da el mismo error :/

  • @davidrobertohernandez said in Problema al actualizar:

    error: no se pudo abrir el archivo /var/lib/pacman/local/libsoup-2.60.1-1/desc: No existe el fichero o el directorio

    Si no existe el fichero o directorio, lo borraria para que no me de problemas, luego podría instalarlo cuando quisiera, entonces haría:

    sudo -r /var/lib/pacman/local/libsoup-2.60.1-1

    y después volvería a actualizar con

    sudo pacman -Syyu

    Por favor, informanos como fué

    ?

actualizar11 problema16 Posts 5Views 145
Log in to reply