• "Wifi Adapter is not connected"?


    Hey what’s up everyone,I have installed antergos few times in recent weeks and had no problem with it, except DaVinci not being able to get installed, until Apple released a new update and broke the dual boot system of mine, which was not really well put together in the first place, anyway.
    When I tried to reinstall antegos, I saw that wifi was not working, I tried everything to make it work, anything…installing broadcom driver…trying to set up network manager…any single possible way that I found…my problem is not even found on internet…
    The problem is that it says my Wifi Adapter is not connected…and when I use this command “ip link” it only shows 2 options not the third one which is my wifi…But everything works fine in Manjaro…whats going on? Can you please help me with this… I could not even remove the kernel and use lts kernel in case if this is caused by new kernel…
    Again this was not the case 10 days ago it is new…I don’t like Manjaro would you please help me on this?

  • @TheNameless

    Since it does not work ip link, the return of console gives us the output

    $ iwconfig

    $ lspci -vnn | grep -i net

    $ systemctl --state=active | grep net

  • @TheNameless
    Without you giving more information about your hardware it is somewhat impossible to help you.

  • Its a late 2011 Macbook pro, the base model… tired and sick and old :D, I have to reinstall antergos to check your commadn, I have to get rid of Manjaro first.

  • @TheNameless
    Don’t lose Manjaro just yet! Manjaro can also give lots of good information about your hardware in order for anybody to help you.

  • Okay, just tell me what you guys need that I have to check in Majaro…I don’t think those pages can help this subject at all.Tell me what you need that I must do in Majaro.

  • @TheNameless
    And what makes you believe those links can’t help you?

  • @manuel I believe its a kernel problem, you know…Kernel is like bios but in software department, not being able to know wifi adapter just tells me its the kernel,knowing the hardware in depth cannot help that much IMO,BTW as I mentioned I was not able to remove kernel after switching to lts kernel.It is certainly a problem from antergos side.

  • @TheNameless
    Alright, good luck with your beliefs. ;)

  • @manuel said in "Wifi Adapter is not connected"?:

    @TheNameless
    Alright, good luck with your beliefs. ;)

    +1

  • Now instead of helping me, you guys are attacking me :)? The norm of all forums… WHAT DOES KNOWING MY HARDWARE AT THIS POINT DO? When I HAVE installed the freaking driver already and it has not worked? The problem with people like you is not that you are brutal and ugly in the way you speak to others instead of helping, its that you know nothing! Only normal persecutors, do that do this and this,It is the biggest problem with all Linux communities, instead of helping others try to push them figure it out by themselves…Why am I here then? If you want to keep posting none-sense and pages of my stupid hardware to me?Didn’t I give the model of my Laptop?
    I want to know if antergos is made by people like you so that I avoid it and tell everyone to do so!
    LEARN HOW TO TREAT PEOPLE INSTEAD TALKING NONE SENSE AS GENERATION Z LOVES TO DO AND PET EACH OTHER ON BACK!
    @ JuDD Whats wrong with you sending the link of this exact post? I want to be nice with people like you and stay as far as I can from these stupid arguments…
    I ONLY NEEDED A HELP AND INSTEAD OF HELP YOU DO THIS? THANKS FOR THE HELP! I WAIT UNTIL SOME GROWN UP COMES ALONG AND SAY SOMETHING!
    THANKS! GOD BLESS YOU! BUT GROW UP!

  • @TheNameless
    Please don’t insult people who actually were trying to help you.
    If you want help, then you must be prepared to give the information that is needed to solve the problem. Shouting, insulting and aggressive behaviour won’t get you any help. And please remember that none of your helpers are getting paid to do that, they do it as their hobby or whatever reason they may have.
    So either be prepared to give the information, or go to some other place to get help.

  • Stop twisting the truth here, I see what you are doing, you asked me about my hardware , I gave you the exact model of my laptop…but you forced me again by giving me pages about my hardware again …hello!

  • @TheNameless
    So did you try any of the suggestions behind the links? If you did or did not, please tell us that, so nobody will need give you those links again.

  • The only way this website is presenting is not having network manager installed…It does NOT say what to do when the Wifi Adapter is not even connected, thats what I have mentioned in the beginning…Thats the whole point.

  • @TheNameless
    What do you mean by not being able to remove linux and install linux-lts? What was the error message? Could you show some information about that?
    Are you going to give answers to the commands judd presented?
    Probably most of us do not have late 2011 MacBook Pro, and as you told us, your “problem is not even found on internet”. So where do you think we could find more info than you?

    Now Manjaro and Antergos/Arch have different kernels. That may be a reason why Manjaro works and Antergos/Arch doesn’t, in your particular case. But wait and see, things may be the other way around in the near future…

  • I don’t know it either, you told me hold on Manjaro, thats why I have not done anything yet, I’m gonna install antergos right now and check those commands which Judd gave me.But as you mentioned Manjaro uses different Kernel and that MIGHT be the reason all this is happening, IDK…
    After installation of antergos I’m gonna come back with results of Judd’s suggestions and the error which system gives me when I’m deleting the up to date kernel while I’m changing to LTS kenrnel,thanks for your help! And sorry for getting angry…

  • @judd said in "Wifi Adapter is not connected"?:

    @TheNameless

    Since it does not work ip link, the return of console gives us the output

    $ iwconfig

    $ lspci -vnn | grep -i net

    $ systemctl --state=active | grep net
    The answer to the first command is this

    enp2s0f0 no wireless extensions.

    lo no wireless extensions.
    And the second command is this

    02:00.0 Ethernet controller [0200]: Broadcom Limited NetXtreme BCM57765 Gigabit Ethernet PCIe [14e4:16b4] (rev 10)
    Subsystem: Broadcom Limited NetXtreme BCM57765 Gigabit Ethernet PCIe [14e4:16b4]
    03:00.0 Network controller [0280]: Broadcom Limited BCM4331 802.11a/b/g/n [14e4:4331] (rev 02)

    and the third one is this

    sys-devices-pci0000:00-0000:00:1c.0-0000:02:00.0-net-enp2s0f0.device loaded active plugged NetXtreme BCM57765 Gigabit Ethernet PCIe
    sys-subsystem-net-devices-enp2s0f0.device loaded active plugged NetXtreme BCM57765 Gigabit Ethernet PCIe
    network.target loaded active active Network

    After a fresh install ( downgrade of Macintosh and reinstalling antergos ) the problem still exists!

adapter8 wifi90 connected5 Posts 22Views 389
Log in to reply