• SE "congela" la conexion


    Ayer se paró solo una vez mirando un video de Youtube con el firefox y tuve que reiniciar. Pero no lo ha hecho más. De momento todo correcto. Pero quiero darle más tiempo, por eso no doy el tema como solucionado. Si de aqui 4 o 5 dias no me falla más marco como solucionado.
    Además se va actualizando muy a menudo el kernel, igual va por ahi el fallo también, no se…

  • @Jordi_S.
    Does the problem happen with linux-lts kernel?
    ¿El problema ocurre con linux-lts kernel?

  • No, es el 4.13.12-1-ARCH, no lo he probado con el LTS. Pero ya digo que ahora va muy bien.

  • Bueno, esto funciona genial. Ya no se ha parado ni un momento más ni ha hecho más cosas raras. Tema solucionado.
    Muchas gracias!

  • Nada, si lo se no lo escribo. Ahora me ha fallado dos veces seguidas, hasta ahora no lo habia hecho…en fin. Hay algun comando para buscar algun error cuando hace eso? Quiero seguir investigando…si estuviera en Windows le echaria la culpa a un virus jeje
    La segunda vez ni desconectando y volviendo a conectar se ha conectado de nuevo, he tenido que reiniciar…es el tipico “busy” que he visto por ahi en programas o cosas asi, no se…

  • @Jordi_S.
    Maybe this helps to investigate:

    journalctl -b
    
  • Con esta oren no parece haber ningun error. Todo se carga correctamente. La parte del NetworkManager está todo correcto (creo). Las partes que veo “raras” son estas:

    nov 20 10:47:30 AMD NetworkManager[453]: <info>  [1511171250.3169] device (enp2s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
    nov 20 10:47:30 AMD NetworkManager[453]: <info>  [1511171250.3691] ovsdb: No se pudo conectar: No existe el fichero o el directorio
    nov 20 10:47:31 AMD NetworkManager[453]: <info>  [1511171251.6566] device (enp2s0): state change: unavailable -> disconnected (reason 'carrier-changed', sys-iface-state: 'managed')
    nov 20 10:47:31 AMD NetworkManager[453]: <info>  [1511171251.6574] policy: auto-activating connection 'Conexión cableada 1'
    nov 20 10:47:31 AMD NetworkManager[453]: <info>  [1511171251.6633] device (enp2s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
    nov 20 10:47:31 AMD NetworkManager[453]: <info>  [1511171251.6692] device (enp2s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
    nov 20 10:47:31 AMD NetworkManager[453]: <info>  [1511171251.6714] device (enp2s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
    nov 20 10:47:31 AMD NetworkManager[453]: <info>  [1511171251.7300] dhcp4 (enp2s0): state changed unknown -> bound
    

    Pero al final:

    nov 20 10:47:31 AMD NetworkManager[453]: <info>  [1511171251.7375] manager: NetworkManager state is now CONNECTED_LOCAL
    nov 20 10:47:31 AMD NetworkManager[453]: <info>  [1511171251.7455] manager: NetworkManager state is now CONNECTED_SITE
    nov 20 10:47:31 AMD NetworkManager[453]: <info>  [1511171251.7456] policy: set 'Conexión cableada 1' (enp2s0) as default for IPv4 routing and DNS
    nov 20 10:47:31 AMD NetworkManager[453]: <info>  [1511171251.7457] dns-mgr: Writing DNS information to /usr/bin/resolvconf
    nov 20 10:47:31 AMD NetworkManager[453]: <info>  [1511171251.8689] device (enp2s0): Activation: successful, device activated.
    nov 20 10:47:31 AMD NetworkManager[453]: <info>  [1511171251.8703] manager: startup complete
    nov 20 10:47:33 AMD NetworkManager[453]: <info>  [1511171253.1096] manager: NetworkManager state is now CONNECTED_GLOBAL
    
  • journalctl -p 3 -xb -1
    systemctl --state=active | grep dhcpcd
    systemctl list-units | grep -iE 'net|dhc'

    ?

  • Esto es lo que me da ahora, cuando falle lo hago de nuevo todo:

    journalctl -p 4 -xb -l:
    
    -- Logs begin at Tue 2017-02-28 17:30:09 CET, end at Mon 2017-11-20 16:15:24 CET. --
    nov 20 15:04:16 AMD kernel: [Firmware Bug]: AMD-Vi: IOAPIC[0] not in IVRS table
    nov 20 15:04:16 AMD kernel: [Firmware Bug]: AMD-Vi: No southbridge IOAPIC found
    nov 20 15:04:16 AMD kernel: AMD-Vi: Disabling interrupt remapping
    nov 20 15:04:17 AMD kernel: sp5100_tco: I/O address 0x0cd6 already in use
    
    systemctl --state:
    dhcpcd.service        loaded active running   dhcpcd on all interfaces  
    
    systemctl list-units:
    sys-devices-pci0000:00-0000:00:04.0-0000:02:00.0-net-enp2s0.device                       loaded active plugged   RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller              
    sys-subsystem-net-devices-enp2s0.device                                                  loaded active plugged   RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller              
    dhcpcd.service                                                                           loaded active running   dhcpcd on all interfaces                                               
    NetworkManager-wait-online.service                                                       loaded active exited    Network Manager Wait Online                                            
    NetworkManager.service                                                                   loaded active running   Network Manager                                                        
    systemd-timesyncd.service                                                                loaded active running   Network Time Synchronization                                           
    ufw.service                                                                              loaded active exited    CLI Netfilter Manager                                                  
    wicd.service                                                                             loaded active running   Wicd a wireless and wired network manager for Linux                    
    network-online.target                                                                    loaded active active    Network is Online                                                      
    network.target                                                                           loaded active active    Network                                                                
    
    
  • @Jordi_S.

    No veo nada incorrecto en tu conección.

    Ahi alguna posibilidad que tu proveedor de internet tenga fallas intermitentes ???

    Por otro lado necesito que me pases los resultados de los comandos, tal y como te los doy, de lo contrario se hace dificil ayudarte.

  • Los resultados de los comandos estan tal cual menos la orden, que la he escrito yo, ya que he mandado los resultados a archivo, que es más cómodo hacer un cortar-pegar.
    Veo que aun está por ahí cargado el wait-online, como lo hago para quitarlo completamente y que no lo cargue?? No lo encuentro. He probado un mask y sigue apareciendo en systemd…
    Puede ser el proveedor, o el PLC, pero ha mejorado muchisimo la cosa con esto que me has ido recomendando hacer, asi que es difícil eso…

  • @Jordi_S. said in SE "congela" la conexion:

    Veo que aun está por ahí cargado el wait-online, como lo hago para quitarlo completamente y que no lo cargue??

    sudo su si es en una tty (Crtl+Alt+F2, F3…)aparte mejor
    systemctl stop NetworkManager-wait-online.service y luego
    systemctl disable NetworkManager-wait-online.servicey reinicia a ver que tal …

  • Ya lo he hecho, estos comandos no eliminan el servicio. El sistema lo carga igualmente y luego lo para.
    Este servicio lo veo en /usr/lib/systemd/systemd-networkd-wait-online. Puedo eliminar el archivo asi tal cual y ya esta? O petara todo?

    – edit –

    Bueno ahora se ha parado y he mirado esos comandos, dan lo mismo que ya puse por ahi.

  • @Jordi_S. said in SE "congela" la conexion:

    Este servicio lo veo en /usr/lib/systemd/systemd-networkd-wait-online. Puedo eliminar el archivo asi tal cual y ya esta?

    sudo -r /usr/lib/systemd/systemd-networkd-wait-online elimínalo y no creo que pueda romper nada, de lo contrario, se instala de nuevo y ya.

    ?

Posts 34Views 375
Log in to reply