• Error when generating a xorg.conf


    [    88.198] 
    X.Org X Server 1.19.5
    Release Date: 2017-10-12
    [    88.198] X Protocol Version 11, Revision 0
    [    88.198] Build Operating System: Linux 4.9.54-1-lts x86_64 
    [    88.198] Current Operating System: Linux Julian-PC 4.13.11-1-ARCH #1 SMP PREEMPT Thu Nov 2 10:25:56 CET 2017 x86_64
    [    88.198] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=303e9986-02fc-47ff-917c-0ae5c263dc94 rw quiet
    [    88.198] Build Date: 12 October 2017  09:59:53PM
    [    88.198]  
    [    88.198] Current version of pixman: 0.34.0
    [    88.198] 	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    [    88.198] Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [    88.198] (==) Log file: "/var/log/Xorg.1.log", Time: Sat Nov  4 11:49:44 2017
    [    88.198] (II) Loader magic: 0x555f06dced60
    [    88.198] (II) Module ABI versions:
    [    88.198] 	X.Org ANSI C Emulation: 0.4
    [    88.198] 	X.Org Video Driver: 23.0
    [    88.198] 	X.Org XInput driver : 24.1
    [    88.198] 	X.Org Server Extension : 10.0
    [    88.198] (--) using VT number 1
    
    [    88.198] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
    [    88.199] (II) xfree86: Adding drm device (/dev/dri/card0)
    [    88.199] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
    [    88.200] (--) PCI:*(0:1:0:0) 1002:67ef:1462:809d rev 207, Mem @ 0xd0000000/268435456, 0xe0000000/2097152, 0xefe00000/262144, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
    [    88.208] List of video drivers:
    [    88.208] 	vesa
    [    88.208] 	fbdev
    [    88.208] 	modesetting
    [    88.208] 	amdgpu
    [    88.208] (II) LoadModule: "vesa"
    [    88.209] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    [    88.209] (II) Module vesa: vendor="X.Org Foundation"
    [    88.209] 	compiled for 1.19.3, module version = 2.3.4
    [    88.209] 	Module class: X.Org Video Driver
    [    88.209] 	ABI class: X.Org Video Driver, version 23.0
    [    88.209] (II) LoadModule: "fbdev"
    [    88.209] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    [    88.209] (II) Module fbdev: vendor="X.Org Foundation"
    [    88.209] 	compiled for 1.19.3, module version = 0.4.4
    [    88.209] 	Module class: X.Org Video Driver
    [    88.209] 	ABI class: X.Org Video Driver, version 23.0
    [    88.209] (II) LoadModule: "modesetting"
    [    88.209] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
    [    88.209] (II) Module modesetting: vendor="X.Org Foundation"
    [    88.209] 	compiled for 1.19.5, module version = 1.19.5
    [    88.209] 	Module class: X.Org Video Driver
    [    88.209] 	ABI class: X.Org Video Driver, version 23.0
    [    88.209] (II) LoadModule: "amdgpu"
    [    88.209] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
    [    88.210] (II) Module amdgpu: vendor="X.Org Foundation"
    [    88.210] 	compiled for 1.19.3, module version = 1.4.0
    [    88.210] 	Module class: X.Org Video Driver
    [    88.210] 	ABI class: X.Org Video Driver, version 23.0
    [    88.210] (II) VESA: driver for VESA chipsets: vesa
    [    88.210] (II) FBDEV: driver for framebuffer: fbdev
    [    88.210] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [    88.210] (II) AMDGPU: Driver for AMD Radeon:
    	All GPUs supported by the amdgpu kernel driver
    [    88.290] (++) Using config file: "/root/xorg.conf.new"
    [    88.290] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [    88.291] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [    88.291] (==) ServerLayout "X.org Configured"
    [    88.291] (**) |-->Screen "Screen0" (0)
    [    88.291] (**) |   |-->Monitor "Monitor0"
    [    88.291] (**) |   |-->Device "Card0"
    [    88.291] (**) |-->Screen "Screen1" (1)
    [    88.291] (**) |   |-->Monitor "Monitor1"
    [    88.291] (**) |   |-->Device "Card1"
    [    88.291] (**) |-->Input Device "Mouse0"
    [    88.291] (**) |-->Input Device "Keyboard0"
    [    88.291] (**) Option "DontZap" "false"
    [    88.291] (==) Automatically adding devices
    [    88.291] (==) Automatically enabling devices
    [    88.291] (==) Automatically adding GPU devices
    [    88.291] (==) Automatically binding GPU devices
    [    88.291] (==) Max clients allowed: 256, resource mask: 0x1fffff
    [    88.292] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
    [    88.292] 	Entry deleted from font path.
    [    88.292] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
    [    88.292] 	Entry deleted from font path.
    [    88.292] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
    [    88.292] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
    [    88.292] 	Entry deleted from font path.
    [    88.292] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
    [    88.292] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
    [    88.292] 	Entry deleted from font path.
    [    88.292] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
    [    88.292] 	Entry deleted from font path.
    [    88.292] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
    [    88.292] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
    [    88.292] 	Entry deleted from font path.
    [    88.292] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
    [    88.292] (**) FontPath set to:
    	/usr/share/fonts/misc/,
    	/usr/share/fonts/TTF/,
    	/usr/share/fonts/OTF/,
    	/usr/share/fonts/misc/,
    	/usr/share/fonts/TTF/,
    	/usr/share/fonts/OTF/
    [    88.292] (**) ModulePath set to "/usr/lib/xorg/modules"
    [    88.292] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
    [    88.292] (WW) Disabling Mouse0
    [    88.292] (WW) Disabling Keyboard0
    [    88.292] (II) [KMS] drm report modesetting isn't supported.
    [    88.292] (EE) 
    [    88.292] (EE) Backtrace:
    [    88.302] (EE) 0: /usr/lib/xorg-server/Xorg (OsLookupColor+0x139) [0x555f06b4aee9]
    [    88.303] (EE) 1: /usr/lib/libpthread.so.0 (funlockfile+0x50) [0x7fea75d24def]
    [    88.303] (EE) 2: ? (?+0x50) [0x50]
    [    88.303] (EE) 
    [    88.303] (EE) Segmentation fault at address 0x0
    [    88.303] (EE) 
    Fatal server error:
    [    88.303] (EE) Caught signal 11 (Segmentation fault). Server aborting
    [    88.303] (EE) 
    [    88.303] (EE) 
    Please consult the The X.Org Foundation support 
    	 at http://wiki.x.org
     for help. 
    [    88.303] (EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.
    [    88.303] (EE) 
    [    88.304] (EE) Server terminated with error (1). Closing log file.
    
  • @s9209122222 said in Error when generating a xorg.conf:

    /var/log/Xorg.1.log

    lspci > log.txt && lsusb >> log.txt && dmesg >> log.txt && pastebinit -i log.txt -b lpaste.net
    

    And if you have the time try to discribe wy and what exactly do you do and try to do…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • the errors:

    [    88.292] (EE) 
    [    88.292] (EE) Backtrace:
    [    88.302] (EE) 0: /usr/lib/xorg-server/Xorg (OsLookupColor+0x139) [0x555f06b4aee9]
    [    88.303] (EE) 1: /usr/lib/libpthread.so.0 (funlockfile+0x50) [0x7fea75d24def]
    [    88.303] (EE) 2: ? (?+0x50) [0x50]
    [    88.303] (EE) 
    [    88.303] (EE) Segmentation fault at address 0x0
    [    88.303] (EE) 
    Fatal server error:
    [    88.303] (EE) Caught signal 11 (Segmentation fault). Server aborting
    [    88.303] (EE) 
    [    88.303] (EE) 
    Please consult the The X.Org Foundation support 
    	 at http://wiki.x.org
     for help. 
    [    88.303] (EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.
    [    88.303] (EE) 
    [    88.304] (EE) Server terminated with error (1). Closing log file.
    

    Caught signal 11 (Segmentation fault). Server aborting ==>https://bbs.archlinux.org/viewtopic.php?id=230607

    [ 88.303] (EE) Caught signal 11 (Segmentation fault). Server aborting
    https://bbs.archlinux.org/viewtopic.php?id=208252

    ¿ “intel_iommu = off” ?

  • amdgpu not intel here…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad said in Error when generating a xorg.conf:

    amdgpu not intel here…

    Bad me, you’re right !!! ==>[ 88.210] (II) AMDGPU: Driver for AMD Radeon: All GPUs supported by the amdgpu kernel driver

    I have not read well, I hurried too … :)https://bbs.archlinux.org/viewtopic.php?id=229332

  • first of all there is no need for a xorg.conf to run X it is only usefull for enhancements inside:

    If you want manual configuration, create /etc/X11/xorg.conf.d/20-amdgpu.conf, and add the following:

    Section "Device"
        Identifier "AMD"
        Driver "amdgpu"
    EndSection
    

    So first i would try to remove /etc/X11/xorg.conf and start system without it.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad I need to add the new modeline to display 72hz for my monitor, 20-amdgpu.conf can’t do it
    It is how I do it:

    sudo Xorg :1 -configure
    
  • with /etc/X11/xorg.conf.d/21-amd-monitor.conf you can add just the monitor section and no need for the whole xorg.conf

    and what is about xrandr ? should be able to handle this too?

    xrandr                                                                                                                                      130 ↵
    Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
    VGA-0 disconnected primary (normal left inverted right x axis y axis)
    DVI-D-0 disconnected (normal left inverted right x axis y axis)
    HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 299mm
       1920x1080     60.00*+  60.00    59.94    50.00    60.05    60.00    50.04  
       1680x1050     59.95  
       1600x900      60.00  
       1280x1024     75.02    60.02  
       1280x960      60.00  
       1280x720      60.00    59.94    50.00  
       1152x720      60.00  
       1024x768      75.03    60.00  
       800x600       75.00    60.32  
       720x576       50.00  
       720x480       59.94  
       640x480       75.00    59.94    59.93
    

    xrandr --output HDMI-0 --mode 1920x1080 --rate 60

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad I need 72hz not 60hz, only xorg.conf can remember the setting after reboot.

  • @s9209122222 yes i was giving you my settings… taking from what i got from xrandr…

    you can do it like this:


    Permanently adding undetected resolutions
    Once a suitable resolution is found using xrandr, the mode can be permanently added by creating an entry in /etc/X11/xorg.conf.d/:

    create:
    /etc/X11/xorg.conf.d/10-monitor.conf

    Section "Monitor"
        Identifier "VGA1"
        Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
        Option "PreferredMode" "1280x1024_60.00"
    EndSection
    
    Section "Screen"
        Identifier "Screen0"
        Monitor "VGA1"
        DefaultDepth 24
        SubSection "Display"
            Modes "1280x1024_60.00"
        EndSubSection
    EndSection
    
    Section "Device"
        Identifier "Device0"
        Driver "intel"
    EndSection
    

    Replace intel with the right driver, e.g. nvidia. When the X server is restarted, you should be able to set the new resolution.

    If this doesn’t work for you, try removing the Screen and Device sections and just leaving the Monitor section.


    source: https://wiki.archlinux.org/index.php/Xrandr#Permanently_adding_undetected_resolutions

    You will need to change names and settings to what you need for your system !!!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • @joekamprad It works, thanks.

xorg.conf1 generating1 error198 Posts 11Views 247
Log in to reply