Specs first,
Hardware: Surface Pro 3, i5, 4GB RAM, 128GB drive
OS: Antergos /w KDE updated fully minutes ago
Extra stuff: btrfs file sys, 5GB swap partition, seperate root and home partitions, etc.

I read on the arch wiki that btrfs doesn’t support swap files so I am good there, but I should be able to suspend in some capacity to ram or any of the states, but none of them work. I’ve tried suspend-to-ram, and hibernation.

I attempted to suspend-to-ram and then turn it back on and the computer screen stays black and shows no signs of life other than that I have to hold my power button for 10 seconds to force shuttoff the device which tells me it is on… And the lights on my keyboard are still on if I keep them on which is as expected since it’s only a basic suspend.

When I hibernate, the computer does turn off and stuff like I expect but the same problem happens where the computer seems to power on but the computer never really comes back and stays black. No flashing or or anything in either case. The back light stays off in both cases so there’s no sense that it is even half way on or something.

I remember maybe a few months ago that standby used to work in the 4.12 days I think, and hibernation “worked” but wifi would remain off and messed up until I had to reboot. I didn’t use my laptop much during the 4.11/12/13 transition much so I don’t know where this function stopped working, so thanks for any help and let me know what else I need to show to help maybe fix this issue or maybe issue a bug report, thanks!

I’ve tried to attach my logs but I don’t have permission to apparently, so maybe another way I can would be appreciated.